Welcome to the North American Subaru Impreza Owners Club Friday July 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-27-2001, 08:16 AM   #1
chuglobal
Scooby Specialist
 
Member#: 10041
Join Date: Sep 2001
Location: Marietta, Ga.
Vehicle:
2015 WRX Limited CVT
ISM

Default OE Suspension

I did a search on "suspension" in the warranty section and did not come up with anything useful so here's my previous post under the suspension area ...

"I noticed yesterday for the first time while driving that if I'm corning slowly I get this creaky noise. I never noticed it before until yesterday ... I have 3100+ miles on my WRX and have not yet abused it. I heard that this is a common problem with the WRX, is this true? What can I do to shut it up? I heard even high end aftermarket suspension ( DMS ) will also have the same problem, is that true? The creaking sound makes the car sound cheap ... I would like to get rid of it. Thanks."

I have heard the the sway bar bolts or bushings could be loose or springs have rotate and need to be lubed ... are these common issues on a 2002 WRX? Please help.
* Registered users of the site do not see these ads.
chuglobal is offline   Reply With Quote
Old 10-27-2001, 10:35 AM   #2
ANZAC_1915
Moderator
 
Member#: 456
Join Date: Oct 1999
Chapter/Region: NWIC
Location: Redmond, WA, USA
Vehicle:
2008 Forester XT
Steel Gray Metallic

Default

My old WRX did that. I think it was rear way bar bushes.
ANZAC_1915 is offline   Reply With Quote
Old 10-29-2001, 12:49 AM   #3
tt_ttf
Scooby Specialist
 
Member#: 4431
Join Date: Feb 2001
Chapter/Region: NWIC
Location: Lynnwood,WA,USA
Vehicle:
MY07 STi and '06 WRX
Urban Grey & WRC Blue

Default

I have a really annoying metalic clunk at lowe speed in the front left suspension. It comes and goes as you accelerate or brake and take load on/off the suspension. To me it sound like the rear end of the suspension arm where it attaches to the frame (going on looking at my alloy arms still in the box and where the noise sounds like it is comming from

I have it in for the dealer to look at it on Thursday
tt_ttf is offline   Reply With Quote
Old 10-29-2001, 10:46 AM   #4
chuglobal
Scooby Specialist
 
Member#: 10041
Join Date: Sep 2001
Location: Marietta, Ga.
Vehicle:
2015 WRX Limited CVT
ISM

Default Yo yo yo ...

The creaky problem on my OE suspension was solved this past Sat by Tom ... thanks. He determined right off that the area on the suspension where the spring rests on the cone area od the suspension was either dirty or dry. Tom sprayed some lube and the noise disappeared. The group of us went back to my place afterwards to wash our cars and I hosed all 4 suspension in the same area and there has yet been any noise. I like simple answers. Thanks Tom!
chuglobal is offline   Reply With Quote
Old 03-19-2002, 11:10 AM   #5
SnortWagon
Scooby Newbie
 
Member#: 14124
Join Date: Jan 2002
Location: Long Lake, MN
Vehicle:
2002 WRX Wagon
Silver

Default

tt_ttf:

Your problem sounds exactly like what I am experiencing right now. What did your dealer say or do?
SnortWagon is offline   Reply With Quote
Old 05-02-2002, 10:44 PM   #6
SJwrx
Scooby Specialist
 
Member#: 14970
Join Date: Feb 2002
Chapter/Region: BAIC
Location: San Jose, CA
Vehicle:
1997 GF8
multi

Default

Instead of Stevens Creek Subaru fixing it, they stiffed me. "We can't hear it". My A$$! When I corner my friend in other cars hear it, plus the WRX isn't the best on keeping road noise out of the car anyway.

Rich
SJwrx is offline   Reply With Quote
Old 05-02-2002, 11:59 PM   #7
fpa1974
Scooby Newbie
 
Member#: 15371
Join Date: Feb 2002
Location: Roswell, GA
Vehicle:
2002 WRX Sedan(gone)
Pearl Blue

Default Re: Yo yo yo ...

Quote:
Originally posted by chuglobal
The creaky problem on my OE suspension was solved this past Sat by Tom ... thanks. He determined right off that the area on the suspension where the spring rests on the cone area od the suspension was either dirty or dry. Tom sprayed some lube and the noise disappeared. The group of us went back to my place afterwards to wash our cars and I hosed all 4 suspension in the same area and there has yet been any noise. I like simple answers. Thanks Tom!
Sorry for not being able to make this evening.


Back to the point. I do have this noise on the front (both sides, left is worse) as well under same conditions as you. So did this solution really worked?

Florian
fpa1974 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Considering Spec C or other OE Suspension spoolinsuby Brakes, Steering & Suspension 8 12-16-2008 09:12 PM
FS: OE '04 STi suspension sciolist Suspension/Brakes/Handling 5 02-28-2007 04:35 PM
What OE suspensions fit a '95 LS? Siper2 Brakes, Steering & Suspension 12 06-05-2004 07:18 PM
OE Suspension chuglobal Brakes, Steering & Suspension 8 05-17-2002 05:32 PM
Anyone running 225/50/16's on OE RS wheels w/ lowered suspension? GTBGUY Brakes, Steering & Suspension 3 04-23-2001 09:24 AM


All times are GMT -4. The time now is 03:31 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.