Welcome to the North American Subaru Impreza Owners Club Monday December 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-28-2001, 10:44 PM   #1
jHughes
Scooby Newbie
 
Member#: 608
Join Date: Dec 1999
Location: Seattle, WA, USA
Unhappy cruise control is broken

My cruise control suddenly stopped working. One morning it just wouldn't work. Has this happened to anyone else? It seems like it should be some loose wire or disconnected hose or fuse...? anyone have any ideas or experience with this problem?

thanks
justin
* Registered users of the site do not see these ads.
jHughes is offline   Reply With Quote
Old 10-29-2001, 01:00 PM   #2
paulnose
Scooby Newbie
 
Member#: 4348
Join Date: Feb 2001
Location: Fairfield County, CT
Vehicle:
2001 2.5RS
Silverthorn

Default

My switch wasn't connected when they delivered the car to me. But that was it. Might want to try checking the fuse. Check the vacuum line to the cruise control unit, and check the switch on the dash.

You can always just take the cruise control out, only took me 10 minutes, but kinda defeats the purpose. (You need to take it out/relocate for turbo mod.)
paulnose is offline   Reply With Quote
Old 10-29-2001, 04:03 PM   #3
bluesubie
Scooby Guru
 
Member#: 767
Join Date: Jan 2000
Chapter/Region: Tri-State
Location: N.J.
Vehicle:
04 FXT

Lightbulb

Manual tranny?
Other than checking the fuse and vacuum hose, also check that the clutch pedal switch is working properly.

There is a plastic stopper covering a hole on the clutch pedal arm. If this plastic breaks or pops off, the switch that disengages the cruise when you press the clutch will always be on. The part is under $2.00.

Dennis
bluesubie is offline   Reply With Quote
Old 11-03-2001, 01:34 PM   #4
Muqeem
Scooby Newbie
 
Member#: 7299
Join Date: Jun 2001
Location: Joppatowne, MD
Vehicle:
2002 WRX Sedan
WR Blue

Smile Cruise control

I had the same problem as you did Justin. One day, my cruise control did not work and previous to that, it was working perfectly.

My buddy at the dealership looked at it and discovered that the plastic stopper on the clutch pedal arm was broken and was in fact not there anymore. He replaced the stopper and it has been fine since then.

Like Dennis mentioned, I suggest you look at that, if you have not already done so - that should be the problem.

Muqeem
Muqeem is offline   Reply With Quote
Old 11-03-2001, 02:13 PM   #5
paulnose
Scooby Newbie
 
Member#: 4348
Join Date: Feb 2001
Location: Fairfield County, CT
Vehicle:
2001 2.5RS
Silverthorn

Default

Oh, check your brake lights, read in another post that if your brakelights are out the cruise control wont work, not sure that this is true or not.
paulnose is offline   Reply With Quote
Old 11-03-2001, 04:42 PM   #6
HndaTch627
Scooby Guru
 
Member#: 6551
Join Date: May 2001
Chapter/Region: MWSOC
Location: Carol Stream, IL
Vehicle:
'01 GC8 Dinged STM
'09 Concours 14 ABS Black

Default

this refers to the brake light switch not operating which is true. If the brake light switch or clutch pedal switch has gone bad your cruise control will not operate.

jeremy
HndaTch627 is offline   Reply With Quote
Old 11-07-2001, 11:23 AM   #7
DuneHopper
Scooby Newbie
 
Member#: 1249
Join Date: Apr 2000
Location: Newark, DE USA
Vehicle:
2000 OBS
White

Default

Yup, mine crapped out, too. Still under warranty, though.
DuneHopper is offline   Reply With Quote
Old 11-07-2001, 11:32 AM   #8
bluesubie
Scooby Guru
 
Member#: 767
Join Date: Jan 2000
Chapter/Region: Tri-State
Location: N.J.
Vehicle:
04 FXT

Question Stopper

Regarding the stopper and switch.
Wouldn't it make more sense not to have a hole in the clutch pedal arm in the first place?
Maybe just have the switch in direct contact with the pedal arm? Or would that not be good for the switch?

Dennis
bluesubie is offline   Reply With Quote
Old 11-09-2001, 01:39 PM   #9
OBS Fan
Scooby Newbie
 
Member#: 9751
Join Date: Aug 2001
Location: New Hampshire
Default

I'm having the same problem (97 OBS). Can anybody give more detail or where to find the vacuum line that might be disconnected on a 2.2L? Would the plastic stopper on the clutch pedal be white plastic? I found it on my floormat the other day. I thought it was only a bumper stop for the pedal arm, so I ignored it. Any further description on where to look for the clutch pedal switch? Can I disengage this switch?

Do check your fuses, on the 97 OBS (and probably RS) the cruise control fuse is also for ABS. So, if your cruise is out, your ABS could be out too.

Thanks for the info everybody.

-OBS Fan
OBS Fan is offline   Reply With Quote
Old 08-23-2008, 10:29 PM   #10
compleckz
Scooby Newbie
 
Member#: 145989
Join Date: Apr 2007
Chapter/Region: NESIC
Location: Charlemont, MA
Vehicle:
1998 Impreza L
White

Default

back from the dead, my cruise hasnt been working for 3 months (98 2.2), and the clutch pedal stopper thing was my problem. i stuck a small screw in the hole and all is well. that hole is the stupidest thing ever though. will be getting the right part on monday

thanks
compleckz is offline   Reply With Quote
Old 08-25-2008, 10:15 AM   #11
MrH
Scooby Newbie
 
Member#: 186279
Join Date: Aug 2008
Location: Phila, PA
Vehicle:
2000 2.5RS
Blue Ridge Pearl

Default

Quote:
Originally Posted by Muqeem View Post
I had the same problem as you did Justin. One day, my cruise control did not work and previous to that, it was working perfectly.

My buddy at the dealership looked at it and discovered that the plastic stopper on the clutch pedal arm was broken and was in fact not there anymore. He replaced the stopper and it has been fine since then.

Like Dennis mentioned, I suggest you look at that, if you have not already done so - that should be the problem.

Muqeem
Yep. It just happend to me too. I found the stopper laying on the floor right when the cruise control stopped working. I end up buying a carpet fastener. Now it works.
MrH is offline   Reply With Quote
Old 08-25-2008, 10:32 AM   #12
winterparkmg
Scooby Newbie
 
Member#: 187656
Join Date: Aug 2008
Chapter/Region: SCIC
Location: San Diego
Vehicle:
2003 WRX
Black

Default

I have been searching for this answer for a long time!!! Will try the screw method and report back. I checked relays and cables. Count on a stupid screw/plug to break a cross-country essential component...
winterparkmg is offline   Reply With Quote
Old 08-25-2008, 08:56 PM   #13
winterparkmg
Scooby Newbie
 
Member#: 187656
Join Date: Aug 2008
Chapter/Region: SCIC
Location: San Diego
Vehicle:
2003 WRX
Black

Default

Put a wood screw in the hole, pointing toward the engine and called it good. Sure enough, cruise control works! I'm glad I was lazy and didn't pay someone a ton of money to do a "diagnostics check" on my cruise control. Thanks guys!
winterparkmg is offline   Reply With Quote
Old 08-27-2008, 02:33 PM   #14
mcarthurpaul
Scooby Newbie
 
Member#: 80144
Join Date: Jan 2005
Vehicle:
2004 wrx wagon
Blue

Default

I have had to fix my switch twice before, but the cruise control has stopped working again and the switch does not seem to be the problem. Do you have a pic of the plug on the clutch arm?
mcarthurpaul is offline   Reply With Quote
Old 11-02-2008, 09:05 PM   #15
jigga
Scooby Guru
 
Member#: 9960
Join Date: Sep 2001
Location: in bed...
Vehicle:
2002 Impreza WRX
WRBlue Perl

Default

bump... I'm having this issue also.. I found the plug but am unsure as to where exactly it goes...
jigga is offline   Reply With Quote
Old 11-03-2008, 01:01 AM   #16
BillJC
Scooby Specialist
 
Member#: 31002
Join Date: Dec 2002
Location: Sonoma, CA
Vehicle:
2002 WRX
Blue

Default

Can someone take a picture of the plug? My cruise stopped working a few months ago and I have been too busy to diagnose it. If I know what to look for, it would make things a little simpler for me.

Thanks,

Bill
BillJC is offline   Reply With Quote
Old 11-19-2008, 05:56 PM   #17
supersuby2
Scooby Newbie
 
Member#: 161678
Join Date: Oct 2007
Location: Marquette MI
Vehicle:
2002 wrx
white

Default

Bump for a pic.... my boss has a 2002 forester that the cruise quit working on and i think this may be the problem
supersuby2 is offline   Reply With Quote
Old 11-19-2008, 10:25 PM   #18
BillJC
Scooby Specialist
 
Member#: 31002
Join Date: Dec 2002
Location: Sonoma, CA
Vehicle:
2002 WRX
Blue

Default

I figured it out. Go and buy a " nylon plug from a hardware store. It fits in the hold on the clutch pedal. If you follow the pedal up, it's pretty obvious where it needs to go. There is a switch that just sits there if the plug is gone.

Bill
BillJC is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Broken Cruise Control, HELP BlueBerryRex Electrical & Lighting 3 03-12-2004 12:54 AM
Broken Cruise control! BlueBerryRex Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 1 03-11-2004 02:15 AM
cruise control problem / broken avatarr Electrical & Lighting 1 10-10-2003 11:10 AM
Broken Cruise control, horn, and probably airbag rs-scooby Service & Maintenance 3 10-05-2003 12:04 PM
Broken Cruise control, horn, and probably airbag rs-scooby Tri-State Area Forum 4 10-04-2003 09:28 PM


All times are GMT -4. The time now is 06:06 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.