Welcome to the North American Subaru Impreza Owners Club Friday October 28, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Old 08-29-2006, 12:07 AM   #1
Scooby Newbie
Member#: 72021
Join Date: Oct 2004
Location: BARBADOS

Default Cel On - Code 54

I own a JDM 1999 Impreza. This evening coming home the "check engine" light came on and, first it was intermitently coming on and going off and then at one point the light came on and it remained. The symptoms of the car while driving was that even although the accelerator pedal was halfway down to the floor, the car would not go over 60 kmph.

I "jumpered" the black connectors when I got home and I got the following code:

54 - Air Inlet Line

However, the inlet manifold looks find to me and it doesn't sound like it has any leaks.

Can anyone help me.
* Registered users of the site do not see these ads.
Ramon_12345 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 08-29-2006, 10:13 PM   #2
Tim Sanderson
Scooby Guru
Member#: 6486
Join Date: May 2001
Chapter/Region: MWSOC
Location: S.E. wisconsin
00 Impreza 2.5 RS
Blue Ridge Pearl


Wow, try the conversions forum or the pre 02 turbo forum.
Tim Sanderson is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
washed engine bay, now car won't start CEL on pinoy_boy204 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 42 06-08-2010 09:12 AM
Need some help GUYs. CEL on 3 CODES 06bluebird Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 7 08-28-2009 12:26 PM
Need help please!!! Cel on won't read code landry1 AccessPort 3 07-28-2008 08:34 PM
CEL on but no code? spit_heron Service & Maintenance 11 09-29-2006 10:17 AM
CEL on, Cruise blinking, and NO CODE SpaldingSpeed Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 17 09-09-2005 07:09 PM

All times are GMT -4. The time now is 02:09 AM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.