Welcome to the North American Subaru Impreza Owners Club Friday September 4, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-29-2001, 03:15 PM   #1
Franco
Scooby Newbie
 
Member#: 10352
Join Date: Sep 2001
Vehicle:
2002 WRX
White

Default Weird Smell

I have roughly 2900 wiles on my WRX, got it in May. Its almost time for an oil change. I took off the intake silincer about 3 weeks ago. Just a couple of days ago, I popped my clutch and my car was turning bout 5000-6000 for 3-4 secs and barley hitting 25mph(the cluth was engaged). After that I backed off the throttle and it was running fine. When I turned off the car I noticed a buring smell comming from the engine compartment. Now, every time i run the car hard, that smell comes back. What is it? Its definately not burn clutch becuse I have experienced that many times learning before.
* Registered users of the site do not see these ads.
Franco is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-29-2001, 10:59 PM   #2
KKL
Scooby Newbie
 
Member#: 10220
Join Date: Sep 2001
Chapter/Region: VIC
Location: N49 13' W123 03'
Vehicle:
2010 STI
World Rally Blue Pearl

Unhappy Burn-in smell

I just stopped by my dealer's service center today to ask about the smell that's been eminating for the last week on my 2 month old (2000Km) baby. It starts right after the engine hits operating temperature and goes away after about 5 minutes. I don't know if I'm imagining it, but I could swear I see an occasional wisp of smoke coming out of the hood scope when this happens. A service rep took a look under the hood and couldn't find anything wrong. He then told me that they've had the ocassional car where it took 7000-8000 Km's for the various break-in smells to go away. My car's going in for it's first service (a post break-in special deal from my dealer) on Friday and they'll take a closer look then.

I'm figuring that it's because I'm starting to push the car harder now that it's broken in and I'm burning off more of the various coatings and stuff that are used to protect parts during shipping. A search of the forums here seem to confirm this as well.

Update: Took it in this AM for the oil change and they found a coolant leak, so I have to leave it for the day. Hopefully it's something silly like a loose clamp.

Last edited by KKL; 11-02-2001 at 02:01 PM.
KKL is offline   Reply With Quote
Old 10-30-2001, 05:48 PM   #3
kurichan
Scooby Newbie
 
Member#: 8282
Join Date: Jul 2001
Vehicle:
2002 WRX Sedan

Default

My car took 2500 miles to break in.
kurichan is offline   Reply With Quote
Old 10-30-2001, 05:50 PM   #4
kurichan
Scooby Newbie
 
Member#: 8282
Join Date: Jul 2001
Vehicle:
2002 WRX Sedan

Default

Allow me to expand: 2500 miles before the burning smell went away.
kurichan is offline   Reply With Quote
Old 10-30-2001, 09:05 PM   #5
T-WRX-02
Scooby Newbie
 
Member#: 8907
Join Date: Aug 2001
Location: Penn Hills, PA
Vehicle:
2002 Impreza WRX Sdn
WR Blue Pearl

Default

Have you checked under the hood for an expired cat. The tend to favor turbo'd cars during fall and early winter ... and they have a tendency to smell during hard driving.

Seriously, if its not a toasted clutch (it has a unique burned resin fragrance) it may be some wiring or hoses may have shifted against hot metal during your launch. Those soft rubber bushings and mounts will allow things to move around under the hood. If its an oily smell ... well thats not good. Hmmm.
T-WRX-02 is offline   Reply With Quote
Old 03-30-2002, 09:09 AM   #6
initialx
Scooby Newbie
 
Member#: 10007
Join Date: Sep 2001
Vehicle:
02 Impreza WRX

Default

Hi,

what does "expired" cat mean?


initial
initialx is offline   Reply With Quote
Old 03-30-2002, 12:30 PM   #7
WRXSTi69
Scooby Newbie
 
Member#: 12012
Join Date: Nov 2001
Default

Quote:
Originally posted by initialx
Hi,

what does "expired" cat mean?


initial
Not breathing. No signs of life. Dead.
He's talking about a dead feline, not a failed catalytic converter.
WRXSTi69 is offline   Reply With Quote
Old 03-30-2002, 07:47 PM   #8
relayer66
Scooby Newbie
 
Member#: 14614
Join Date: Jan 2002
Chapter/Region: SCIC
Location: San Diego, CA
Vehicle:
2002 WRX
Platinum Silver

Default

how do you usually launch? if you are slipping the clutch above 3 or 4k, you are probably smelling burnt clutch.
relayer66 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird Smell paul25RS Tri-State Area Forum 11 11-17-2003 11:05 PM
Weird Smell in my Car and Trunk! SpoonTypeR Vancouver Impreza Club Forum -- VIC 12 10-29-2003 03:39 PM
Weird Smell SubaruBen Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 2 10-12-2003 07:17 PM
weird smell boysetsfire Normally Aspirated with bolt-on Forced Induction Powertrain 4 08-31-2002 03:27 AM
weird smell in car: anyone else too??? rxed New England Impreza Club Forum -- NESIC 9 07-15-2002 11:45 PM


All times are GMT -4. The time now is 10:30 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.