Welcome to the North American Subaru Impreza Owners Club Friday November 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-31-2006, 02:06 AM   #1
BillMac
Scooby Newbie
 
Member#: 124593
Join Date: Aug 2006
Location: Ada.Ohio
Vehicle:
2007 Sti fp red
346whp 366wtq

Default My New 06 WRX

Yeah i just bought my 06 wrx about a month ago I am loving my first one. I was just wondering if there is a fuel cut off around a 100mph cause it seems that it just falls one its face after that it gains but very slowly. My car has a SPT intake on it and a Apexi N1 catback exhaust. I did try searhing first cause i did want to be lazy couldnt find anything. Please give what info u can!!
* Registered users of the site do not see these ads.
BillMac is offline   Reply With Quote
Old 08-31-2006, 02:24 AM   #2
some dude
Scooby Specialist
 
Member#: 100300
Join Date: Nov 2005
Chapter/Region: MWSOC
Location: MIC|-|IG/\N
Vehicle:
06 WRX
CGM

Default

I have a 06' WRX and it definately does not cutout at 100. I am not sure what top speed is limited to, but I have done a little over 125 in mine and it had more power in reserve.
some dude is offline   Reply With Quote
Old 08-31-2006, 02:34 AM   #3
BillMac
Scooby Newbie
 
Member#: 124593
Join Date: Aug 2006
Location: Ada.Ohio
Vehicle:
2007 Sti fp red
346whp 366wtq

Default

I dont know ive had mine up to 120mph but it just seems to me that it dies down alot after i hit 100mph
BillMac is offline   Reply With Quote
Old 08-31-2006, 02:37 AM   #4
06grayrex
Scooby Specialist
 
Member#: 116132
Join Date: May 2006
Location: stl
Vehicle:
2006 wrx tr Stage II
sgm Jorge tuned -RIP :(

Default

I have had my 06 rex about the same as some dude two days ago and no problems what so ever.....IMO it might be the intake messing with the MAF sensor/ maybe leaning it out???????? Did You reset the ecm after installing the Intake?
06grayrex is offline   Reply With Quote
Old 08-31-2006, 02:48 AM   #5
BillMac
Scooby Newbie
 
Member#: 124593
Join Date: Aug 2006
Location: Ada.Ohio
Vehicle:
2007 Sti fp red
346whp 366wtq

Default

it seemed to strugle after 100mph even when i first got it but after i put the shortram intake on i disconected the battery before i started then its started and idled fine i drove it down the street and it like started like surging around 4000rpm so i dove to my buddies shop and when i got there it didnt surge anymore
BillMac is offline   Reply With Quote
Old 08-31-2006, 02:53 AM   #6
06grayrex
Scooby Specialist
 
Member#: 116132
Join Date: May 2006
Location: stl
Vehicle:
2006 wrx tr Stage II
sgm Jorge tuned -RIP :(

Default

You also have to remember that the ecm has to relearn the new readings after you reset it. It may take a couple of hundred of miles to do so.
06grayrex is offline   Reply With Quote
Old 08-31-2006, 03:00 AM   #7
06grayrex
Scooby Specialist
 
Member#: 116132
Join Date: May 2006
Location: stl
Vehicle:
2006 wrx tr Stage II
sgm Jorge tuned -RIP :(

Default

You may want to consider purchasing EM (cobb ap or utech)...After installing Cobb AP Stage 1 the car was a totally different beast. I saw on all the forums everyone saying that an intake was not needed because the stock air box flowed good enough until you had a need for more air flow ie. turbo upgrade. Thats why I got the AP first. Which I glad I did.......
06grayrex is offline   Reply With Quote
Old 08-31-2006, 11:53 AM   #8
slipstreamxk1
Scooby Newbie
 
Member#: 99280
Join Date: Oct 2005
Chapter/Region: MAIC
Location: Buffalo, NY
Vehicle:
2006 WRX LTD
OBP

Default

some of what youre getting is lack of engine management and meeting the restrictions on the stock td04 turbo.

I honestly don't know why subaru didnt ditch that turbo when they added displacement.
slipstreamxk1 is offline   Reply With Quote
Old 08-31-2006, 12:12 PM   #9
deblas66
Scooby Specialist
 
Member#: 114096
Join Date: May 2006
Chapter/Region: Tri-State
Location: NYC
Default

Quote:
Originally Posted by slipstreamxk1 View Post
restrictions on the stock td04 turbo.
There's your answer
deblas66 is offline   Reply With Quote
Old 08-31-2006, 12:19 PM   #10
equipment junkie
Scooby Specialist
 
Member#: 97607
Join Date: Oct 2005
Chapter/Region: TXIC
Location: Houston, Texas
Vehicle:
2006 wrx
wrx blue

Default

I ran my 06 WRX at the Texas Mile last October. Bone stock, 2000 miles on it. We clocked the car at 133.5 M.P.H. in the standing start mile. Mind you, this was in 4th gear, because I ran out of track before I ran out of gears . I've had the car up to over 140 M.P.H. when it was stock. I've since installed a VF39 turbo, STI TMIC, Cobb AP with the off the shelf VF39 swap map (a very conservative map), Turbo XS 4" bellmouth down pipe, Turbo XS cat eleminator pipe, MadDad 3" whisperback cat back exhaust. The car pulls much harder above 120 M.P.H. than it did before,
particularly when I added the 3" catback exhaust.
I've also added wheels, tires, Wilwood brakes (6 piston calipers front, 4 piston calipers rear, two piece rotors front and rear), Cobb front and rear sways, Cobb end links front and rear, Megan racinf coil overs front and rear. I never had problems pulling abovr 100 M.P.H. when the car was stock...Also I added the SPT CAI this week (Which technically speaking isn;t really a COLD air intake...at all). It will be a cold air intake when I complete construction of a cold air box to house the air cleaner element and add a fog surround to the front of the car to utilize for "outisde air ingestion".
equipment junkie is offline   Reply With Quote
Old 08-31-2006, 12:20 PM   #11
Poweredbysnail
Scooby Specialist
 
Member#: 74753
Join Date: Nov 2004
Chapter/Region: BAIC
Location: Snail Performance
Vehicle:
2003 Wrx 2.5Lw/gt30r
Team Snail

Default

You just need to tune it up man
Poweredbysnail is offline   Reply With Quote
Old 08-31-2006, 12:26 PM   #12
brodiemash
Scooby Specialist
 
Member#: 105011
Join Date: Jan 2006
Location: Central Cali
Vehicle:
2006 Impreza TR WRX
Obsidian Black

Default

The speedometer only goes up to 140, but I have passed that mark once or twice on mine.
brodiemash is offline   Reply With Quote
Old 08-31-2006, 02:57 PM   #13
jbscooby
Scooby Newbie
 
Member#: 117759
Join Date: Jun 2006
Chapter/Region: SCIC
Location: San Diego
Vehicle:
2006 wrx wagon
metallic silver

Default

+1 for accessport!
jbscooby is offline   Reply With Quote
Old 08-31-2006, 03:07 PM   #14
GNV Motorsports
Vendor
 
Member#: 80970
Join Date: Feb 2005
Location: Pittsburgh, PA
Vehicle:
2003 WRB Stage 4 WRX
www.gnvmotorsports.com

Default

Congratulations! You will enjoy the car for sure.. especially once it's modded PM me if you'd like to discuss modding possibilites and directions to go.

Thanks,
Chris
GNV Motorsports
GNV Motorsports is offline   Reply With Quote
Old 08-31-2006, 05:01 PM   #15
some dude
Scooby Specialist
 
Member#: 100300
Join Date: Nov 2005
Chapter/Region: MWSOC
Location: MIC|-|IG/\N
Vehicle:
06 WRX
CGM

Default

Quote:
Originally Posted by deblas66 View Post
There's your answer

Mine is stock and I don't have the problems BillMac is having. Dosen't sound like the answer to me.
some dude is offline   Reply With Quote
Old 08-31-2006, 06:27 PM   #16
BillMac
Scooby Newbie
 
Member#: 124593
Join Date: Aug 2006
Location: Ada.Ohio
Vehicle:
2007 Sti fp red
346whp 366wtq

Default

Quote:
Originally Posted by treefrogaz View Post
You just need to tune it up man
what do u mean by tune it up? its only got 2300 miles on it im really depressed know that ive found out that ive probly got the slowest top speed on the forum. Im not getting a check engine light or anything
BillMac is offline   Reply With Quote
Old 08-31-2006, 07:27 PM   #17
BillMac
Scooby Newbie
 
Member#: 124593
Join Date: Aug 2006
Location: Ada.Ohio
Vehicle:
2007 Sti fp red
346whp 366wtq

Default

Bump Up
BillMac is offline   Reply With Quote
Old 08-31-2006, 09:07 PM   #18
deblas66
Scooby Specialist
 
Member#: 114096
Join Date: May 2006
Chapter/Region: Tri-State
Location: NYC
Default

Quote:
Originally Posted by some dude View Post
Mine is stock and I don't have the problems BillMac is having. Dosen't sound like the answer to me.
So you're telling me that your car accelerates from 100 and up the same as it does from 0-100? You must have a factory freak because after 100 mine lost bite too and it felt exactly like a turbo with crappy top end would feel.
deblas66 is offline   Reply With Quote
Old 08-31-2006, 09:08 PM   #19
deblas66
Scooby Specialist
 
Member#: 114096
Join Date: May 2006
Chapter/Region: Tri-State
Location: NYC
Default

Sorry, to stay on topic, BillMac, I wouldn't worry too much about it unless the "falls on its face" feeling is absurdly harsh.

If you think it's too much for just the turbo running out of breath, take it to a tuner and see if they can get it to hold better.
deblas66 is offline   Reply With Quote
Old 08-31-2006, 09:48 PM   #20
SubaruDriver502
Scooby Newbie
 
Member#: 114182
Join Date: May 2006
Chapter/Region: Tri-State
Location: Stroudsburg Pennsylvania
Vehicle:
2003 toyota corolla
RIP wrx, damn u bambi!

Default

auto or manual? At an airstrip I was at after I broke her in, my 06 still pulls hard past 100 up to the 130 at redline in 4th. 5th it pulls hard too. Pretty sure the auto's cut out from what I have read. The manuals are drag limited for the non STI models (read that on car and driver)
SubaruDriver502 is offline   Reply With Quote
Old 08-31-2006, 09:53 PM   #21
06rexwagon
Scooby Specialist
 
Member#: 114730
Join Date: May 2006
Chapter/Region: SWIC
Location: Albuquerque, NM
Vehicle:
2006 WRX Limited Wag
9.8@150

Default

Quote:
Originally Posted by BillMac View Post
Yeah i just bought my 06 wrx about a month ago I am loving my first one. I was just wondering if there is a fuel cut off around a 100mph cause it seems that it just falls one its face after that it gains but very slowly. My car has a SPT intake on it and a Apexi N1 catback exhaust. I did try searhing first cause i did want to be lazy couldnt find anything. Please give what info u can!!
'06 is limited around 146 mph I believe. I've never tried to take mine over 100, but I know it had plenty more in it
06rexwagon is online now   Reply With Quote
Old 09-01-2006, 01:27 AM   #22
BillMac
Scooby Newbie
 
Member#: 124593
Join Date: Aug 2006
Location: Ada.Ohio
Vehicle:
2007 Sti fp red
346whp 366wtq

Default

i had it up to a 120 tonight and it then just ran out of room how long does it take to r un out
BillMac is offline   Reply With Quote
Old 09-01-2006, 01:44 AM   #23
jtins06wrx
Scooby Newbie
 
Member#: 123270
Join Date: Aug 2006
Chapter/Region: MWSOC
Location: Royal Oak, MI
Vehicle:
2007 STI
Black

Default

i've had mine a year. and i now have 19,000 miles on it. i just got the AP and WOW, that is so sweel. everyone needs one

Last edited by jtins06wrx; 09-03-2007 at 01:55 AM.
jtins06wrx is offline   Reply With Quote
Old 09-01-2006, 02:35 AM   #24
xmystikx
Scooby Specialist
 
Member#: 112253
Join Date: Apr 2006
Chapter/Region: SCIC
Location: www.theallenchu.com
Vehicle:
14 wrx
revlis

Default

GET RID OF THE INTAKE.. your stock airbox is more than sufficient
xmystikx is offline   Reply With Quote
Old 09-01-2006, 02:59 AM   #25
littlewhitewagon
Scooby Guru
 
Member#: 103068
Join Date: Dec 2005
Chapter/Region: SCIC
Location: PM me if I don't answer posts
Vehicle:
11 STI sedan
SWP

Default

I have had my 06 to almost redline in 5th gear. Of course it doesn't pull as hard once it gets up 120+, but it still pulls. Don't try this on a public road that has ANY traffic.
littlewhitewagon is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
my new 06 wrx limited roccer Member's Car Gallery 47 06-04-2014 05:49 PM
My new 06 WRX T8R Western Canada 9 06-22-2006 01:09 AM
Scratch on my new 06 WRX, spot paint or whole bumper? Danosaurus Car Care & Detailing 22 03-29-2006 10:56 PM
Some pics of my fairly new 06 Wrx rainon General Community 8 03-23-2006 02:22 AM
My New 06 Blue WRX limited --pics wht93gted Member's Car Gallery 21 01-16-2006 06:57 PM


All times are GMT -4. The time now is 04:41 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.