Welcome to the North American Subaru Impreza Owners Club Sunday December 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-01-2006, 12:38 AM   #1
BigBlueSVX
Scooby Newbie
 
Member#: 82600
Join Date: Mar 2005
Location: Portland, OR
Vehicle:
1994 SVX *sold*
Laguna Blue

Default Misfire on EJ22

I'm posting this for my friend, he recently bought a 91 Legacy wagon (EJ22). The other day it started missing and running rough. Here is some info:

- Spark plugs/wires are new
- Will start, but will die with no throttle (won't idle)
- Very laggy throttle response
- It did backfire through the intake a few times
- It misses at any rpm
- Compression is great

One over thing...it rained the other day, and since his hood is off the car at the moment, the engine got a bath. This happened before the problem started, so it very well could have shorted something out, I just don't know what. We did try to blow some sitting water off the engine block with compressed air but it didn't help much.

Any likely causes/info would be great, we need to get this car back on the road.
* Registered users of the site do not see these ads.
BigBlueSVX is offline   Reply With Quote
Old 09-01-2006, 02:45 PM   #2
John*G
Scooby Specialist
 
Member#: 19562
Join Date: Jun 2002
Chapter/Region: NESIC
Location: VT
Vehicle:
95 coupe
red

Default

It got wet and won't idle because it is probably only running on 2 or 3 cylinders. Dry everything, pull the wires off etc, pull the plugs and check the gap if you havn't. Check your coil pack next.
You may have to take it off and put it in a dry warm spot for a couple hours.
( You may want to try a warm oven)
If you can keep the engine running and let it get hot it will eventually dry itself out. With my car this can take several days of driving back and forth to work.
John*G is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Advice on timing belt parts, i.e. belt tensioners on EJ22 SubarNoober Normally Aspirated Powertrain 1 02-21-2008 06:10 PM
CEL = misfire on cylinder 3? Chrisnonstop Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 13 07-17-2002 03:04 PM
Subaru WRX 2002 misfiring on low tank electro Warranty Issues & SOA Problems 8 05-04-2002 03:25 AM
Has anyone had coil or plug misfires on light load MyFastToys Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 2 03-12-2002 03:36 PM
Power on EJ22 NA? oldpreza Normally Aspirated Powertrain 1 05-03-2001 11:05 PM


All times are GMT -4. The time now is 01:09 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.