Welcome to the North American Subaru Impreza Owners Club Friday July 11, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-05-2006, 04:22 AM   #1
suBooneru
Scooby Newbie
 
Member#: 104901
Join Date: Jan 2006
Chapter/Region: BAIC
Location: Sebastopol, Ca.
Vehicle:
2014 Forester XT
White

Default 06 WRX Weather Stripping & Stereo problems.

So I'm already having a few problems with my new 06 WRX and it's got me worried of what could go wrong in the long run. I sure hope my car doesn't start falling apart in a couple years.

First off I just noticed yesterday that the whole corner of the weather stripping near the passenger side rear window was just hanging down. Probably about 7 inches worth of it was loose. I'm not sure if it's supposed to be glued on there or what, but it doesn't look like it was. I was able to kinda re-attach it to the metal for now, but it doesn't seem like it is stuck on there very good. I'm going to have the dealer look at it.

My second issue is that after I turned my car on last night I noticed that the stereo display had no lights on it whatesover. The headlights and all interior lights including the stereo buttons were on, but not the actual display. I of course tried pressing the power on button then all of the other buttons, but none of them got it workin. Finally I just turned the car off and on and then the display was working again. I hope this things not just gonna crap out for good one of these days already.

I've already got 23,000 miles on the car and I'm kinda worried that I might have more of these sort of problems occuring after the warranty is up. I just didn't expect these sort of things to be happening on a near new Subaru. Anyone else having any similar problems with yours?
* Registered users of the site do not see these ads.
suBooneru is offline   Reply With Quote
Old 09-05-2006, 04:30 AM   #2
supermarkus
Scooby Guru
 
Member#: 6971
Join Date: May 2001
Location: Edmonds, Washington, USA
Vehicle:
2008 WRX STi
SSM

Default

The weather stripping pulls out very easily, it is not difficult to stuff back into place, you can do it yourself or have the dealer do it. It is VERY easy to do and not at all scary once you're used to how it works. I had to remove mine to put JDM side visors on and can vouch for how easy it is to work with. As for the stereo, honestly, who cares? It's a POS and you'll probably end up replacing it with something better down the road. Just have them replace it if needed. That's what warranties are for.

23K miles in a year, does not qualify as "near new" in my book, but that's my opinion.
supermarkus is offline   Reply With Quote
Old 09-05-2006, 05:35 AM   #3
bildon
Scooby Newbie
 
Member#: 59347
Join Date: Apr 2004
Chapter/Region: SCIC
Location: Santa Barbara/Los Angeles
Vehicle:
2006 WRX TR
Black

Default

I had my weather stripping come out in the exact same place. No biggie really though, just took a copule minutes of fussing to get it back in there. That was over a month ago and I've had no problems since. I just figured it was one of my foolish friends using it as a handle to get out or something...
bildon is offline   Reply With Quote
Old 09-05-2006, 05:35 AM   #4
suBooneru
Scooby Newbie
 
Member#: 104901
Join Date: Jan 2006
Chapter/Region: BAIC
Location: Sebastopol, Ca.
Vehicle:
2014 Forester XT
White

Default

Quote:
Originally Posted by supermarkus View Post
The weather stripping pulls out very easily, it is not difficult to stuff back into place, you can do it yourself or have the dealer do it. It is VERY easy to do and not at all scary once you're used to how it works. I had to remove mine to put JDM side visors on and can vouch for how easy it is to work with. As for the stereo, honestly, who cares? It's a POS and you'll probably end up replacing it with something better down the road. Just have them replace it if needed. That's what warranties are for.

23K miles in a year, does not qualify as "near new" in my book, but that's my opinion.
Thanks, thats good to know about the weather stripping. I didn't really get a good look at it since I noticed it when I was camping and it was dark out.
As for the stereo it has good enough sound quality for me, so I don't really plan on replacing it and there are bigger POS stereos in cheaper cars like my last honda that last at least 100k miles.

Yeah I can see why you would say 23k miles seems like a lot to classify it as near new, but the car is only 8 months old with mostly cruising freeway miles, so I wouldn't think crap should be going wrong with it.

I also already had to bring the car in to the dealership for a random, bad sounding grinding noise. Turns out it was just a rock that got stuck between the between the brake rotor and backing plate, but I wouldn't think a car that is made to be a sort of all terrain vehicle would be suceptible to a little tiny rock.

Oh I also have that annoying irregular kind of grinding sound when decellerating from higher RPM's and after hearing of all of the broken tranny storys it just kinda worries me.

I guess I may be a little off base in my bitching, but it's just kind of annoying having these little issues on a "less than year old car" when it was a stretch for me to afford it in the first place.
suBooneru is offline   Reply With Quote
Old 09-05-2006, 05:40 AM   #5
suBooneru
Scooby Newbie
 
Member#: 104901
Join Date: Jan 2006
Chapter/Region: BAIC
Location: Sebastopol, Ca.
Vehicle:
2014 Forester XT
White

Default

Quote:
Originally Posted by bildon View Post
I had my weather stripping come out in the exact same place. No biggie really though, just took a copule minutes of fussing to get it back in there. That was over a month ago and I've had no problems since. I just figured it was one of my foolish friends using it as a handle to get out or something...
Haha yeah pretty sure that it was one of my friends who did it to mine. I also love it when people push on the window to slam the door.
suBooneru is offline   Reply With Quote
Old 09-05-2006, 03:26 PM   #6
supermarkus
Scooby Guru
 
Member#: 6971
Join Date: May 2001
Location: Edmonds, Washington, USA
Vehicle:
2008 WRX STi
SSM

Default

Quote:
Originally Posted by suBooneru View Post
Thanks, thats good to know about the weather stripping. I didn't really get a good look at it since I noticed it when I was camping and it was dark out.
As for the stereo it has good enough sound quality for me, so I don't really plan on replacing it and there are bigger POS stereos in cheaper cars like my last honda that last at least 100k miles.

Yeah I can see why you would say 23k miles seems like a lot to classify it as near new, but the car is only 8 months old with mostly cruising freeway miles, so I wouldn't think crap should be going wrong with it.

I also already had to bring the car in to the dealership for a random, bad sounding grinding noise. Turns out it was just a rock that got stuck between the between the brake rotor and backing plate, but I wouldn't think a car that is made to be a sort of all terrain vehicle would be suceptible to a little tiny rock.

Oh I also have that annoying irregular kind of grinding sound when decellerating from higher RPM's and after hearing of all of the broken tranny storys it just kinda worries me.

I guess I may be a little off base in my bitching, but it's just kind of annoying having these little issues on a "less than year old car" when it was a stretch for me to afford it in the first place.

The grinding decel noise could be the throw-out bearing, I would take it in and have a tech ride along with you. I had it too in my 02 wrx, but the whole shebang was changed out when I took it in for a juddery clutch, never had much noise issue after the new clutch was in. They are noisy transmissions however, I didn't find mine as fragile as everyone would have you believe. If you drag race the car and beat the hell out of it, it will probably break. If you drive with some mechanical sympathy, it should be reliable. YMMV.
supermarkus is offline   Reply With Quote
Old 09-05-2006, 04:51 PM   #7
couchflambeau
Scooby Specialist
 
Member#: 102145
Join Date: Dec 2005
Chapter/Region: MWSOC
Location: Grand Forks, ND
Vehicle:
'04 STi/Cobb St. II
18L Java Black Pearl

Default

Quote:
Originally Posted by bildon View Post
I had my weather stripping come out in the exact same place. No biggie really though, just took a copule minutes of fussing to get it back in there. That was over a month ago and I've had no problems since. I just figured it was one of my foolish friends using it as a handle to get out or something...
We have the same problem on our AS-350 B3 EuroCopter A-stars.... very annoying on a helicopter costing a couple million dollars....

(my point is, sometimes that's just a cost of business on a $35,000 car.... just push the stuff back on!)
couchflambeau is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Stock, 06 Wrx Rims/tires & Stern St-1 flexinrex Wheels/Tires 72 05-01-2007 05:46 PM
VF34 on 06 WRX finally installed & tuned! ChrisCJ99 Factory 2.5L Turbo Powertrain 52 11-29-2006 11:01 PM
NC: 06 WRX Cobb AP & TBE, H-Techs NC06TR Private 'For Sale' Classifieds 51 08-17-2006 09:55 PM
Stock 06 WRX, turbo lag, & heat soak bluelagoonGLI Newbies & FAQs 26 04-09-2006 11:12 PM


All times are GMT -4. The time now is 08:21 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.