Welcome to the North American Subaru Impreza Owners Club Monday September 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Vancouver Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Vancouver Impreza Club Forum -- VIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-08-2006, 07:18 PM   #1
AnorexicSTI
Scooby Specialist
 
Member#: 85227
Join Date: Apr 2005
Chapter/Region: VIC
Location: Vancouver, BC, Canada
Vehicle:
2005 STI
Silver

Default Group N STI tranny mount review

Install was easy, but I didn't have the torque specs for all the bolts. I did the best I could "by feel." Torqued the 2 big 12mm bolts to 80 ftlbs... but the rest were about 40-50 ftlbs in my estimation.

If somebody has the torque specs for all the bolts needed to be removed (all the brackets), please let me know.

Stock mount appeared to be BROKEN! I will upload a pic later, but I'm pretty sure it was busted. The Group N mount looked taller and bigger, but weight was the same at 3 lbs each... my scale goes in 1/4 lb increments so I suspect the group N is more like 3.24 and the stock one is 2.76 and they both came out as 3 lbs on the display.

NVH seems to be noticeably worse... I can feel vibratons in my butt. Is this normal? I installed Urethane bushings in my Honda before and it resulted in something similar, but that was all 5 mounts! I didnt think replacing 1 mount would cause this much vibration. Maybe I messed up the tightening sequence or torque specs?

I also removed this 1 lb "vibration dampener" so maybe that is causing the excess vibration. I hear of people removing the "5 lb dampener" on their earlier model Subarus so I didn't think removing this small one would make much difference... will try putting it back in and see what happens.

Anyways, the thing does as it should...keeps the tranny in place! 1-2 speedshift midturn is no problem now... feels just like when doing it in a straight line.

1.5 thumbs up... due to the added NVH.
* Registered users of the site do not see these ads.
AnorexicSTI is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: Group N STi Tranny Mount (GC8) + other stuff UpTown I-TS VIC Private Classifieds 9 12-10-2007 02:46 PM
CO: Group-N STi tranny mount NvrenuffWRX Drivetrain 1 09-11-2007 11:31 PM
STi tranny mount review beachbum Car Part Reviews 5 04-03-2007 12:49 AM
Group N Sti Tranny Mount Review! elhalisf Transmission (AT/MT) & Driveline 6 12-28-2004 05:10 PM
CC8 STI Group N engine/tranny mount review Dolphin Overton Normally Aspirated Powertrain 7 03-18-2002 01:58 PM


All times are GMT -4. The time now is 11:46 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.