Welcome to the North American Subaru Impreza Owners Club Friday July 11, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
South West Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > South West Impreza Club Forum -- SWIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-02-2006, 06:31 PM   #1
SubeSTIle
Scooby Specialist
 
Member#: 80736
Join Date: Feb 2005
Chapter/Region: SWIC
Location: West Valley, AZ
Vehicle:
1999 FXT White
E85 is for girls

Default Cruise control problem

If anyone know anything about the CC on an 01RS and could help me figure out why mine isnt working send me a PM or an email subestile@cox.net. it wont turn on at all as far as i can tell. Thanks for any help.

James
STile
* Registered users of the site do not see these ads.
SubeSTIle is offline   Reply With Quote
Old 10-02-2006, 06:35 PM   #2
couchflambeau
Scooby Specialist
 
Member#: 102145
Join Date: Dec 2005
Chapter/Region: MWSOC
Location: Grand Forks, ND
Vehicle:
'04 STi/Cobb St. II
18L Java Black Pearl

Default

Could be a completely different set up, I had an 02' bugeye WRX that the CC crapped.... turned out to be a faulty brake switch or something like that. Covered under warranty at the time so I didn't concern myself much with it.
couchflambeau is offline   Reply With Quote
Old 10-02-2006, 06:50 PM   #3
SubeSTIle
Scooby Specialist
 
Member#: 80736
Join Date: Feb 2005
Chapter/Region: SWIC
Location: West Valley, AZ
Vehicle:
1999 FXT White
E85 is for girls

Default

that could be it but i dont have any idea. fish how much to have it checked?
SubeSTIle is offline   Reply With Quote
Old 10-03-2006, 06:01 PM   #4
DemonScooby
Scooby Newbie
 
Member#: 39554
Join Date: Jul 2003
Chapter/Region: SWIC
Location: Phoenix, AZ
Vehicle:
1998 Impreza 2.5 RS
Black with Gold Rims

Default

couch's problem sounds like the clutch stopper plug problem i had w/ my cc. it was a 1.99 part that clips onto the clutch arm above the pedal, and pushes a button so the computer knows the clutch is engaged.
DemonScooby is offline   Reply With Quote
Old 10-03-2006, 06:03 PM   #5
racingfish
Scooby Guru
 
Member#: 60976
Join Date: May 2004
Chapter/Region: SWIC
Location: Goodyear
Vehicle:
1969 LGT
FATURBO

Default

just bring it by next sat... not this sat. talk ta rich see if he can hook u up....
racingfish is offline   Reply With Quote
Old 10-03-2006, 06:24 PM   #6
M.Ehle
Scooby Newbie
 
Member#: 62391
Join Date: May 2004
Chapter/Region: SWIC
Location: Phoenix, AZ
Vehicle:
2006 Legacy Spec.B
TSM 98/500

Subaru Stars

Not to take anything away from Fish, but also check all brake light bulbs. Any burnt out brake light will prevent the CC from working. I had this problem myself, supposed to be covered under warranty on a Toyota and I got charged $45 to change a brake light bulb. If that's not it then go see da FishMeister
M.Ehle is offline   Reply With Quote
Old 10-03-2006, 09:13 PM   #7
SubeSTIle
Scooby Specialist
 
Member#: 80736
Join Date: Feb 2005
Chapter/Region: SWIC
Location: West Valley, AZ
Vehicle:
1999 FXT White
E85 is for girls

Default

i am going to try replacing the cc switch first and see if that is the problem. but other than that its not worth putting any money into at this point. Thanks for any sugestions of things to check. all brakelights work so i know thats not the problem. anyone have a picture of the clutch switch they are refering to? afaik mine is working. Thanks

James
SubeSTIle is offline   Reply With Quote
Old 10-03-2006, 10:44 PM   #8
Smoby
Scooby Specialist
 
Member#: 97642
Join Date: Oct 2005
Chapter/Region: SWIC
Location: Phoenix, AZ
Vehicle:
2002 Wrx Sedan
MBP

Default

Does your cruise control have a light on it that lights up?

If so, I would look into the switch on the clutch pedal as mentioned. I had the same problem where the switch would light up, but cruise just wouldnt work.
Smoby is offline   Reply With Quote
Old 10-04-2006, 01:29 AM   #9
SubeSTIle
Scooby Specialist
 
Member#: 80736
Join Date: Feb 2005
Chapter/Region: SWIC
Location: West Valley, AZ
Vehicle:
1999 FXT White
E85 is for girls

Default

switch doesnt light up at all. afaik it should light up but doesnt, can someone with an RS with CC confirm this?
SubeSTIle is offline   Reply With Quote
Old 10-04-2006, 02:31 PM   #10
SubeSTIle
Scooby Specialist
 
Member#: 80736
Join Date: Feb 2005
Chapter/Region: SWIC
Location: West Valley, AZ
Vehicle:
1999 FXT White
E85 is for girls

Default

it was the switch. ordered one from avondale. 50 bucks for a switch... what a rip off...
SubeSTIle is offline   Reply With Quote
Old 10-04-2006, 02:33 PM   #11
dozer54321
Scooby Specialist
 
Member#: 116437
Join Date: Jun 2006
Chapter/Region: SWIC
Location: Glendale, AZ
Vehicle:
2002 WRX - MINE
99 SUS - WIFEY

Default

is it the same switch that is in a 02 wrx?
dozer54321 is offline   Reply With Quote
Old 10-04-2006, 02:37 PM   #12
racingfish
Scooby Guru
 
Member#: 60976
Join Date: May 2004
Chapter/Region: SWIC
Location: Goodyear
Vehicle:
1969 LGT
FATURBO

Default

Quote:
Originally Posted by SubeSTIle View Post
it was the switch. ordered one from avondale. 50 bucks for a switch... what a rip off...

thats for overnighting it....
racingfish is offline   Reply With Quote
Old 10-04-2006, 02:47 PM   #13
Evil_STI
*** Banned ***
 
Member#: 106521
Join Date: Feb 2006
Chapter/Region: SWIC
Location: is_gay
Vehicle:
I am an ancient of
chaos. \\ t3hclap.com

Default

Quote:
Originally Posted by racingfish View Post
thats for overnighting it....
Thats still alot for like a $10 thing-a-ma-bop.

How much was THE SWITCH?
Evil_STI is offline   Reply With Quote
Old 10-04-2006, 02:50 PM   #14
dozer54321
Scooby Specialist
 
Member#: 116437
Join Date: Jun 2006
Chapter/Region: SWIC
Location: Glendale, AZ
Vehicle:
2002 WRX - MINE
99 SUS - WIFEY

Default

i have an extra cruise control dash switch in my garage for an 02, im assuming they are the same, should have posted up about needing one
dozer54321 is offline   Reply With Quote
Old 10-04-2006, 02:54 PM   #15
SubeSTIle
Scooby Specialist
 
Member#: 80736
Join Date: Feb 2005
Chapter/Region: SWIC
Location: West Valley, AZ
Vehicle:
1999 FXT White
E85 is for girls

Default

they are different for the 01s and the 02s, the 02+ light up on the dash and mine the switch lights up. besides i used subie bucks as im broke.
SubeSTIle is offline   Reply With Quote
Old 10-04-2006, 02:58 PM   #16
racingfish
Scooby Guru
 
Member#: 60976
Join Date: May 2004
Chapter/Region: SWIC
Location: Goodyear
Vehicle:
1969 LGT
FATURBO

Default

Normally $50+ our price was like $34. he coulda got it for $34 but He needed it by friday for his trip. so it was like 20 bux to overnite.
racingfish is offline   Reply With Quote
Old 10-04-2006, 03:00 PM   #17
Evil_STI
*** Banned ***
 
Member#: 106521
Join Date: Feb 2006
Chapter/Region: SWIC
Location: is_gay
Vehicle:
I am an ancient of
chaos. \\ t3hclap.com

Default

Ohh...I see...so its THE WHOLE harness or what?
Evil_STI is offline   Reply With Quote
Old 10-04-2006, 03:02 PM   #18
racingfish
Scooby Guru
 
Member#: 60976
Join Date: May 2004
Chapter/Region: SWIC
Location: Goodyear
Vehicle:
1969 LGT
FATURBO

Default

NAHH just a switch
racingfish is offline   Reply With Quote
Old 10-04-2006, 03:08 PM   #19
Evil_STI
*** Banned ***
 
Member#: 106521
Join Date: Feb 2006
Chapter/Region: SWIC
Location: is_gay
Vehicle:
I am an ancient of
chaos. \\ t3hclap.com

Default

Damn.
Evil_STI is offline   Reply With Quote
Old 10-04-2006, 03:28 PM   #20
racingfish
Scooby Guru
 
Member#: 60976
Join Date: May 2004
Chapter/Region: SWIC
Location: Goodyear
Vehicle:
1969 LGT
FATURBO

Default

told him he coulda had mine, i dont use cc. i dont even know how to use it.
racingfish is offline   Reply With Quote
Old 10-04-2006, 03:36 PM   #21
Evil_STI
*** Banned ***
 
Member#: 106521
Join Date: Feb 2006
Chapter/Region: SWIC
Location: is_gay
Vehicle:
I am an ancient of
chaos. \\ t3hclap.com

Default

Ohh...well u push the button...then flick it...I think...its one of those..."Gota be there to use it right" kind of things...
Evil_STI is offline   Reply With Quote
Old 10-04-2006, 08:14 PM   #22
SubeSTIle
Scooby Specialist
 
Member#: 80736
Join Date: Feb 2005
Chapter/Region: SWIC
Location: West Valley, AZ
Vehicle:
1999 FXT White
E85 is for girls

Default

your switch wouldnt work for me fish, they are different on the legs afaik
SubeSTIle is offline   Reply With Quote
Old 10-04-2006, 08:17 PM   #23
racingfish
Scooby Guru
 
Member#: 60976
Join Date: May 2004
Chapter/Region: SWIC
Location: Goodyear
Vehicle:
1969 LGT
FATURBO

Default

yeah i dont even think i have a switch... i think its all on the colum

go A's
racingfish is offline   Reply With Quote
Old 10-04-2006, 08:53 PM   #24
SubeSTIle
Scooby Specialist
 
Member#: 80736
Join Date: Feb 2005
Chapter/Region: SWIC
Location: West Valley, AZ
Vehicle:
1999 FXT White
E85 is for girls

Default

thats what i figured as my06 sit is on the column
SubeSTIle is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
cruise control problem avatarr Factory 2.0L Turbo Powertrain 9 10-27-2003 10:39 AM
cruise control problems? extraducksauce Service & Maintenance 2 10-26-2002 10:43 AM
4EAT + cruise control problems kami333 Newbies & FAQs 0 08-19-2002 02:27 PM
Cruise COntrol Problem...Help? Rubasu Normally Aspirated Powertrain 2 06-12-2001 05:04 PM
Cruise Control Problem AndyHidley Technical Forum Archive 2 07-20-2000 11:04 AM


All times are GMT -4. The time now is 10:22 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.