Welcome to the North American Subaru Impreza Owners Club Friday August 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-11-2006, 04:20 PM   #1
brianswagon
Scooby Newbie
 
Member#: 96135
Join Date: Sep 2005
Chapter/Region: SCIC
Location: Socal
Vehicle:
04 WRX
WRB

Default Engine Trouble Help

Ive got an 04 WRX with some serious engine issues. It has a flashing CEL, some really loud knocking coming from the engine and or around the engine, and an awkward vibration that shakes the whole car. It almost feels as if the cylinders are timed inproperly. All the fluids in the car are fine, and the car has about 35k on it.
As far as mods, ive got a TBE and and up pipe, i really dont think that the CEL is relate to either of these because its been running fine with this set up for 15k+ miles. I plan on taking it to autozone soon to pul the code, but i dont know if it is safe to drive. Any suggestions?
* Registered users of the site do not see these ads.
brianswagon is offline   Reply With Quote
Old 09-11-2006, 05:29 PM   #2
Obsessive
Scooby Specialist
 
Member#: 77302
Join Date: Dec 2004
Chapter/Region: MWSOC
Location: Billy Mays
Vehicle:
damn well better
bail me out of this ****

Default

Quote:
Originally Posted by brianswagon View Post
Ive got an 04 WRX with some serious engine issues. It has a flashing CEL, some really loud knocking coming from the engine and or around the engine, and an awkward vibration that shakes the whole car. It almost feels as if the cylinders are timed inproperly. All the fluids in the car are fine, and the car has about 35k on it.
As far as mods, ive got a TBE and and up pipe, i really dont think that the CEL is relate to either of these because its been running fine with this set up for 15k+ miles. I plan on taking it to autozone soon to pul the code, but i dont know if it is safe to drive. Any suggestions?

I would definately not drive it, it may leave you stranded. Could be quite a few things, but with the 'loud knocking', it leads me to believe that it could be something quite serious (hopefully not).

If it indeed is a major component (wrist pin, rod bearing, etc.), then you could be doing more damage by driving it. I would rip the exhaust off, put the stocker parts on, and call subaru roadside assistance for them to pick it up...

It could be something less serious, such as timing issues (slipped belt, bad tensioner), but I don't think you would have a super-loud knock coming from the engine, but more of a popping (back through the intake), stumbling rev, all around POS running engine.

Eric
Obsessive is offline   Reply With Quote
Old 09-12-2006, 01:40 PM   #3
brianswagon
Scooby Newbie
 
Member#: 96135
Join Date: Sep 2005
Chapter/Region: SCIC
Location: Socal
Vehicle:
04 WRX
WRB

Default

Thanks Eric, unfortunately im up at school right now so i have no tools or garage to put it back to stock. I do plan on towing it asap.
brianswagon is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine troubles HELP! NWSTi-wa Factory 2.5L Turbo Powertrain 3 06-12-2010 08:25 PM
HELP 2006 engine troubles subywuby45 Service & Maintenance 5 02-21-2008 09:38 PM
engine trouble, help legacydreamz Legacy Forum 6 04-08-2006 11:07 AM
need some subie help,engine troubles... Vidiotgamer Factory 2.0L Turbo Powertrain 8 10-29-2003 04:30 PM
check engine light, wierd engine trouble? gipoliceman Factory 2.0L Turbo Powertrain 3 01-14-2003 09:04 PM


All times are GMT -4. The time now is 11:47 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.