Welcome to the North American Subaru Impreza Owners Club Monday October 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-06-2012, 04:52 PM   #3626
mark342
Scooby Newbie
 
Member#: 284693
Join Date: Jun 2011
Chapter/Region: MWSOC
Location: Olathe, KS
Vehicle:
1999 Impreza 2.5 RS
STM

Default

Need help diagnosing some stuttering/hesitating issue

Got a 99 RS with an ver 9 ej207. Only engine related mod is a walbro 255. 93 octane.

The car seems like it isn't getting the normal power it used to get, and stutters a lot at full throttle and seems like the power slightly fluctuates while just generally cruising at ~40 mph (was running fine yesterday.) Feels like power cuts out randomly. No CEL. Same symptoms with and without a/c running. The only thing maybe out of the ordinary is that it's been hot around here lately (100* F when I just drove it a moment ago). I don't have that air intake trumpet that goes over the radiator (not sure what fits), so maybe the combo of all the hot air isn't helping? FWIW, the engine isn't overheating (running at about the 1/3-2/5 mark on the temp gauge).

Kinda stumped--any thoughts?
* Registered users of the site do not see these ads.

Last edited by mark342; 07-06-2012 at 04:59 PM.
mark342 is offline   Reply With Quote
Old 07-06-2012, 05:07 PM   #3627
WRick
Scooby Newbie
 
Member#: 86107
Join Date: Apr 2005
Chapter/Region: E. Canada
Location: 10% REAL FRUIT JUICE
Default



here goes the new build !

Found this lying around @ Subaru Canada's part depot. 300 $ lol !!

Version 9 spec C double crossdrilled nitrided crank

wtf I think a fan motor is more expensive
WRick is offline   Reply With Quote
Old 07-06-2012, 07:02 PM   #3628
jam007
Scooby Specialist
 
Member#: 174706
Join Date: Mar 2008
Chapter/Region: SCIC
Location: Camarillo, California
Vehicle:
2004 WRX V8 EJ207
6MT, 08 Spec B

Default

Nice find!
jam007 is offline   Reply With Quote
Old 07-07-2012, 04:16 PM   #3629
mattrubywrx
Scooby Newbie
 
Member#: 315635
Join Date: Apr 2012
Vehicle:
04 STi
Aspen White

Default

does running no cats trip a "check engine" light every now and then on the ej207? my car feels to be running great but the engine light keeps coming on and off, now it has came on and stayed for a a day , which is the longest yet.
mattrubywrx is offline   Reply With Quote
Old 07-07-2012, 04:41 PM   #3630
Xcelr8to1320
Scooby Specialist
 
Member#: 131272
Join Date: Nov 2006
Chapter/Region: MWSOC
Location: Mid-MI
Vehicle:
2003 WRX Wagon

Default

It can. Have you pulled the code to confirm what it is?
Xcelr8to1320 is offline   Reply With Quote
Old 07-07-2012, 06:01 PM   #3631
mattrubywrx
Scooby Newbie
 
Member#: 315635
Join Date: Apr 2012
Vehicle:
04 STi
Aspen White

Default

not yet, been waiting to have my buddy plug his reader into it but its such an onn and off thing, hard to catch it with the engine light on while he's around.
do the codes store on the ecu after the CEL is off?
mattrubywrx is offline   Reply With Quote
Old 07-07-2012, 09:42 PM   #3632
mark342
Scooby Newbie
 
Member#: 284693
Join Date: Jun 2011
Chapter/Region: MWSOC
Location: Olathe, KS
Vehicle:
1999 Impreza 2.5 RS
STM

Default

Need to get new spark plugs--what are the oem ones? If not oem, what's the most common? No mods other than walbro 255 lph.

I'm seeing NGK BKR7EIX a lot, but not sure if those are oem or not.

Thanks
mark342 is offline   Reply With Quote
Old 07-07-2012, 10:11 PM   #3633
iNfEk
Scooby Guru
 
Member#: 21339
Join Date: Jul 2002
Chapter/Region: HIIC
Location: Kapolei, HI
Vehicle:
2002 LHD STI V7 6MT
12.9@103MPH EJ205 4EAT

Default

Quote:
Originally Posted by mattrubywrx
not yet, been waiting to have my buddy plug his reader into it but its such an onn and off thing, hard to catch it with the engine light on while he's around.
do the codes store on the ecu after the CEL is off?
Yes if the CEL turns off the code still should be accessible as long as the reader can read them.
iNfEk is offline   Reply With Quote
Old 07-08-2012, 05:09 AM   #3634
ImNOrobo
Scooby Specialist
 
Member#: 255716
Join Date: Aug 2010
Chapter/Region: NWIC
Location: Where the simpsons live.
Vehicle:
A '04/'05/'01
RHD?!

Default

Quote:
Originally Posted by WhiteBgeye02 View Post
only 18psi? come on bro turn that **** up! vf37 on yours or something different? idk how much correction you have but i made 310/315 on the same virtual dyno setup with a lot of correction to smooth it out. what octane you running? i know phatron does a really good job with every car he does so its why i ask
That wasn't really a good pull, just something I could post up. I hit 21 peak on my boost gauge now. I am running 93 octane and the smoothing factor was 7. I have this tuned for autocross/dd. I trust what Ron did, I asked for more boost and he tried but it wasn't liking it. Either way I am happy with the way it feels and don't really care too much about numbers.

Quote:
Originally Posted by kayen View Post
Looks to me he logged just manifold pressure, instead of calculated manifold pressure. Which would be why it only shows 18psi on the dyno graph. However he could have just done a very safe tune.
Calculated manifold pressure was used. I am pretty sure he went safe, it is still pretty rich up top. There probably is more power to be made but like I said above I am happy with how she feels. For a basic stage 2 with the protune I am making a little less than I was with an 18g on my 205 but the off boost response is night and day. The linear feel of the turbo feels great too.

I learned alot from reading this thread and I appreciate everyones advice/knowledge.
ImNOrobo is online now   Reply With Quote
Old 07-08-2012, 05:11 AM   #3635
ImNOrobo
Scooby Specialist
 
Member#: 255716
Join Date: Aug 2010
Chapter/Region: NWIC
Location: Where the simpsons live.
Vehicle:
A '04/'05/'01
RHD?!

Default

Quote:
Originally Posted by Jeremey.smith View Post
+1 for stephen at IA.
He gave me a discount for my AVCS kit.
Anyway, hate to jump in the middle of something, but I just did my v8 swap and AVCS is working, however I cannot get a smooth idle and keep getting code P0519 IAC. The car runs smooth once you get it past the ****ty idle. I removed and cleaned my air control valve only to have the code come back after 15 min of driving. This was last night, today after work Im goin to adjust my throttle cables on hopes that mavbe one of them is just sticking.
Just wanted another opinion on the matter or any other possible solutions.
Any update? I had the same problem. It turned out to be a bad IACV. I used the old one off of my 205 and never had the problem come back.
ImNOrobo is online now   Reply With Quote
Old 07-08-2012, 12:25 PM   #3636
Jeremey.smith
Scooby Newbie
 
Member#: 276065
Join Date: Mar 2011
Chapter/Region: South East
Location: Valdosta, Ga
Vehicle:
2002 207
wrb

Default

I clean it again and it went away as it did the first time. Its took about half an hour begore it came bavk. Ill see how long it last this time. I also still have my mine from my 205. I'm going to swap them if it comes bak again. It hasn't came back since you replaced it?
Jeremey.smith is offline   Reply With Quote
Old 07-08-2012, 03:16 PM   #3637
WhiteBgeye02
Scooby Specialist
 
Member#: 224785
Join Date: Sep 2009
Chapter/Region: MWSOC
Location: neenah
Vehicle:
2005 wrx-jdm207
i went black...

Default

dont forget you need a new gasket for it^ or it will leak like crazy and your car will hunt to find its idle
WhiteBgeye02 is offline   Reply With Quote
Old 07-08-2012, 03:17 PM   #3638
mark342
Scooby Newbie
 
Member#: 284693
Join Date: Jun 2011
Chapter/Region: MWSOC
Location: Olathe, KS
Vehicle:
1999 Impreza 2.5 RS
STM

Default

Quote:
Originally Posted by mark342 View Post
Need to get new spark plugs--what are the oem ones? If not oem, what's the most common? No mods other than walbro 255 lph.

I'm seeing NGK BKR7EIX a lot, but not sure if those are oem or not.

Thanks
Anyone?
mark342 is offline   Reply With Quote
Old 07-08-2012, 03:21 PM   #3639
iNfEk
Scooby Guru
 
Member#: 21339
Join Date: Jul 2002
Chapter/Region: HIIC
Location: Kapolei, HI
Vehicle:
2002 LHD STI V7 6MT
12.9@103MPH EJ205 4EAT

Default

Quote:
Originally Posted by mark342

Anyone?
Search this thread. I know I've asked and others have too. I cant remember off the top of my head.
iNfEk is offline   Reply With Quote
Old 07-08-2012, 03:27 PM   #3640
Computersare8ad
Scooby Specialist
 
Member#: 287080
Join Date: Jun 2011
Chapter/Region: TXIC
Location: Katy
Vehicle:
2014 WRB WRX
Stock

Default

Quote:
Originally Posted by mark342

Anyone?
The BRK7EIX is an iridium that is one step colder. It is what I am running on my stg2 v8 ej207.

NGK 2667 is the same item but some places recognize that part number and not the other.
Computersare8ad is offline   Reply With Quote
Old 07-08-2012, 04:34 PM   #3641
mark342
Scooby Newbie
 
Member#: 284693
Join Date: Jun 2011
Chapter/Region: MWSOC
Location: Olathe, KS
Vehicle:
1999 Impreza 2.5 RS
STM

Default

What should I be running in a stock engine then?
mark342 is offline   Reply With Quote
Old 07-08-2012, 04:37 PM   #3642
Computersare8ad
Scooby Specialist
 
Member#: 287080
Join Date: Jun 2011
Chapter/Region: TXIC
Location: Katy
Vehicle:
2014 WRB WRX
Stock

Default

Quote:
Originally Posted by mark342
What should I be running in a stock engine then?
Same should be fine.... just make sure to get tuned.
Computersare8ad is offline   Reply With Quote
Old 07-08-2012, 04:43 PM   #3643
mark342
Scooby Newbie
 
Member#: 284693
Join Date: Jun 2011
Chapter/Region: MWSOC
Location: Olathe, KS
Vehicle:
1999 Impreza 2.5 RS
STM

Default

Yep, tuning is no problem. Brother is good with romraider. Guess I'll go ahead and grab a pack of those then.
mark342 is offline   Reply With Quote
Old 07-08-2012, 05:19 PM   #3644
jhenry1983
Scooby Newbie
 
Member#: 269361
Join Date: Jan 2011
Chapter/Region: SCIC
Location: Los Angeles, CA
Vehicle:
2011 sti
03wrx Rallycar

Default

28 bucks on ebay with free next day shipping when i got my spark plugs should take a look
jhenry1983 is offline   Reply With Quote
Old 07-08-2012, 05:51 PM   #3645
ImNOrobo
Scooby Specialist
 
Member#: 255716
Join Date: Aug 2010
Chapter/Region: NWIC
Location: Where the simpsons live.
Vehicle:
A '04/'05/'01
RHD?!

Default

Quote:
Originally Posted by Jeremey.smith View Post
I clean it again and it went away as it did the first time. Its took about half an hour begore it came bavk. Ill see how long it last this time. I also still have my mine from my 205. I'm going to swap them if it comes bak again. It hasn't came back since you replaced it?
No it hasn't come back since I replaced that and the gasket. I knew my 205 IACV worked just fine and hasn't let me down since.
ImNOrobo is online now   Reply With Quote
Old 07-09-2012, 08:21 PM   #3646
WRick
Scooby Newbie
 
Member#: 86107
Join Date: Apr 2005
Chapter/Region: E. Canada
Location: 10% REAL FRUIT JUICE
Default

anyone know the size of the oil pump a spec C V7 comes with ? Since the crank is different, should I change this ?
WRick is offline   Reply With Quote
Old 07-10-2012, 08:01 AM   #3647
Jeremey.smith
Scooby Newbie
 
Member#: 276065
Join Date: Mar 2011
Chapter/Region: South East
Location: Valdosta, Ga
Vehicle:
2002 207
wrb

Default

Quote:
Originally Posted by ImNOrobo View Post
No it hasn't come back since I replaced that and the gasket. I knew my 205 IACV worked just fine and hasn't let me down since.
Nice. My new gasket is supposed to come in tomorrow & ill be doin the same thing. Hate to crack it open now and have it expand on me.
Jeremey.smith is offline   Reply With Quote
Old 07-10-2012, 08:19 AM   #3648
fastnoypi
Scooby Specialist
 
Member#: 6886
Join Date: May 2001
Chapter/Region: Tri-State
Vehicle:
MY01 EJ207 HTA35r
nothing to see, i'm stock

Default

Quote:
Originally Posted by WRick View Post
anyone know the size of the oil pump a spec C V7 comes with ? Since the crank is different, should I change this ?
spec C V7 should be 11mm. IMO If you had alot of shrapnel in your oil when your motor popped, i'd swap it out along with your oil cooler.
fastnoypi is offline   Reply With Quote
Old 07-10-2012, 08:56 AM   #3649
Xcelr8to1320
Scooby Specialist
 
Member#: 131272
Join Date: Nov 2006
Chapter/Region: MWSOC
Location: Mid-MI
Vehicle:
2003 WRX Wagon

Default

So I heard from a local tuner that my V7 engine is not much stronger than a standard USDM EJ257. And so now I'm confused because everything I've read says otherwise. Anyone able to shed some light here?
Xcelr8to1320 is offline   Reply With Quote
Old 07-10-2012, 09:58 AM   #3650
LIQUIDSK8S
Scooby Specialist
 
Member#: 22605
Join Date: Aug 2002
Location: Boca Raton, FL
Vehicle:
2002 JDM STI/WRX
WRB

Default

Quote:
Originally Posted by Xcelr8to1320 View Post
So I heard from a local tuner that my V7 engine is not much stronger than a standard USDM EJ257. And so now I'm confused because everything I've read says otherwise. Anyone able to shed some light here?
Never go back to that tuner, he has no idea what he is talking about
LIQUIDSK8S is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ej207 owner wants opinions adbramsay Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 2 02-26-2011 07:29 PM
Ej207 V6 AndrewFD3 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 10 06-03-2010 04:53 PM
JDM Sti EJ207 V9 crank 75mm or billet crank (K1, Manley) VENDORS ??? L'frise Private 'Wanted' Classifieds 7 06-03-2010 09:24 AM
08 ej207 JDM dual AVCS heads on a built v7 ej207 icev7 Built Motor Discussion 17 02-21-2010 03:21 PM
Ver 8 EJ207 Owners Check In spoolinsuby Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 21 10-17-2005 01:56 AM


All times are GMT -4. The time now is 12:33 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.