Welcome to the North American Subaru Impreza Owners Club Monday September 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-10-2012, 03:50 PM   #4526
Torquey
Scooby Specialist
 
Member#: 175334
Join Date: Mar 2008
Chapter/Region: TXIC
Location: Dallas, TX
Vehicle:
2003 Impreza WRX
JDM v8 EJ207 WRB

Default

Quote:
Originally Posted by WhiteBgeye02 View Post
What A Cluster **** Of Three Pages Of Info!
LOL... maybe the last few pages could be merged with the "ej207 info" thread... although Vlad may go berserk over it
* Registered users of the site do not see these ads.
Torquey is offline   Reply With Quote
Old 10-10-2012, 03:54 PM   #4527
todeswalzer
Scooby Specialist
 
Member#: 191495
Join Date: Oct 2008
Chapter/Region: NESIC
Location: Lowell MA
Vehicle:
'05 WRB GTX3071R
JDM V8 EJ207 USDM 6MT

Default

The sky is blue

Then its yellow. With proof.



Lol jk its blue
todeswalzer is offline   Reply With Quote
Old 10-10-2012, 03:56 PM   #4528
Vlad
Scooby Guru
 
Member#: 46135
Join Date: Oct 2003
Chapter/Region: Tri-State
Location: NY
Vehicle:
02 WRX
Sti V9 Spec C

Default

Vlad is online now   Reply With Quote
Old 10-10-2012, 04:12 PM   #4529
WhiteBgeye02
Scooby Specialist
 
Member#: 224785
Join Date: Sep 2009
Chapter/Region: MWSOC
Location: neenah
Vehicle:
2005 wrx-jdm207
i went black...

Default

okay who here is willing to help me out either on here or PM w/ getting avcs to work on a local guys car? i have tried to get someone to reverse the polarity signal in the rom but ppl on romraider are less and less help now days. i know how to on a v8 but not v7

my next option is to do it the old way and swap nps sensors.

I have made the sure car is out of rough correction mode, up to temp, moving down the road at many speeds, etc etc same stuff i did with my v8 when i got it in Feb. but this guy bought it like this. got it tuned by a bad shop and now I am attempting to make it better by getting avcs to work as a start.

what should i see in gear when i log nps? what should i see in neutral?

i know i should search and have used the google search adv function but it only goes so far.it also seems easier if someone who knows the right answers can help me privatly if needed.
v7 engine in 02/03 wrx. the trans is supposed to be an 05wrx trans. he is going to verify which 5mt harness it has. i know from bugeye to blobeye somewere they switched the type of plug the nps and reverse plugs had were they connected to the trans harness but the end that connects to the car is the same.
WhiteBgeye02 is offline   Reply With Quote
Old 10-10-2012, 04:13 PM   #4530
Ryan2002WRX
Scooby Newbie
 
Member#: 225439
Join Date: Oct 2009
Default

I knew what I had but then last night was very excited and confused for a little while. It all got worked out and none the less its all good info. But now reading the last few pages my head hurts a little lol
Ryan2002WRX is offline   Reply With Quote
Old 10-10-2012, 05:12 PM   #4531
johnfelstead
Scooby Specialist
 
Member#: 856
Join Date: Feb 2000
Chapter/Region: International
Location: Hampshire, England, UK
Vehicle:
2005 JDM STi
Black

Default

Quote:
Originally Posted by azscooby View Post
My V8 EJ207DW5CR has the temp sensor in the plenum (right under throttle body) and the oil filler says 7/03..

I was under the impression mine was a model year 2003/2004.....?

John your new info would suggest mine is a model year 2005, since it has the temp sensor?

I find that confusing if not contradictory to what the date on my oil cap says, though of course its entirely possible its not an original cap.
I'd say the homologation sheet is wrong, and the caps are easily mixed up, so to be sure always go off the engine type code to get the spec would be my advice.
johnfelstead is offline   Reply With Quote
Old 10-10-2012, 05:26 PM   #4532
navydub
Scooby Newbie
 
Member#: 242585
Join Date: Mar 2010
Chapter/Region: MAIC
Location: Chesapeake, VA
Vehicle:
2005 Saabaru
Black

Default

Ok so back home today, new battery and went to start the car. I notice the fiel pump isn't priming. I swap ECUs to the USDM one and the fuel pump primes just fine. Motor starts and runs on the USDM ECU but will not start and the motor won't prime on the JDM ECU. I'm thinking I got a V9 immo'd ECU can anyone confirm?

B1 ECU code 22611AJ810
navydub is offline   Reply With Quote
Old 10-10-2012, 05:37 PM   #4533
johnfelstead
Scooby Specialist
 
Member#: 856
Join Date: Feb 2000
Chapter/Region: International
Location: Hampshire, England, UK
Vehicle:
2005 JDM STi
Black

Default

Quote:
Originally Posted by navydub View Post
Ok so back home today, new battery and went to start the car. I notice the fiel pump isn't priming. I swap ECUs to the USDM one and the fuel pump primes just fine. Motor starts and runs on the USDM ECU but will not start and the motor won't prime on the JDM ECU. I'm thinking I got a V9 immo'd ECU can anyone confirm?

B1 ECU code 22611AJ810
MY05 JDM STi, it has an imobilisor.
johnfelstead is offline   Reply With Quote
Old 10-10-2012, 06:02 PM   #4534
Torquey
Scooby Specialist
 
Member#: 175334
Join Date: Mar 2008
Chapter/Region: TXIC
Location: Dallas, TX
Vehicle:
2003 Impreza WRX
JDM v8 EJ207 WRB

Default

Quote:
Originally Posted by navydub View Post
Ok so back home today, new battery and went to start the car. I notice the fiel pump isn't priming. I swap ECUs to the USDM one and the fuel pump primes just fine. Motor starts and runs on the USDM ECU but will not start and the motor won't prime on the JDM ECU. I'm thinking I got a V9 immo'd ECU can anyone confirm?

B1 ECU code 22611AJ810
check page #178 of this thread... another guy is dealing with the same issue with same ECU. Like John said... v9 ECU with most likely immobilizer.
Torquey is offline   Reply With Quote
Old 10-10-2012, 06:05 PM   #4535
johnfelstead
Scooby Specialist
 
Member#: 856
Join Date: Feb 2000
Chapter/Region: International
Location: Hampshire, England, UK
Vehicle:
2005 JDM STi
Black

Default

The MY05 JDM STi had the imobilisor, the MY05 JDM STi Spec C doesn't.
johnfelstead is offline   Reply With Quote
Old 10-10-2012, 06:26 PM   #4536
PHruska
Scooby Newbie
 
Member#: 214589
Join Date: Jun 2009
Chapter/Region: BAIC
Location: Berkeley CA/bozeman MT
Vehicle:
2002 wrx wagon
PSM

Default

what oil are you guys running in the 207? t6?
PHruska is offline   Reply With Quote
Old 10-10-2012, 06:37 PM   #4537
navydub
Scooby Newbie
 
Member#: 242585
Join Date: Mar 2010
Chapter/Region: MAIC
Location: Chesapeake, VA
Vehicle:
2005 Saabaru
Black

Default

Quote:
Originally Posted by johnfelstead View Post
MY05 JDM STi, it has an imobilisor.
****. Figured so. Called the company I bought it from, they confirmed it's a Ver9 immo'd ECU. They're getting me a ver8 ECU in the mail tomorrow. On the plus side the car idles well on the USDM ecu
navydub is offline   Reply With Quote
Old 10-10-2012, 08:05 PM   #4538
561wrx
Scooby Specialist
 
Member#: 166427
Join Date: Dec 2007
Chapter/Region: South East
Location: boynton bch, fl
Vehicle:
03 wrx

Default

Quote:
Originally Posted by PHruska
Had this headache:

ended up with this:

Free AVCS harness
Did u make that from a different wiring harness?
561wrx is offline   Reply With Quote
Old 10-10-2012, 08:06 PM   #4539
Zaider
Scooby Newbie
 
Member#: 154281
Join Date: Jul 2007
Chapter/Region: W. Canada
Location: Calgary, AB
Vehicle:
2002 V7 EJ207 Dom1.5
MBP

Default

Quote:
Originally Posted by PHruska View Post
what oil are you guys running in the 207? t6?
You should try giving this thread a read. Its been discussed several times.
Zaider is offline   Reply With Quote
Old 10-10-2012, 08:18 PM   #4540
mattrubywrx
Scooby Newbie
 
Member#: 315635
Join Date: Apr 2012
Vehicle:
04 STi
Aspen White

Default

hey guys,
so i recently effed up my turbo (vf30) so now im going to upgrade
does anyone have any suggestions for fordable aftermarket turbo options?
im looking for something with quick spool that mounts in the stock location. hoping to hit around 340awp, (currently at 306awp on the vf30)
my motor is a v7 ej207, 3" tbe catless exhaust, el headers, fmic,
mattrubywrx is online now   Reply With Quote
Old 10-10-2012, 08:20 PM   #4541
PHruska
Scooby Newbie
 
Member#: 214589
Join Date: Jun 2009
Chapter/Region: BAIC
Location: Berkeley CA/bozeman MT
Vehicle:
2002 wrx wagon
PSM

Default

Quote:
Originally Posted by Zaider

You should try giving this thread a read. Its been discussed several times.
That's funny. I've read every page but forgot. Didn't have time to search cause I was out getting fluids. Just looking for a quick piece of advice.
PHruska is offline   Reply With Quote
Old 10-10-2012, 08:23 PM   #4542
todeswalzer
Scooby Specialist
 
Member#: 191495
Join Date: Oct 2008
Chapter/Region: NESIC
Location: Lowell MA
Vehicle:
'05 WRB GTX3071R
JDM V8 EJ207 USDM 6MT

Default

Quote:
Originally Posted by mattrubywrx
hey guys,
so i recently effed up my turbo (vf30) so now im going to upgrade
does anyone have any suggestions for fordable aftermarket turbo options?
im looking for something with quick spool that mounts in the stock location. hoping to hit around 340awp, (currently at 306awp on the vf30)
my motor is a v7 ej207, 3" tbe catless exhaust, el headers, fmic,
20g should get you there
todeswalzer is offline   Reply With Quote
Old 10-10-2012, 09:14 PM   #4543
25rsti
Scooby Guru
 
Member#: 166324
Join Date: Dec 2007
Chapter/Region: NESIC
Location: Haverhill, MA
Vehicle:
3 turbos &n NA
@DBlockSTi

Default

Anyone know if a usdm wrx/sti crank position sensor will work for these engines? Does year matter? IF mine is bad I will need to order/buy a new one (want to be ahead of the curve for this)
25rsti is offline   Reply With Quote
Old 10-10-2012, 09:36 PM   #4544
mattrubywrx
Scooby Newbie
 
Member#: 315635
Join Date: Apr 2012
Vehicle:
04 STi
Aspen White

Default

Quote:
Originally Posted by todeswalzer View Post
20g should get you there
that will be rather laggy no?
mattrubywrx is online now   Reply With Quote
Old 10-10-2012, 10:59 PM   #4545
jhenry1983
Scooby Newbie
 
Member#: 269361
Join Date: Jan 2011
Chapter/Region: SCIC
Location: Los Angeles, CA
Vehicle:
2011 sti
03wrx Rallycar

Default

Quote:
Originally Posted by mattrubywrx

that will be rather laggy no?
Depends on what your using it for, but yes it will be more laggy then a vf30 for sure. The fmic doesnt help either as far as lag.

350 is doable with a 20g. If you have the cash the atp 3071gtx is the way to go. Stock location and the best fit for our motors. It also has an option for external wastegate coming from the compressor housing which is tits
jhenry1983 is offline   Reply With Quote
Old 10-10-2012, 11:22 PM   #4546
mattrubywrx
Scooby Newbie
 
Member#: 315635
Join Date: Apr 2012
Vehicle:
04 STi
Aspen White

Default

Quote:
Originally Posted by jhenry1983 View Post
Depends on what your using it for, but yes it will be more laggy then a vf30 for sure. The fmic doesnt help either as far as lag.

350 is doable with a 20g. If you have the cash the atp 3071gtx is the way to go. Stock location and the best fit for our motors. It also has an option for external wastegate coming from the compressor housing which is tits

ill have to take a look at that, any other ideas? im trying to narrow it down to a couple of turbos that are known for making reliable power on the ej207 motor, rather then researching and reading about a million of them and getting confused
mattrubywrx is online now   Reply With Quote
Old 10-11-2012, 01:00 AM   #4547
PHruska
Scooby Newbie
 
Member#: 214589
Join Date: Jun 2009
Chapter/Region: BAIC
Location: Berkeley CA/bozeman MT
Vehicle:
2002 wrx wagon
PSM

Default

nvm got it.

but the intercooler shipped with a y pipe but no elbow.... time to call the dealer again....

Just started it up for the first time... had a massive PS leak and make a lot of smoke but she runs. sounds pretty good, but have a CEL that im not sure where is coming from. need to get a reader/tactrix first.

Last edited by PHruska; 10-11-2012 at 03:29 AM.
PHruska is offline   Reply With Quote
Old 10-11-2012, 07:32 AM   #4548
todeswalzer
Scooby Specialist
 
Member#: 191495
Join Date: Oct 2008
Chapter/Region: NESIC
Location: Lowell MA
Vehicle:
'05 WRB GTX3071R
JDM V8 EJ207 USDM 6MT

Default

Quote:
Originally Posted by mattrubywrx

ill have to take a look at that, any other ideas? im trying to narrow it down to a couple of turbos that are known for making reliable power on the ej207 motor, rather then researching and reading about a million of them and getting confused
Quote:
Originally Posted by jhenry1983

Depends on what your using it for, but yes it will be more laggy then a vf30 for sure. The fmic doesnt help either as far as lag.

350 is doable with a 20g. If you have the cash the atp 3071gtx is the way to go. Stock location and the best fit for our motors. It also has an option for external wastegate coming from the compressor housing which is tits
My setup is a dr725 fmic and an ATP gtx3071r w/ ewg


I'm pretty sure he mentioned an affordable option is what he wants. My turbo alone was $2300, kinda rules that out

Its still a week or 2 from running so I have no information/numbers for ya as of yet.


But if you want 340whp you're going to give up some spool. Period.
todeswalzer is offline   Reply With Quote
Old 10-11-2012, 09:47 AM   #4549
WRick
Scooby Newbie
 
Member#: 86107
Join Date: Apr 2005
Chapter/Region: E. Canada
Location: 10% REAL FRUIT JUICE
Default

Quote:
Originally Posted by 25rsti View Post
Anyone know if a usdm wrx/sti crank position sensor will work for these engines? Does year matter? IF mine is bad I will need to order/buy a new one (want to be ahead of the curve for this)
I took one off a legacy 2.5i 2007 and it's fine.
WRick is offline   Reply With Quote
Old 10-11-2012, 11:52 AM   #4550
PHruska
Scooby Newbie
 
Member#: 214589
Join Date: Jun 2009
Chapter/Region: BAIC
Location: Berkeley CA/bozeman MT
Vehicle:
2002 wrx wagon
PSM

Default

So with throwing a code on the Jdm ecu can I uSe a code reader to get the code or will I only
Be able to through romraider?
PHruska is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ej207 owner wants opinions adbramsay Factory 2.0L Turbo Powertrain 2 02-26-2011 07:29 PM
Ej207 V6 AndrewFD3 Factory 2.0L Turbo Powertrain 10 06-03-2010 04:53 PM
JDM Sti EJ207 V9 crank 75mm or billet crank (K1, Manley) VENDORS ??? L'frise Private 'Wanted' Classifieds 7 06-03-2010 09:24 AM
08 ej207 JDM dual AVCS heads on a built v7 ej207 icev7 Built Motor Discussion 17 02-21-2010 03:21 PM
Ver 8 EJ207 Owners Check In spoolinsuby Factory 2.0L Turbo Powertrain 21 10-17-2005 01:56 AM


All times are GMT -4. The time now is 10:09 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.