Welcome to the North American Subaru Impreza Owners Club Tuesday November 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-10-2013, 08:42 PM   #6301
mrxr250rider
Scooby Specialist
 
Member#: 271412
Join Date: Jan 2011
Chapter/Region: Tri-State
Location: avoca pa
Vehicle:
05 ej207 wrx wagon
wrb

Default

notice any ticking at cold starts? my header to up pipe leak was small at first from the previous owner. really only noticeable on cold start up. now its bad and can be heard all the time.

i had it tuned with the leak,i never had any complaints but id say i lost some spool because of it and now it just sucks

edit: just looked at a log on efi's data base. i also hit full boost at 4k(prob due to header to up pipe leak). still made good numbers on 18psi. 298/264. my most recent log isnt on there from when i was retuned for 21psi but it put down 310/288.
* Registered users of the site do not see these ads.

Last edited by mrxr250rider; 04-10-2013 at 09:01 PM.
mrxr250rider is offline   Reply With Quote
Old 04-10-2013, 09:53 PM   #6302
JulianDelphiki
Scooby Specialist
 
Member#: 307912
Join Date: Jan 2012
Chapter/Region: South East
Location: FL
Vehicle:
1997 OBS V8 Ej207
Stimikey tuned

Default

took the uppipe header and dp off. Didnt look like it was leaking(no soot on gaskets) and took the heatshields off(screw you subaru). Now to find some decent replacement gaskets

JulianDelphiki is offline   Reply With Quote
Old 04-11-2013, 12:46 AM   #6303
Whoracle
Scooby Newbie
 
Member#: 301075
Join Date: Nov 2011
Chapter/Region: NWIC
Location: Sumner
Vehicle:
2003 Impreza WRX
Silver

Default

Just picked up my bugeye from the mechanic, the 207 is amazing! I was wondering what people are using to replace their splitter/bellows or did you all just modify the stock one?
Whoracle is offline   Reply With Quote
Old 04-11-2013, 08:09 AM   #6304
25rsti
Scooby Guru
 
Member#: 166324
Join Date: Dec 2007
Chapter/Region: NESIC
Location: Haverhill, MA
Vehicle:
3 turbos &n NA
@DBlockSTi

Default

I have a JDM splitter and JDM hood scoop.
25rsti is offline   Reply With Quote
Old 04-11-2013, 08:38 AM   #6305
Mountain
Scooby Newbie
 
Member#: 331271
Join Date: Sep 2012
Location: Vermont
Vehicle:
03 WRX
Aspen White

Default

Quote:
Originally Posted by Whoracle View Post
Just picked up my bugeye from the mechanic, the 207 is amazing! I was wondering what people are using to replace their splitter/bellows or did you all just modify the stock one?
JDM splitter and scoop is the only way to go
Mountain is offline   Reply With Quote
Old 04-11-2013, 10:40 AM   #6306
Vlad
Scooby Guru
 
Member#: 46135
Join Date: Oct 2003
Chapter/Region: Tri-State
Location: NY
Vehicle:
02 WRX
Sti V9 Spec C

Default

JDM scoop, USDM GRB intercooler, splitter/bellows made by me, using Subaru parts.
The JDM scoop compleetly feeds the GRB intercooler, with no room for louvers for the top of the turbo.
Vlad is offline   Reply With Quote
Old 04-11-2013, 02:28 PM   #6307
kyle.hoyer
Scooby Newbie
 
Member#: 327892
Join Date: Aug 2012
Chapter/Region: MAIC
Location: Manassas, VA
Vehicle:
2002 WRX
PSM

Default

That's interesting reading about to guys only hitting full boost at around 4. I have a V7 with 18g and don't hit full boost (18psi) until like 4. That should be normal right? You have me worried about leaks now and missing out on quicker spool
kyle.hoyer is online now   Reply With Quote
Old 04-11-2013, 08:00 PM   #6308
JulianDelphiki
Scooby Specialist
 
Member#: 307912
Join Date: Jan 2012
Chapter/Region: South East
Location: FL
Vehicle:
1997 OBS V8 Ej207
Stimikey tuned

Default

Quote:
Originally Posted by WhiteBgeye02 View Post
post a log if you dont mind or email it to me w/ wgdc logged. Brad498Bahr@aol.com. I am the local tuner in the North and East Wisconsin area so i should be able to see if there are any mistakes. phatbotti prob never makes mistakes tho
I took both heat shields off and seafoamed the bov vac line looking for leaks in the uppipe/header, none were found.

Here is a log to 5.5k. Full boost at 4.1k. AVCS appears to be working correctly also. Lmk
https://docs.google.com/spreadsheet/...UE&usp=sharing
JulianDelphiki is offline   Reply With Quote
Old 04-11-2013, 08:16 PM   #6309
mrxr250rider
Scooby Specialist
 
Member#: 271412
Join Date: Jan 2011
Chapter/Region: Tri-State
Location: avoca pa
Vehicle:
05 ej207 wrx wagon
wrb

Default

Whitebugeye. What does wgdc have to do with it? I have an adjustable waste gate actuator. It's set to 18psi. Would that cause a slower spool?
mrxr250rider is offline   Reply With Quote
Old 04-11-2013, 08:41 PM   #6310
25rsti
Scooby Guru
 
Member#: 166324
Join Date: Dec 2007
Chapter/Region: NESIC
Location: Haverhill, MA
Vehicle:
3 turbos &n NA
@DBlockSTi

Default

Do any of you guys have any compressor surge?
25rsti is offline   Reply With Quote
Old 04-11-2013, 08:52 PM   #6311
Psychoreo
Scooby Guru
 
Member#: 79643
Join Date: Jan 2005
Chapter/Region: NESIC
Location: Cromwell
Vehicle:
2015 WRX STI
Terminal black pearl

Default

Quote:
Originally Posted by 25rsti View Post
Do any of you guys have any compressor surge?
I get some flutter when letting off the throttle in certain driving situations that some may call compressor surge.

Stock jdm bpv
Psychoreo is online now   Reply With Quote
Old 04-11-2013, 08:53 PM   #6312
25rsti
Scooby Guru
 
Member#: 166324
Join Date: Dec 2007
Chapter/Region: NESIC
Location: Haverhill, MA
Vehicle:
3 turbos &n NA
@DBlockSTi

Default

Same here. Trying to understand why, and maybe, fix?
25rsti is offline   Reply With Quote
Old 04-11-2013, 08:58 PM   #6313
Psychoreo
Scooby Guru
 
Member#: 79643
Join Date: Jan 2005
Chapter/Region: NESIC
Location: Cromwell
Vehicle:
2015 WRX STI
Terminal black pearl

Default

Quote:
Originally Posted by 25rsti View Post
Same here. Trying to understand why, and maybe, fix?
Mine only seems to happen at higher boost/half throttle situations when I let off the throttle. It's not hurting anything so I don't worry about it.
Psychoreo is online now   Reply With Quote
Old 04-11-2013, 09:08 PM   #6314
25rsti
Scooby Guru
 
Member#: 166324
Join Date: Dec 2007
Chapter/Region: NESIC
Location: Haverhill, MA
Vehicle:
3 turbos &n NA
@DBlockSTi

Default

I've read that compressor surge is bad on journal bearing turbos like my VF37.
25rsti is offline   Reply With Quote
Old 04-11-2013, 09:10 PM   #6315
Psychoreo
Scooby Guru
 
Member#: 79643
Join Date: Jan 2005
Chapter/Region: NESIC
Location: Cromwell
Vehicle:
2015 WRX STI
Terminal black pearl

Default

Quote:
Originally Posted by 25rsti View Post
I've read that compressor surge is bad on journal bearing turbos like my VF37.
Real compressor surge or that little flutter?

Sure, it's not good. But it's not going to explode tomorrow. How often does it do it?
Psychoreo is online now   Reply With Quote
Old 04-11-2013, 09:14 PM   #6316
25rsti
Scooby Guru
 
Member#: 166324
Join Date: Dec 2007
Chapter/Region: NESIC
Location: Haverhill, MA
Vehicle:
3 turbos &n NA
@DBlockSTi

Default

Well, my car's down right now for wheel bearings so I haven't driven it 20 miles yet but it sounds like the same as your situation. So, not often.
25rsti is offline   Reply With Quote
Old 04-11-2013, 09:22 PM   #6317
Psychoreo
Scooby Guru
 
Member#: 79643
Join Date: Jan 2005
Chapter/Region: NESIC
Location: Cromwell
Vehicle:
2015 WRX STI
Terminal black pearl

Default

I'd worry about other things then
Psychoreo is online now   Reply With Quote
Old 04-11-2013, 09:25 PM   #6318
mrxr250rider
Scooby Specialist
 
Member#: 271412
Join Date: Jan 2011
Chapter/Region: Tri-State
Location: avoca pa
Vehicle:
05 ej207 wrx wagon
wrb

Default

I think it happens to any wrx with a bpv in that situation. Not something to worry about.
mrxr250rider is offline   Reply With Quote
Old 04-11-2013, 09:42 PM   #6319
25rsti
Scooby Guru
 
Member#: 166324
Join Date: Dec 2007
Chapter/Region: NESIC
Location: Haverhill, MA
Vehicle:
3 turbos &n NA
@DBlockSTi

Default

Hm, I thought it was any wrx/sti with a bov and the bpv cured it. Ah well, I guess if it's a normal thing with the 207 crowd I won't worry too much about it.
25rsti is offline   Reply With Quote
Old 04-11-2013, 09:55 PM   #6320
mrxr250rider
Scooby Specialist
 
Member#: 271412
Join Date: Jan 2011
Chapter/Region: Tri-State
Location: avoca pa
Vehicle:
05 ej207 wrx wagon
wrb

Default

I thought it was the other way around actually lol.
mrxr250rider is offline   Reply With Quote
Old 04-11-2013, 09:58 PM   #6321
25rsti
Scooby Guru
 
Member#: 166324
Join Date: Dec 2007
Chapter/Region: NESIC
Location: Haverhill, MA
Vehicle:
3 turbos &n NA
@DBlockSTi

Default

Do you have the same symptoms?
25rsti is offline   Reply With Quote
Old 04-11-2013, 10:00 PM   #6322
mrxr250rider
Scooby Specialist
 
Member#: 271412
Join Date: Jan 2011
Chapter/Region: Tri-State
Location: avoca pa
Vehicle:
05 ej207 wrx wagon
wrb

Default

Yes with forge bpv. I just try to stay out of boost partial throttle unless its low boost
mrxr250rider is offline   Reply With Quote
Old 04-11-2013, 10:10 PM   #6323
WhiteBgeye02
Scooby Specialist
 
Member#: 224785
Join Date: Sep 2009
Chapter/Region: MWSOC
Location: neenah
Vehicle:
2005 wrx-jdm207
i went black...

Default

Quote:
Originally Posted by mrxr250rider View Post
Whitebugeye. What does wgdc have to do with it? I have an adjustable waste gate actuator. It's set to 18psi. Would that cause a slower spool?
well r u shooting for 18psi then? whats ur boost control setup?
WhiteBgeye02 is offline   Reply With Quote
Old 04-11-2013, 10:11 PM   #6324
JulianDelphiki
Scooby Specialist
 
Member#: 307912
Join Date: Jan 2012
Chapter/Region: South East
Location: FL
Vehicle:
1997 OBS V8 Ej207
Stimikey tuned

Default

Apparently the lag I have is all the time and not just below 4k. If I coast to 4k then mash the gas it takes until 4.7k to fully hit. It sounds more and more like a preturbo exhaust leak but for the life of me I can not find it. How can I tell if the turbo is going bad?
JulianDelphiki is offline   Reply With Quote
Old 04-11-2013, 10:22 PM   #6325
WhiteBgeye02
Scooby Specialist
 
Member#: 224785
Join Date: Sep 2009
Chapter/Region: MWSOC
Location: neenah
Vehicle:
2005 wrx-jdm207
i went black...

Default

Quote:
Originally Posted by JulianDelphiki View Post
Apparently the lag I have is all the time and not just below 4k. If I coast to 4k then mash the gas it takes until 4.7k to fully hit. It sounds more and more like a preturbo exhaust leak but for the life of me I can not find it. How can I tell if the turbo is going bad?
did u do a compression test ever? i saw an engine with low compression spool a turbo super slow
WhiteBgeye02 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ej207 owner wants opinions adbramsay Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 2 02-26-2011 08:29 PM
Ej207 V6 AndrewFD3 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 10 06-03-2010 05:53 PM
JDM Sti EJ207 V9 crank 75mm or billet crank (K1, Manley) VENDORS ??? L'frise Private 'Wanted' Classifieds 7 06-03-2010 10:24 AM
08 ej207 JDM dual AVCS heads on a built v7 ej207 icev7 Built Motor Discussion 17 02-21-2010 04:21 PM
Ver 8 EJ207 Owners Check In spoolinsuby Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 21 10-17-2005 02:56 AM


All times are GMT -4. The time now is 05:23 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.