Welcome to the North American Subaru Impreza Owners Club Friday October 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
View Poll Results: Bad gasoline or no?
Shouldn't have bought that crappy gas! 6 100.00%
Naw, sounds like something else to me. 0 0%
Voters: 6. You may not vote on this poll

Reply
 
Thread Tools Display Modes
Old 11-01-2001, 02:37 AM   #1
DAUTHI
Scooby Newbie
 
Member#: 840
Join Date: Feb 2000
Location: Everywhere!!!
Vehicle:
GC8! '00 2.5RS
Silverthorne and mud

Question Opinions needed! Bad gas?

No, no! Gasoline you silly fool!

But seriously, I have recently noticed an extremely foul odor(sulfurish) eminating from my cars tail pipe. This was like two days ago. Tonight the smell remains and now I throw a CEL! Tried two ECU resets, CEL returns within 1 minute of warm up. My AFR monitor shows nothing unusual with the mixture.

The reason I'm pretty sure it's bad gas is, about a day before the smell I filled the tank at a gas station of questionable virtue because that was all I had around at the moment. BTW it's Clark's for any of you mid western folk.

I just want some input as I have never, to my knowedge, bought bad gas before. I try to usually use Shell here, and in NY it was Mobile only for me. Both of those have treated me well. Is this the kind of stuff a bad tank of gas will do?

Make me feel better! I gotta drive 400 miles on friday. And no, I have no Subaru dealer to check with up here.

Pete "Stinky" W.

P.S. I know all about bad O2 sensors. Been there done that X2, this is NOT a bad O2 sensor.
* Registered users of the site do not see these ads.

Last edited by DAUTHI; 11-01-2001 at 03:09 AM.
DAUTHI is offline   Reply With Quote
Old 11-01-2001, 07:07 AM   #2
tmat3
Scooby Specialist
 
Member#: 2817
Join Date: Nov 2000
Location: NYC and Troy, NY
Vehicle:
2001 Impreza 2.5RS
BRP

Default

My g/f's mom got a 97 Thunderbird, and when she put bad gas in the tank, CE light came on a little after. I would put better gas once you get an empty tank, then let the engine do the rest and see what happens.
tmat3 is offline   Reply With Quote
Old 11-01-2001, 10:36 AM   #3
trojan9x
Scooby Specialist
 
Member#: 3169
Join Date: Dec 2000
Location: Effort, PA
Vehicle:
2001 2.5 RS: Holbert
Memorial Winner 2003

Default

let your car run and burn off the gas, make the the cap is on tight (happened to me CEL), get real gas, and put some fuel injection cleaner in there too incase that bad gas did any bad stuff
trojan9x is offline   Reply With Quote
Old 11-01-2001, 06:29 PM   #4
Iowannaski
Scooby Specialist
 
Member#: 8268
Join Date: Jul 2001
Location: Brighton, MA
Vehicle:
00 GM67
BRP me ASAP

Default

Quote:
Originally posted by trojan9x
let your car run and burn off the gas


If you're going to burn off the gas, just drive it. If you want to get rid of the gas, disconnect the fuel line and drain it. Of course, I'm not going to make any suggestion as to what you should do with 10 gal. of gas. Do you have a lawnmower?
Iowannaski is offline   Reply With Quote
Old 11-01-2001, 08:34 PM   #5
DAUTHI
Scooby Newbie
 
Member#: 840
Join Date: Feb 2000
Location: Everywhere!!!
Vehicle:
GC8! '00 2.5RS
Silverthorne and mud

Default

Ha! No lanmower. I'll burn it driving. I got 400+ miles to do tomorrow. I did throw in a can of "dry gas" just in case tho.

Guess we'll see!

Pete
DAUTHI is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
good gas? bad gas? scubiesnacks19 Texas Impreza Club Forum -- TXIC 4 02-16-2007 10:49 AM
Need Advice - Bad Gas Furnace Kevin Thomas Off-Topic 8 10-29-2005 07:05 PM
Bad gas at this SD gas station bzWrx Southern California Impreza Club Forum -- SCIC 8 01-31-2003 04:18 PM
Bad gas in Milwaukee Danno Mid West Subaru Owners Club Forum -- MWSOC 6 05-05-2001 07:09 AM
Good gas/Bad gas Lets hear it! skuttledude General Forum Archive 6 08-01-2000 09:41 AM


All times are GMT -4. The time now is 10:29 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.