Welcome to the North American Subaru Impreza Owners Club Thursday September 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-01-2001, 08:20 PM   #1
Andursun0013
Scooby Specialist
 
Member#: 11616
Join Date: Oct 2001
Location: Coweta, OK
Vehicle:
1998 2.35RS-T
2006 Baja 2007 Leg. Wagon

Question Need some help!

My car seems to run fine, but i get a little bit of hesitation right around 2500 rpms. Does anybody know what might be wrong, is it a common problem with subaru?
* Registered users of the site do not see these ads.
Andursun0013 is offline   Reply With Quote
Old 11-01-2001, 08:27 PM   #2
Peaty
Techno Sapien
Moderator
 
Member#: 449
Join Date: Oct 1999
Chapter/Region: MWSOC
Location: Lawrence, KS
Vehicle:
2010 Legacy 3.6R Lim
Azurite Blue Pearl

Default

How old are your sparkplug wires and plugs. Some did have a problem look here:

http://www.geocities.com/hobiegary/hesitation.htm

Peaty
Peaty is offline   Reply With Quote
Old 11-02-2001, 04:14 PM   #3
Scoobyru
Scooby Newbie
 
Member#: 9772
Join Date: Aug 2001
Location: Rockford MI
Vehicle:
1997 Jeep
Wrangler. Slow slow slow!

Default

Maybe a clogged fuel filter or dirty injectors? Try some fuel injector cleaner. These are the simplest solutions.
Joe
Scoobyru is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need some help with cooling system... subi400 Service & Maintenance 1 06-04-2010 02:49 PM
New WRX and need some help on some mods 02WRXguy Texas Impreza Club Forum -- TXIC 19 07-16-2002 11:49 PM
Need some help choosing some upgrades FlaaB Factory 2.0L Turbo Powertrain 4 06-04-2002 12:00 PM
Possible Impreza purchase, have some ?'s, need some help. STi2001 Normally Aspirated with bolt-on Forced Induction Powertrain 4 10-14-2001 11:10 PM
I need some help and some answers coloradobound Normally Aspirated Powertrain 3 02-23-2001 02:01 PM


All times are GMT -4. The time now is 12:55 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.