Welcome to the North American Subaru Impreza Owners Club Friday April 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-24-2006, 06:01 PM   #1
RR02wrx
Scooby Specialist
 
Member#: 99614
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: NJ
Vehicle:
00 Impreza
BRP

Default RR's Swap Progress pt. 2

UPDATED PICTURES PG.#3/Small crappy vid pg. 4~

Figured I'd make another thread as the other one was already 56k unfriendly and if I added anymore pics 56k users would give up befor they all loaded. Anywho: Updates - Well when I had to drop my class because of the accident, and the PA hospital told me a had a 'slight' concussion and a little whiplash.. yeah, well that was totally wrong. I went for cat scans here in NJ and they found I had a subderal hematoma (brain = bleeding). About a month of rest and i'm feeling good again. I moved all of my stuff home from hellhole blairsville PA.. some updated pics of the car:




f'in glare








Still messy.. but you can actually see the pedals now!






Ready to go home

The car is so close to being done... I give it 2 weeks. Now that its home it will be easy, and I have a few friends that will come and help me. Hopefully we don't run into anymore problems! Thanks for any comments, I know you swapped people know how anxious I am to drive this damn thing.. Thread will be updated when the car is up and running; hopefully some vids also. Oh yeah, I just ordered Accessport today. Stage 2 woot.
* Registered users of the site do not see these ads.

Last edited by RR02wrx; 05-04-2007 at 07:27 AM.
RR02wrx is offline   Reply With Quote
Old 09-25-2006, 07:25 PM   #2
RR02wrx
Scooby Specialist
 
Member#: 99614
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: NJ
Vehicle:
00 Impreza
BRP

Default



RR02wrx is offline   Reply With Quote
Old 09-25-2006, 07:27 PM   #3
Spilner
Scooby Specialist
 
Member#: 63977
Join Date: Jun 2004
Chapter/Region: NESIC
Location: Mass
Vehicle:
2005 STi
WRB

Default

very nice I'm digging the brp on bronze, ar eyou doing the dash swap as well?
Spilner is offline   Reply With Quote
Old 09-25-2006, 07:43 PM   #4
RR02wrx
Scooby Specialist
 
Member#: 99614
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: NJ
Vehicle:
00 Impreza
BRP

Default

Thanks. I'd love to but after buying the Accessport i'm flat broke.. Just using the 04 cluster in the gc dash.
RR02wrx is offline   Reply With Quote
Old 09-25-2006, 07:47 PM   #5
83Rabbit
Scooby Specialist
 
Member#: 5050
Join Date: Mar 2001
Chapter/Region: MAIC
Default

your sideskirt fell off...



























lol jk, nice
83Rabbit is offline   Reply With Quote
Old 09-27-2006, 05:36 PM   #6
RR02wrx
Scooby Specialist
 
Member#: 99614
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: NJ
Vehicle:
00 Impreza
BRP

Default


Last edited by RR02wrx; 12-18-2006 at 10:20 PM.
RR02wrx is offline   Reply With Quote
Old 09-27-2006, 06:01 PM   #7
Spilner
Scooby Specialist
 
Member#: 63977
Join Date: Jun 2004
Chapter/Region: NESIC
Location: Mass
Vehicle:
2005 STi
WRB

Default

Quote:
Originally Posted by RR02wrx View Post
Thanks. I'd love to but after buying the Accessport i'm flat broke.. Just using the 04 cluster in the gc dash.
nice, it makes a huge difference. keep up the good work
Spilner is offline   Reply With Quote
Old 10-03-2006, 09:19 PM   #8
RR02wrx
Scooby Specialist
 
Member#: 99614
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: NJ
Vehicle:
00 Impreza
BRP

Default



Is that a fuel pump I hear in the backround trying to prime...?
RR02wrx is offline   Reply With Quote
Old 10-07-2006, 06:05 PM   #9
RR02wrx
Scooby Specialist
 
Member#: 99614
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: NJ
Vehicle:
00 Impreza
BRP

Default

Swapped brakes (because I put them in backwards ) and turned the rotors..


(Temporarily sprayed the unpainted parts a cheap gold until they get repainted or powdercoated black)
RR02wrx is offline   Reply With Quote
Old 10-08-2006, 01:28 PM   #10
ilgdrummer
Scooby Newbie
 
Member#: 28364
Join Date: Oct 2002
Chapter/Region: SCIC
Location: San Diego
Vehicle:
2004 Wagon STI
Java Black

Default

Hey,
Beautiful car, I always loved the 4 doors been looking for one, but for now Im stuck witha 2 door. Did you just swap everything out of an sti straight to the gc shell? I want to do the samething, but I'm wondering if you got stuck anywhere, it seems pretty simple just take everything off the sti and put it on the gc shell. Any info would be great.
Looking good,
Tony
ilgdrummer is offline   Reply With Quote
Old 10-08-2006, 01:50 PM   #11
RR02wrx
Scooby Specialist
 
Member#: 99614
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: NJ
Vehicle:
00 Impreza
BRP

Default

Yeah, pretty much. No custom modifications.. except to get that GD gauge cluster in the GC dash. All the mechanical stuff bolts right up, I even swapped fuel tanks. The only issues with doing it is that track width on a GD is around 20mm wider than the gc track, so that will cause some rubbing if it's not accounted for. Other than that, pretty straightforward. Not a terrible ammount of wiring/splicing, but there definatly is some to be done.
RR02wrx is offline   Reply With Quote
Old 10-08-2006, 02:17 PM   #12
ilgdrummer
Scooby Newbie
 
Member#: 28364
Join Date: Oct 2002
Chapter/Region: SCIC
Location: San Diego
Vehicle:
2004 Wagon STI
Java Black

Default

Ok, so you didn't swap the whole dash? Just the gauge cluster? As far as wiring and splicing what components required it? I considering doing the same thing and Im just trying to get some info. How much did you pay for the donor sti? Do you know if any specific year is best 04-06?
Thanks again,
Tony
ilgdrummer is offline   Reply With Quote
Old 10-08-2006, 02:19 PM   #13
ilgdrummer
Scooby Newbie
 
Member#: 28364
Join Date: Oct 2002
Chapter/Region: SCIC
Location: San Diego
Vehicle:
2004 Wagon STI
Java Black

Default

Ok, so you didn't swap the whole dash? Just the gauge cluster? As far as wiring and splicing what components required it? I considering doing the same thing and Im just trying to get some info. How much did you pay for the donor sti? Do you know if any specific year is best 04-06?
Thanks again,
Tony
ilgdrummer is offline   Reply With Quote
Old 10-08-2006, 05:38 PM   #14
RR02wrx
Scooby Specialist
 
Member#: 99614
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: NJ
Vehicle:
00 Impreza
BRP

Default

Nope kept the GC dash.. Im still undecided about it. I want to see how off the fitment is in person befor I make the final decision.. some say its bad, but from what ive seen in pics and stuff its not too terrible. Wiring... all 4 doors, front/rear/side lights, side window controls if you have them, defrosters, HVAC, potentially steering column items(signals, windshield wipers, horn, ignition, etc), dome lights, airbags, potentially cluster if you dont get the gd cluster... hmm, thats all I can think of off the top of my head. I paid 10k for it all. Well the newest years are the best, especially in 07 because of some dccd upgrades and stuff.. but obviously they'll be more expensive. Good luck
RR02wrx is offline   Reply With Quote
Old 10-19-2006, 07:30 PM   #15
RR02wrx
Scooby Specialist
 
Member#: 99614
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: NJ
Vehicle:
00 Impreza
BRP

Default

Ok, the car is running. I can't get it to idle below 1800 though. Anyone have any clue why? I dont like letting it run for long because it hangs just below 2k the whole time and i'm worried about it overheating. I had it running for like 15 minutes today... the fans went on and off a few times...etc, but I eventually just shut it off. It also does "pop" very quietly when it gets to around the 10 min mark of being on. Im just trying to be as cautious as possible I dont want to run it for a long time if it's going to damage anything... I just can't figure out why it wont drop below 1800. Also, I installed the AP on it, blah blah whatever. There is a check engine light on, and when I try to check it the AP tells me there are no trouble codes.
RR02wrx is offline   Reply With Quote
Old 10-19-2006, 08:13 PM   #16
t3hWIT
Scooby Guru
 
Member#: 58779
Join Date: Apr 2004
Chapter/Region: MAIC
Location: **** Town
Vehicle:
95 STi RA (rhd)
98 Tacoma (300k Club)

Default

Are the coolant hoses hooked up to the throttle body? I did the TB bypass mod on my car and the idle is often around 1600rpm.
t3hWIT is offline   Reply With Quote
Old 10-19-2006, 08:27 PM   #17
RR02wrx
Scooby Specialist
 
Member#: 99614
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: NJ
Vehicle:
00 Impreza
BRP

Default

I'd assume so yes, everything is hooked up on the engine.. If not wouldn't coolant be spewing everywhere?
RR02wrx is offline   Reply With Quote
Old 10-20-2006, 12:05 AM   #18
Jaxx
NASIOC Supporter
 
Member#: 177
Join Date: Aug 1999
Chapter/Region: NWIC
Location: Boise,Idaho,USA
Vehicle:
The 93 Imp W/EJ20K
flat black

Default

vaccuem leak ...?


are there any cels?
Jaxx is offline   Reply With Quote
Old 10-20-2006, 12:23 AM   #19
jamesfacts
NASIOC Supporter
 
Member#: 51282
Join Date: Dec 2003
Chapter/Region: Tri-State
Location: Brooklyn NYC / Danbury CT
Vehicle:
98 RS
black & blue from parking

Default

Quote:
Originally Posted by RR02wrx View Post
Nope kept the GC dash.. Im still undecided about it. I want to see how off the fitment is in person befor I make the final decision.. some say its bad, but from what ive seen in pics and stuff its not too terrible. Wiring... all 4 doors, front/rear/side lights, side window controls if you have them, defrosters, HVAC, potentially steering column items(signals, windshield wipers, horn, ignition, etc), dome lights, airbags, potentially cluster if you dont get the gd cluster... hmm, thats all I can think of off the top of my head. I paid 10k for it all. Well the newest years are the best, especially in 07 because of some dccd upgrades and stuff.. but obviously they'll be more expensive. Good luck
The dash fit is only as good as the installer.

Quote:
Originally Posted by RR02wrx View Post
I'd assume so yes, everything is hooked up on the engine.. If not wouldn't coolant be spewing everywhere?
Some people bypass the tb using a brass pill or whatever.
jamesfacts is offline   Reply With Quote
Old 10-21-2006, 03:32 AM   #20
RR02wrx
Scooby Specialist
 
Member#: 99614
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: NJ
Vehicle:
00 Impreza
BRP

Default

Quote:
Originally Posted by Jaxx View Post
vaccuem leak ...?


are there any cels?
There is a CEL but when I try to check it with my AP it says there are no trouble codes. Tried with a buddys AP and it said the same thing. I don't beleive there is a vacum leak but I should go check...
RR02wrx is offline   Reply With Quote
Old 10-22-2006, 01:02 PM   #21
thahaminator
Scooby Specialist
 
Member#: 22738
Join Date: Aug 2002
Chapter/Region: MAIC
Location: MD
Default

Looking good and alot better than when I last saw it.
thahaminator is offline   Reply With Quote
Old 10-22-2006, 08:11 PM   #22
RR02wrx
Scooby Specialist
 
Member#: 99614
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: NJ
Vehicle:
00 Impreza
BRP

Default

Quote:
Originally Posted by thahaminator View Post
Looking good and alot better than when I last saw it.
Thanks man. When are you going to get some pics of yours online? The car is so close to being done... have to bleed the clutch and fix whatever is up with the gas pedal and I can take her out on the first drive.

I'd really love to know why it idles so high though. Do I just need to take it on a few drive cycles since the engine hasnt been running in so long? Ive only kept it on for 15 minutes max..
RR02wrx is offline   Reply With Quote
Old 10-23-2006, 12:19 AM   #23
jamesfacts
NASIOC Supporter
 
Member#: 51282
Join Date: Dec 2003
Chapter/Region: Tri-State
Location: Brooklyn NYC / Danbury CT
Vehicle:
98 RS
black & blue from parking

Default

Quote:
Originally Posted by RR02wrx View Post
Thanks man. When are you going to get some pics of yours online? The car is so close to being done... have to bleed the clutch and fix whatever is up with the gas pedal and I can take her out on the first drive.

I'd really love to know why it idles so high though. Do I just need to take it on a few drive cycles since the engine hasnt been running in so long? Ive only kept it on for 15 minutes max..
The idle should settle down within a minute of startup. Go back with a pressure tester and look for vac leaks.
jamesfacts is offline   Reply With Quote
Old 10-23-2006, 10:11 PM   #24
RR02wrx
Scooby Specialist
 
Member#: 99614
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: NJ
Vehicle:
00 Impreza
BRP

Default

Quote:
Originally Posted by americanyouth View Post
The idle should settle down within a minute of startup. Go back with a pressure tester and look for vac leaks.
Could it potentially be something to do with the fact that my gas pedal doesn't work at all? I have to check the fuses and such.. if no fuses related to the throttle or pedal are blown then I will take the gas pedal assembly out and try to figure something out. It's pretty frustrating to be this close and I cant figure out these few things.
RR02wrx is offline   Reply With Quote
Old 10-24-2006, 02:20 PM   #25
jamesfacts
NASIOC Supporter
 
Member#: 51282
Join Date: Dec 2003
Chapter/Region: Tri-State
Location: Brooklyn NYC / Danbury CT
Vehicle:
98 RS
black & blue from parking

Default

Quote:
Originally Posted by RR02wrx View Post
Could it potentially be something to do with the fact that my gas pedal doesn't work at all? I have to check the fuses and such.. if no fuses related to the throttle or pedal are blown then I will take the gas pedal assembly out and try to figure something out. It's pretty frustrating to be this close and I cant figure out these few things.
That would absolutely do it. Fortunately, gas pedals are not expensive from the dealer - $90 at cost and I think $130 retail.
jamesfacts is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
my swap progress Jaxx Subaru Conversions 207 05-20-2011 08:47 PM
my swap progress EJ20G homemade Rocky Mountains Impreza Club Forum -- RMIC 63 06-01-2010 05:06 PM
Swap progress with the ugly panda Not All There Subaru Conversions 82 05-10-2008 07:29 PM
my swap progress ImprezaRSfan! Subaru Conversions 23 05-31-2004 11:54 PM
Silvia swap progress Blugin Texas Impreza Club Forum -- TXIC 29 05-01-2003 11:10 PM


All times are GMT -4. The time now is 12:11 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.