Welcome to the North American Subaru Impreza Owners Club Saturday December 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-03-2001, 01:31 PM   #1
keystone
Scooby Newbie
 
Member#: 9807
Join Date: Aug 2001
Location: Saint Louis, MO
Vehicle:
2002 WRX
BLUE

Default I think i have something wrong...

I allready had my ECU re-programmed cause it was running to close to tollerance, and the ecu shut-down 2 cyls. My gas milage has sucked entire time except for the first 2 weeks I had the car. If I drive nice ill get 190m/tank.

But if I have any fun at all i get like 150!

Im taking my car in cause it aint right.....
* Registered users of the site do not see these ads.
keystone is offline   Reply With Quote
Old 11-03-2001, 01:54 PM   #2
HndaTch627
Scooby Guru
 
Member#: 6551
Join Date: May 2001
Chapter/Region: MWSOC
Location: Carol Stream, IL
Vehicle:
'01 GC8 Dinged STM
'09 Concours 14 ABS Black

Default

well driving style will dictate puel consumptiuon...spending alot of time in boost will KILL your gas mileage. May want to learn to short shift gears.

Jeremy
HndaTch627 is offline   Reply With Quote
Old 11-03-2001, 02:17 PM   #3
hkwan
Scooby Specialist
 
Member#: 7536
Join Date: Jun 2001
Location: San Jose
Vehicle:
2005 WRX STi

Default

Keystone, what does it mean by ECM running too close to tolerance? What tolerance spec.? What did they do when they re-program the computer, did they actually put in a different program?

190mile/tank definitely not right if you've been shifting below 4000rpm or so. I don't know what the dealer has to do to troubleshoot that. Everything else is fine, correct? You still have the power and all? Do you see tons of black carbon build-up at your tailpipe? Your car can be running way too rich. What type of mod on your car?
hkwan is offline   Reply With Quote
Old 11-03-2001, 10:30 PM   #4
keystone
Scooby Newbie
 
Member#: 9807
Join Date: Aug 2001
Location: Saint Louis, MO
Vehicle:
2002 WRX
BLUE

Smile Well this is what was happening

My car started basicly dumping fuel... wich really has givin me great proformance.. (i have added no hp related parts..) for example my 0-60 is below that of spec... but gas milages sucks..

Then engine is running to rich. and therefore the ecu killed two of my cyls.. Subaru is aware that they set tolerances a little to close to reporting errors, but also stated that majority of people wont have a problem, just cars that run a little quicker for some reason or another. So my car just likes to dump fuel.. With the new ecu program it stays in tolerence, but I almost would like to lose a little proformance for better gas milage.

ohh well
keystone is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Uhh...I think I have something I'm not supposed to have. fivestringslinger General Community 25 08-31-2009 01:26 AM
I think there's something wrong with my new 07 wrx... mordak General Community 16 08-22-2007 10:13 PM
I think there is something wrong with my friend Master2192 Off-Topic 16 06-13-2007 01:26 PM
I think there's something wrong with my nose L Bo Off-Topic 10 04-25-2007 03:02 PM
OMG... I think you have t3h wrong fax number!!! snvin Off-Topic 4 04-04-2005 06:40 PM


All times are GMT -4. The time now is 02:59 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.