Welcome to the North American Subaru Impreza Owners Club Tuesday June 2, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-01-2006, 03:23 PM   #1
VAUGHNB19
Scooby Newbie
 
Member#: 112422
Join Date: Apr 2006
Location: niles illinois
Default excedy clutch i think making my car run richer

i have a 2004 rs with a garrett turbo kit at only 6psi..still fun..but anyway i just got the excedy stage 2 clutch installed and now it running rich as hell just driving normal wit not giving much gas. People telling me its because the clutch is lighter....something like that the turbo was use the stock clutch and now it being lighter it will run more rich..and now every 3 mins when im slowing down and i put it in neutral the car dies.. is that true i need a tune up?
* Registered users of the site do not see these ads.
VAUGHNB19 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-01-2006, 03:27 PM   #2
Paintballguy
Scooby Specialist
 
Member#: 77810
Join Date: Dec 2004
Chapter/Region: MAIC
Location: Pasadena, MD
Vehicle:
2006 Evo IX SE
Tarmac Black

Default

Quote:
Originally Posted by VAUGHNB19 View Post
i have a 2004 rs with a garrett turbo kit at only 6psi..still fun..but anyway i just got the excedy stage 2 clutch installed and now it running rich as hell just driving normal wit not giving much gas. People telling me its because the clutch is lighter....something like that the turbo was use the stock clutch and now it being lighter it will run more rich..and now every 3 mins when im slowing down and i put it in neutral the car dies.. is that true i need a tune up?
ummm the clutch just connects the flywheel to the tranny. I dont think its the clutch.
Paintballguy is offline   Reply With Quote
Old 10-02-2006, 08:57 PM   #3
chapstien
Scooby Specialist
 
Member#: 68284
Join Date: Aug 2004
Chapter/Region: NWIC
Location: State of disapoint
Vehicle:
1988 Corolla SR5
invisible to females

Default

Not the clutch, but maybe something that happend (or didn't) during the install.
chapstien is online now   Reply With Quote
Old 10-04-2006, 08:54 PM   #4
VAUGHNB19
Scooby Newbie
 
Member#: 112422
Join Date: Apr 2006
Location: niles illinois
Default

it actually messed wit the turbo computer some how..and now i have apex afc neo, and it fine now...thanx
VAUGHNB19 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
TGV deletes, and then a boat load of fail. Please help make my car run nicely again. 573 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 11 04-03-2010 11:15 AM
Uppipe making my car run like doodoo? RNBauer Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 7 04-29-2008 09:34 AM
How an EM can make my car run smoother?? BBBsti LTD Engine Management & Tuning 2 07-05-2005 10:44 AM
Would a bad 02 sensor (P0037) make my car run bad? skimmilk68 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 6 11-04-2004 12:33 PM
mositure makes my car run bad...help!! MattJP Service & Maintenance 9 09-19-2003 10:12 AM


All times are GMT -4. The time now is 06:09 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.