Welcome to the North American Subaru Impreza Owners Club Saturday September 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-04-2006, 08:00 AM   #1
VtecGSR95
Scooby Newbie
 
Member#: 112607
Join Date: Apr 2006
Chapter/Region: MWSOC
Location: Mattoon, IL
Vehicle:
2001 Subaru
White

Default CEL help please with JDM ecu in GC8!!!

I have a 2001 impreza L model. I am using a usdm sti block, ver 7 heads and ecu with avcs and ver 7 harness merged with the stock harness. I have the car running good....a little rich cause its not tuned yet, but I am trying to eliminate my CEL's before heading to the dyno. I am getting the following codes:

P0031
P1230

I have checked the O2 sensor wiring and as far as I can tell from the WRX diagrams its all fine. I have checked the resistance of the heater circuit on the sensor and its about 5 ohms. I have checked voltage on the ground side of the heater connector with the car running and I am getting about .3 volts, meaning its dropping all the voltage. I have checked continuity from the heater circuit wiring on the sensor to the sensor housing to check for a short to the housing, but nothing there. I am also getting 12 volts @ the heater+ wire with the key on, and 14+v when the car is idling. So basically the sensor is getting whatever the battery is getting.....dont know if thats correct! I dont have a JDM wiring diagram, but going by the 02-03wrx diagram, everything should be hooked up correctly. Please help me sort out this code! If I clear the code, it comes back on in about 5 seconds.....ONLY with the car running.

The P1230.....I have been through this again and again and also cannot find a wiring issue. I have the fuel pump controller hooked up per the WRX wiring diagram, but the code comes at the same time as the 02 sensor code. I have read that one pissibility is the fuel pump relay needs to be replaced with a WRX relay, but also heard you can ground pin#3 on the relay and get the same effect. Can anyone also help me with this??

My tuner is Jorge @ P and L tuning. He isnt about to touch my car until I get these issues worked out!! I bought the car from a friend and have been working out the bugs since I got it. If you can help or point me in the direction of some help that would be great!! I am not sure if I have one small wiring issue that could cure everything, or several different issues......if I had the proper wiring diagrams I would go through and verify that every pin @ the ecu is in its right place.....cause I have a few wires hangin that arent hooked up that I would clip if I didnt need them!!

Thanks for any help anyone can provide cause I have been searching forever............getting some useful info, but not solving the problems!

Frank
* Registered users of the site do not see these ads.
VtecGSR95 is offline   Reply With Quote
Old 10-04-2006, 12:23 PM   #2
VtecGSR95
Scooby Newbie
 
Member#: 112607
Join Date: Apr 2006
Chapter/Region: MWSOC
Location: Mattoon, IL
Vehicle:
2001 Subaru
White

Default

No one has any info?
VtecGSR95 is offline   Reply With Quote
Old 10-05-2006, 10:29 AM   #3
linsavy
Scooby Specialist
 
Member#: 11620
Join Date: Oct 2001
Location: Ontario
Vehicle:
1997 GF4-STiV3 clone

Default

try asking in the conversions forum.
linsavy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
help with jdm ecu reflash ckrocks Factory 2.0L Turbo Powertrain 0 09-29-2007 10:53 PM
Reading CEL codes on a JDM ECU? powerlabs Subaru Conversions 21 03-19-2007 07:31 PM
CEL help on ver 7 swap on GC8!! VtecGSR95 Service & Maintenance 0 09-29-2006 08:41 PM
intermittent CEL help please TaiChih Factory 2.0L Turbo Powertrain 0 06-18-2003 04:51 PM
CEL help please! Black-X Factory 2.0L Turbo Powertrain 23 04-19-2003 04:18 AM


All times are GMT -4. The time now is 04:46 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.