Welcome to the North American Subaru Impreza Owners Club Friday December 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-05-2001, 02:13 PM   #1
jjimpreza
Scooby Newbie
 
Member#: 1269
Join Date: Apr 2000
Chapter/Region: NWIC
Location: Portland, OR
Vehicle:
2000 RS to WRX
to Forester to LGT to GF8

Unhappy My car has died

Well I got off from work Friday night and hopped in my car to start it. It started only to idle at 1500 RPM for 2 seconds and then die. I looked at things for a while and couldn't figure it out (gas,fuel,spark). There was no check engine light or any codes of a possible problem. So I opted to have it towed to the dealer that was closes to my location. My 2000 Impreza RS has 36,538 miles on the odometer and is leased thru SOA. Subaru informed me that it is my bill to have it towed. So I finally get the car towed to the dealer by midnight and do a drop off for the service.

I called the dealer in the morning only to hear the worst possible news! The serviceman told me that they were able to get the car running to diagnose the problem. He told me that the check engine light was on stating there was a diagnostic code. He asked how long the light had been on and I told it was never on at all, EVER. He told me car the computer was generating a code 11. Which in plain English means an ECU failure. The serviceman told me that computer of the car is bad and will have to be replaced. He told me the service department was shocked to determine this as the problem. Well this is an expensive little fix $1100 part, $200 labor closes part is across the U.S. My serviceman said this is not covered under a warranty because my warranty has ended 538 miles ago. He told me that this is not covered under the 50K warranty.

Has anyone else experienced an ECU problem like this? I can't believe it my car is less than two years old with absolutely no Mods and the computer has died. What would cause this to happen if it wasnít defective? I thought Subaruís were supposed to be reliable cars and run forever. My second question has anyone dealt with Subaru with warranty issues? I know it is out of the 36K warranty but this problem seems like a defect in my eyes. Do you think they will help compensate me with this issue? The Service shop told me to call and that Subaru may help out.

Any thoughts, ideas or personal experiences regarding this would are welcome.

Jerimi
* Registered users of the site do not see these ads.
jjimpreza is offline   Reply With Quote
Old 11-05-2001, 02:28 PM   #2
HIHO
Scooby Specialist
 
Member#: 7624
Join Date: Jun 2001
Location: Hopefully on a nice single track.
Vehicle:
BD5; family sedan
that just wooped your ass

Default

Email SOA, talk to a manager, get someone who is in charge. I would bitch untill something was done. If you complain enough to SOA I bet they will work something out.
HIHO is offline   Reply With Quote
Old 11-05-2001, 04:29 PM   #3
Corpsie
Scooby Newbie
 
Member#: 10502
Join Date: Sep 2001
Location: Livonia, Michigan
Vehicle:
'04 Ford Ranger 4x4
Red Metallic

Default

Why wouldn't a non-moving part still be covered??
Corpsie is offline   Reply With Quote
Old 11-06-2001, 12:30 AM   #4
Faraz
What?...
Do they speak English in What?

Moderator
 
Member#: 1459
Join Date: May 2000
Chapter/Region: Tri-State
Location: Allentown
Vehicle:
2008 WRX 5door MT
WR Blue

Default

yes call SOA and start checking online junkyards for a 2.5 ecu ...it would be cheaper
Faraz is offline   Reply With Quote
Old 11-06-2001, 02:41 PM   #5
Subie Gal
GC84Ever
Super Moderator
 
Member#: 301
Join Date: Sep 1999
Chapter/Region: NWIC
Location: WA
Vehicle:
1970 FF-1 & '70 Van
02 WRX/01 RS

Default

there's a 2.5ECU sittin in my GT in the junkyard it's in...

i mean.. u know.. there are ECU's out there if worst comes to worst...

good luck
jamie
www.subiegal.com
Subie Gal is offline   Reply With Quote
Old 11-06-2001, 02:55 PM   #6
HndaTch627
Scooby Guru
 
Member#: 6551
Join Date: May 2001
Chapter/Region: MWSOC
Location: Carol Stream, IL
Vehicle:
'01 GC8 Dinged STM
'09 Concours 14 ABS Black

Default

WHOA WHOA WHOA!!!! The Ecu's are COVERED UNDER NOT ONLY THE Powertrain warranty but ALSO the OBD-II eimissions warranty. ABSOLUTELY do not pay for thsoe repairs, there is NO reason even at 538 miles out of warranty you would EVER pay for a defective ECU. If they say it'snot covered i would contact the BBB.

Jeremy
HndaTch627 is offline   Reply With Quote
Old 11-06-2001, 05:58 PM   #7
GGB
Scooby Newbie
 
Member#: 8792
Join Date: Jul 2001
Location: Ontario, Canada
Default

I believe that this is a manufacturing defect which should be cover under the warranty. The code might have generated a long time ago, chances is the CEL is not going on but deal to this defective ECU. I wonder if the CEL log can be pull with an exact initial date of CEL registered. This way t might give you argument for a warranty work.
Try work this out with the dealer, if they don't provide a warranty replacement, then contact SOA.
Good luck
GGB is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My car has gone wingless! C J Member's Car Gallery 14 06-02-2010 07:16 PM
My WRX has died.. what shall I do? KoolFrank87 Newbies & FAQs 35 01-10-2008 04:58 AM
Help! My car just died! Dougeefresh Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 7 07-08-2002 03:35 AM
EMERGANCY: My car is dying... Kostamojen General Forum Archive 11 12-12-2000 03:47 AM
Ok, my car keeps dying on me...what's up? Sauginius Southern California Impreza Club Forum -- SCIC 6 11-07-2000 01:01 AM


All times are GMT -4. The time now is 05:06 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.