Welcome to the North American Subaru Impreza Owners Club Monday September 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-09-2006, 02:20 PM   #1
Scaed
Scooby Newbie
 
Member#: 22338
Join Date: Aug 2002
Chapter/Region: South East
Location: Wilmington, NC
Vehicle:
07 STi LTD #504
Urban Gray Metallic

Question 2007 DRL disable different than 2006??

This thread seems very simple http://www.iwsti.com/forums/showthre...ht=disable+drl

But the yellow 10 pin connector does not seem to be there on my 07.

I need to confirm that the relay has moved so I don't feel like I can't follow simple directions.
* Registered users of the site do not see these ads.
Scaed is offline   Reply With Quote
Old 10-10-2006, 05:59 PM   #2
Scaed
Scooby Newbie
 
Member#: 22338
Join Date: Aug 2002
Chapter/Region: South East
Location: Wilmington, NC
Vehicle:
07 STi LTD #504
Urban Gray Metallic

Default

bump for some 07 help?
Scaed is offline   Reply With Quote
Old 10-10-2006, 11:14 PM   #3
Hank3
Scooby Guru
 
Member#: 16157
Join Date: Mar 2002
Chapter/Region: South East
Location: Tallahassee, FL
Vehicle:
'03 Mazda P5 <><
'02 WRX & '08 MS3 SOLD!!!

Default

I can't access the thread since I'm not a member. Is it for an '06? If not, then you may want to check this thread:

http://forums.nasioc.com/forums/showthread.php?t=914064
Hank3 is offline   Reply With Quote
Old 10-10-2006, 11:41 PM   #4
Scaed
Scooby Newbie
 
Member#: 22338
Join Date: Aug 2002
Chapter/Region: South East
Location: Wilmington, NC
Vehicle:
07 STi LTD #504
Urban Gray Metallic

Default

thanks-- the iwsti thread is essentially the same that you posted, sorry about the access limitations. The yellow 10 pin that's pointed to in the nasioc thread isn't in the same place on the 07, AFAIK. Why move the thing?

The only other yellow connector is next to the airbag, so I figured I wouldn't pull it until I get some confirmation. I know that someone on the board has already bought the service manual for the 07, just wanting to confirm that it has moved and where??? Or if it changed color, etc, etc.
Scaed is offline   Reply With Quote
Old 10-11-2006, 12:15 AM   #5
semaj
I'm sorry for apologizing
Moderatour
 
Member#: 113533
Join Date: Apr 2006
Chapter/Region: VIC
Location: Vancouver, BC
Vehicle:
2006 Pathfinder
Off Road

Default

Just take a look at those modules under the dash, the correct one will clearly say "DRL" on it. Even if it is moved to a different spot for '07, you can't go wrong with looking for the letters DRL on the plug.
semaj is offline   Reply With Quote
Old 10-15-2006, 09:38 AM   #6
Scaed
Scooby Newbie
 
Member#: 22338
Join Date: Aug 2002
Chapter/Region: South East
Location: Wilmington, NC
Vehicle:
07 STi LTD #504
Urban Gray Metallic

Default

Any better guidance? Does the e-brake wire feed to the correct module?
Scaed is offline   Reply With Quote
Old 10-15-2006, 01:06 PM   #7
PARANOID56
Scooby Guru
 
Member#: 22035
Join Date: Jul 2002
Chapter/Region: SCIC
Location: San Diego, CA
Vehicle:
2003 Brocoma DCab
71 FJ40, 13 DRZ400SM

Default

um, unless its changed, but doesnt the STI not have DRL? since its HID?

Shane
PARANOID56 is offline   Reply With Quote
Old 10-15-2006, 02:23 PM   #8
Scaed
Scooby Newbie
 
Member#: 22338
Join Date: Aug 2002
Chapter/Region: South East
Location: Wilmington, NC
Vehicle:
07 STi LTD #504
Urban Gray Metallic

Default

Very astute! I should rephrase my question: how do I turn off the headlights during the day?? They are HID's and are on, but they do not have the lights that were on my 02 WRX that were DRL's.

I assumed that a relay controlled them and it would be called a DRL relay.

Last edited by Scaed; 10-15-2006 at 04:15 PM.
Scaed is offline   Reply With Quote
Old 10-23-2006, 12:52 AM   #9
15secWRX
Scooby Specialist
 
Member#: 52088
Join Date: Jan 2004
Chapter/Region: MAIC
Location: NOVA
Vehicle:
07 limited
URBAN GRAY

Default

any updates?
15secWRX is offline   Reply With Quote
Old 10-24-2006, 08:19 AM   #10
Scaed
Scooby Newbie
 
Member#: 22338
Join Date: Aug 2002
Chapter/Region: South East
Location: Wilmington, NC
Vehicle:
07 STi LTD #504
Urban Gray Metallic

Default

yeah, I started a thread in exterior mods because it gets more views. Try here:

http://forums.nasioc.com/forums/show....php?t=1119031

Last edited by Scaed; 11-02-2006 at 12:13 AM.
Scaed is offline   Reply With Quote
Old 11-01-2006, 07:56 PM   #11
tealdub
Scooby Newbie
 
Member#: 87598
Join Date: May 2005
Chapter/Region: MWSOC
Location: OHIO
Vehicle:
09 spec.B
burton custom 167

Talking Finally done...

Please check this link:

http://www.iwsti.com/forums/showthread.php?t=64791

The important step is the last one on the second page. Although this person had cut the wires, I simply used a pinout tool and removed the green/yellow wire so if for some reason I wanted the DRL's back I would just plug them back in. Remove the glovebox. The diode is attached to the wires on back on the glovebox, about 8" up, and the relay is over where it was on the '06 model, next to the I/C box. The relay is the one with the black clip, NOT the blue. It is a 5 pin connector. Simply use a small screwdriver to unattach it from the relay, seperate the white inner plastic cover and use your "pinout tool" btw the connector and the black housing and it should slide right out. Reverse instructions and put it back together. Once that is done, disconnect the small black diode from its white three wire housing and remove it. Take the same tool, or something small and strong, and pry up on the white plastic strip above the green/yellow wire and again it should slide right out. Take a minute to attach the now exposed wire to the existing harness, I just used about 2" of electrical tape on both ends. Now test your lights and make sure EVERYTHING works. Reinstall the glovebox. Done. Total time for me was around 25 mins. I take no responsiblity for this mod. but by all indications this is completely safe.
tealdub is offline   Reply With Quote
Old 11-04-2006, 03:23 PM   #12
Scaed
Scooby Newbie
 
Member#: 22338
Join Date: Aug 2002
Chapter/Region: South East
Location: Wilmington, NC
Vehicle:
07 STi LTD #504
Urban Gray Metallic

Default

using a pinout tool is the ticket. It was easy on relay (black one next to the blue one near passenger right knee), but I ended up having to cut GY wire from diode.

Works as advertised.
Scaed is offline   Reply With Quote
Old 11-16-2006, 10:25 AM   #13
shane86
Scooby Newbie
 
Member#: 67387
Join Date: Aug 2004
Chapter/Region: MWSOC
Location: Minneapolis, MN
Vehicle:
04 WRX - STX
05 LGT Limited Wagon

Default

Ok all you STI guys, can you help out a wrx owner?
The wiring is diffrent for a car that doesn't have HIDs. there is no Green/Yellow wire running into that black relay.

i'm fairly certian that said relay is still the OR relay that controls the DRLs, but the all the descriptions just list the wire color, which isn't the same on the WRX.

My question? what PIN on that relay did you remove?
i have a few images we took from my friend's brand new 07 yesterday illustrating no GY wire.
http://i14.photobucket.com/albums/a3.../PICT0023s.jpg
http://i14.photobucket.com/albums/a3.../PICT0024s.jpg

The wires avaialable are:
Yellow/Red x2
Black
Green/Red
Green Black
shane86 is offline   Reply With Quote
Old 11-17-2006, 12:35 PM   #14
shane86
Scooby Newbie
 
Member#: 67387
Join Date: Aug 2004
Chapter/Region: MWSOC
Location: Minneapolis, MN
Vehicle:
04 WRX - STX
05 LGT Limited Wagon

Default

24hrs later bump.... i'd just like to know which pin the GY wire goes to on that relay!
shane86 is offline   Reply With Quote
Old 12-01-2006, 05:59 PM   #15
garretts77
Scooby Newbie
 
Member#: 131498
Join Date: Nov 2006
Chapter/Region: BAIC
Location: NorCal
Vehicle:
2007 WRX Sedan
Satin White Pearl

Default

Quote:
Originally Posted by shane86 View Post
24hrs later bump.... i'd just like to know which pin the GY wire goes to on that relay!
Shane, any luck with this? I have been reading this thread for a couple of weeks... Any new news?
garretts77 is offline   Reply With Quote
Old 12-14-2006, 03:53 PM   #16
Cautiontext
Scooby Newbie
 
Member#: 74848
Join Date: Nov 2004
Chapter/Region: Tri-State
Location: New York
Vehicle:
07 BMW 335Xi
Black

Default

I thought there was a stickyed how to do this for the 07 sti. Does anyone have a link?
Cautiontext is offline   Reply With Quote
Old 12-14-2006, 04:01 PM   #17
tillithz@
Scooby Newbie
 
Member#: 84382
Join Date: Apr 2005
Chapter/Region: BAIC
Location: Oakland
Vehicle:
2006 STI
Crystal Gray Metallic

Default

that looks like a common relay shane, without testing I would guess the wire he indicated by color in earlier posts.
tillithz@ is offline   Reply With Quote
Old 01-05-2007, 02:17 PM   #18
Shibbs
Scooby Newbie
 
Member#: 131725
Join Date: Nov 2006
Location: Wayzata, MN
Vehicle:
2007 Impreza WRX
Obsidian Black Pearl

Default

STILL no progress on the 07 WRX that DOESN'T have HID? Wow. I must be the only one that cares about my DRLs....
Shibbs is offline   Reply With Quote
Old 01-05-2007, 11:24 PM   #19
garretts77
Scooby Newbie
 
Member#: 131498
Join Date: Nov 2006
Chapter/Region: BAIC
Location: NorCal
Vehicle:
2007 WRX Sedan
Satin White Pearl

Default

Quote:
Originally Posted by Shibbs View Post
STILL no progress on the 07 WRX that DOESN'T have HID? Wow. I must be the only one that cares about my DRLs....
Absolutely not. But I personally don't know how to do it either, and am also waiting for someone to give it up...
garretts77 is offline   Reply With Quote
Old 01-07-2007, 01:13 AM   #20
june.rs
Scooby Newbie
 
Member#: 136412
Join Date: Jan 2007
Chapter/Region: HIIC
Location: HAWAII
Vehicle:
07 WRX
PEARL WHITE

Default drl gone

bye bye drl. i took my drl is gone
june.rs is offline   Reply With Quote
Old 01-07-2007, 11:55 AM   #21
ETacv
Scooby Newbie
 
Member#: 134010
Join Date: Dec 2006
Chapter/Region: NESIC
Location: Bahhston
Vehicle:
2007 WRX bren-t00ned
UGM

Default

Quote:
Originally Posted by june.rs View Post
bye bye drl. i took my drl is gone
Nice... would you like to share how?
ETacv is offline   Reply With Quote
Old 01-08-2007, 02:21 PM   #22
june.rs
Scooby Newbie
 
Member#: 136412
Join Date: Jan 2007
Chapter/Region: HIIC
Location: HAWAII
Vehicle:
07 WRX
PEARL WHITE

Default

I Ground The E Brake Wire And Took The E Brake Light Out Of The Cluster. It Took Me About 10min. No Cutting Involved. I Shoved Eyes In The E Brake Wire Than Connect With A Small Wire And Bolt It On Some Nut That Was In There.
june.rs is offline   Reply With Quote
Old 01-13-2007, 01:04 AM   #23
SilvrWRX
Scooby Newbie
 
Member#: 8582
Join Date: Jul 2001
Chapter/Region: SCIC
Location: Oceanside, CA
Vehicle:
2007 Impreza WRX
Satin White Pearl

Default

Quote:
Originally Posted by Shibbs View Post
STILL no progress on the 07 WRX that DOESN'T have HID? Wow. I must be the only one that cares about my DRLs....
I did a little research and found this thread http://www.iwsti.com/forums/showthread.php?t=73434.

It's directions for the STI, but what's interesting to me is the Diode B95 description in the bulkhead wiring harness table. For the STI, it's listed as a 3 pole connector. The STI DRLs were disabled by pulling the green-red (GR) wire. The problem is I don't have the wiring system diagram for the WRX, but the WRX (listed as "except for STI model" on the table) equivalent of the same diode B95 has only 2 pins. So, I figure we have a 50% chance of achieving the same result. I think the worst that can happen is that the lights would stop working if the wrong choice was made. At which point, we would know that it is the other wire. Has anyone tried this yet? Or better yet, does anyone have the wiring system diagram for 2007 non-hid impreza models (should work for both RS and WRX models)?



We'll still have to disconnect a wire from B280 to remove the City Lights DRL. It should be the same as the STI. The table says it's a blue connector, but the iwSTI thread confuses me because it looks like it shows a wire removed from a black connector instead. Here's the diagram to help locate the connectors in the dash.


What does everyone think?
SilvrWRX is offline   Reply With Quote
Old 01-13-2007, 05:18 PM   #24
ETacv
Scooby Newbie
 
Member#: 134010
Join Date: Dec 2006
Chapter/Region: NESIC
Location: Bahhston
Vehicle:
2007 WRX bren-t00ned
UGM

Default

Hm. I think that there's a good chance of that working. If I had some more time it'd try to fiddle with it but school just started again so yea... If you wanted to try it out you could try to use a pinout tool to take out one of the wires and see if it works. Maybe the one where the GY colored one for the STi should be but i'm not too sure.
You can get the service manuals from techinfo.subaru.com or you could go to your dealer and ask them to print out what you're looking for.
ETacv is offline   Reply With Quote
Old 01-15-2007, 07:12 PM   #25
Captain Ned
Scooby Newbie
 
Member#: 36144
Join Date: May 2003
Chapter/Region: NESIC
Location: Vermont, USA
Vehicle:
2010 Legacy2.5GT Ltd
Graphite Gray Metallic

Default

What happens if one simply unplugs B102?
Captain Ned is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 DRL disable different than 2006? Scaed Interior & Exterior Modification 160 06-29-2012 04:59 PM
2007 2.5i DRL disable? cowboysuby Electrical & Lighting 23 03-21-2008 11:51 PM
2007 WRX DRL Disable JoeSUBARU Electrical & Lighting 5 11-18-2007 03:42 PM
2007 DRL disable munkis Legacy Forum 0 03-31-2007 06:37 PM
2007 DRL Disable john_tran Interior & Exterior Modification 2 02-03-2007 09:13 PM


All times are GMT -4. The time now is 03:26 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.