Welcome to the North American Subaru Impreza Owners Club Thursday May 28, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Alaskan Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Alaskan Impreza Club Forum -- AKIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-12-2006, 03:15 PM   #1
12vpro
Scooby Newbie
 
Member#: 62975
Join Date: May 2004
Chapter/Region: AKIC
Location: Wasilla Alaska
Vehicle:
2004 WRX
Silver

Default turbo question (gurus plz)

I am curious as to whether or not I may have a serious problem. I noticed the other day that my y pipe from the turbo to the intercooler has a black residue on it. my intercooler also seems to have a light coating of oil in it. very minimal but none the less.

at times, when I autostart it and let it run for more than 15 min, I notice that I get a lot of white smoke, only untill I get going, then the smoke dissapears.

I am curious as to whether this could be the seal between the intake side and the exhaust side of the turbo going bad.

any suggestions?
* Registered users of the site do not see these ads.
12vpro is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-12-2006, 03:52 PM   #2
SQUAD_907
Totally Biased
Moderator
 
Member#: 10104
Join Date: Sep 2001
Chapter/Region: AKIC
Location: 907
Vehicle:
WOW! JUST WOW!
I make posts disappear

Default

exh leak...and just "normal" oil blow-by
SQUAD_907 is offline   Reply With Quote
Old 10-12-2006, 05:49 PM   #3
12vpro
Scooby Newbie
 
Member#: 62975
Join Date: May 2004
Chapter/Region: AKIC
Location: Wasilla Alaska
Vehicle:
2004 WRX
Silver

Default

ok, so not such a bad thing? dumb question, but how does the oil get in the intake outlet of the turbo?
12vpro is offline   Reply With Quote
Old 10-12-2006, 06:16 PM   #4
Alaskan_awd
Scooby Specialist
 
Member#: 117002
Join Date: Jun 2006
Chapter/Region: AKIC
Location: Palmer, AK
Vehicle:
2010 >40psi, oh yes!
POWERSTROKE

Default

I belive it is caused from crank case gasses that are passed through the pcv valve back into the intake.
Alaskan_awd is offline   Reply With Quote
Old 10-12-2006, 06:52 PM   #5
prometheum
Scooby Specialist
 
Member#: 92003
Join Date: Jul 2005
Chapter/Region: International
Location: Tatooine
Vehicle:
04 bicycle!

Default

search for oil catch can
prometheum is offline   Reply With Quote
Old 10-12-2006, 08:41 PM   #6
12vpro
Scooby Newbie
 
Member#: 62975
Join Date: May 2004
Chapter/Region: AKIC
Location: Wasilla Alaska
Vehicle:
2004 WRX
Silver

Default

^^^^ thats what I thought. I found a catch can system that is completely internal or something and puts the oil back in the oil pan instead of in a can.
12vpro is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Turbo question The Surrey Scooby Newbies & FAQs 0 06-03-2010 04:10 AM
Blow through carb turbo question... any gurus here? markman Off-Topic 40 01-05-2008 12:46 AM
tie-rod locknut question (help plz) sd 05 sti Brakes, Steering & Suspension 10 05-11-2006 10:36 AM
can somebody explain me?? cat/turbo back gurus BBBsti LTD Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 3 11-23-2004 01:54 PM
19 psi on stock turbo??? - Tuning Gurus what gives??? meisnerboy Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 56 10-03-2003 07:21 AM


All times are GMT -4. The time now is 01:06 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.