Welcome to the North American Subaru Impreza Owners Club Saturday July 12, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-19-2006, 10:51 PM   #1
Clark Kent
Scooby Specialist
 
Member#: 75682
Join Date: Nov 2004
Chapter/Region: Tri-State
Vehicle:
2004 WRX

Default TGV sensor the same as TPS sensor on 04 STi??

Hello,

I need to replace the TGV sensor, and as per scoobymoods, it is the same as the TPS sensor.....on a forester. I was wondering if it was the same on a 2004 STi. Thanks!

Ck
* Registered users of the site do not see these ads.
Clark Kent is offline   Reply With Quote
Old 10-19-2006, 11:28 PM   #2
R0DENT
Scooby Newbie
 
Member#: 111756
Join Date: Apr 2006
Chapter/Region: RMIC
Vehicle:
04 WRB STi
Few Mods...

Default

I doubt it but I have a couple extra TGV sensors if you need one. 04 STi.
R0DENT is offline   Reply With Quote
Old 10-20-2006, 06:35 AM   #3
Clark Kent
Scooby Specialist
 
Member#: 75682
Join Date: Nov 2004
Chapter/Region: Tri-State
Vehicle:
2004 WRX

Default

why would you doubt it? do the ones you have new or used? also, if you could, there are numbers pressed or stamped into the gray plastic of the part. Could you write them down or post a pic??

Thanks man! I REALLY appreciate it!!

Ck
Clark Kent is offline   Reply With Quote
Old 10-20-2006, 06:38 AM   #4
Clark Kent
Scooby Specialist
 
Member#: 75682
Join Date: Nov 2004
Chapter/Region: Tri-State
Vehicle:
2004 WRX

Default

If anyone else has info or can confirm this, please post! I need to get the car running!
Clark Kent is offline   Reply With Quote
Old 10-20-2006, 09:31 AM   #5
TheMadScientist
Scooby Guru
 
Member#: 23717
Join Date: Aug 2002
Chapter/Region: NESIC
Location: Beverly, MA
Vehicle:
2005 Big red

Default

The Sti is DBW and the TPS sensor is intergrated into the DBW module. You need to use the cable throttle TPS sensor in place of the TGV sensor.
I all so have a couple of TGV sensors laying around.

TMS
TheMadScientist is offline   Reply With Quote
Old 10-20-2006, 03:06 PM   #6
vaj
Scooby Specialist
 
Member#: 59136
Join Date: Apr 2004
Chapter/Region: BAIC
Location: Peoples Republic of Kalifornia
Vehicle:
04/5 APRWidebody STi
EQ Tuned - Green/Meth

Default

Per scoobymods and my own personal experience with cracking/replacing the TGV sensor, the part listed on Scooby mods (DBC - TPS) is exactly the correct swap in for the tgv sensors on an MY04 STi.

TMS is correct. Not the first time.

Lemme guess, you busted the tgv when you were working on the turbo?

Good luck with this sensor. Get a buddy to hold stuff out of the way when you swap the tgv. It's tricky but managable. A flex socket handle and u-joint 7mm socket (teeny tiny craftsman kind) worked well for me.
vaj is offline   Reply With Quote
Old 10-20-2006, 03:07 PM   #7
vaj
Scooby Specialist
 
Member#: 59136
Join Date: Apr 2004
Chapter/Region: BAIC
Location: Peoples Republic of Kalifornia
Vehicle:
04/5 APRWidebody STi
EQ Tuned - Green/Meth

Default

but if you still have the turbo out, the sensor swap is cake.
vaj is offline   Reply With Quote
Old 10-20-2006, 10:25 PM   #8
Clark Kent
Scooby Specialist
 
Member#: 75682
Join Date: Nov 2004
Chapter/Region: Tri-State
Vehicle:
2004 WRX

Default

okay thanks guys! I was just nervous about it because I know the STi is a little more advanced than the wrx/ forester engine I wanted to make sure so I PMed Peaty himself and he confirmed it is the same sensor. I feel better, hehe. I was so nervous when it popped! I did remove the sensor already, so I just need to bolt the new one in.

How much are you guys asking for one shipped?
Clark Kent is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Which wire for TPS signal on 04 STI B136 17 or 18 roybfr Factory 2.5L Turbo Powertrain 1 06-25-2006 09:34 PM
Are 04 sti wheels the same as 04 wrx ? WRX82 Tire & Wheel 8 02-09-2006 11:22 AM
04 sti Pink bits the same as 04 jdm oem? serious Brakes, Steering & Suspension 9 05-25-2004 12:34 PM
04 STI, are the strut tops the same as a WRX? Davenow Brakes, Steering & Suspension 2 01-12-2004 12:40 AM
Are 98-99 Rear Brake Assy. the same as a 2k1 on a RS? Deznuts05 Brakes, Steering & Suspension 4 04-21-2003 02:29 PM


All times are GMT -4. The time now is 06:42 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.