Welcome to the North American Subaru Impreza Owners Club Tuesday May 26, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-24-2006, 08:27 AM   #1
05_TurboxSti
Scooby Newbie
 
Member#: 124460
Join Date: Aug 2006
Chapter/Region: TXIC
Location: San Antonio, Tx
Vehicle:
2007 WRX
WRB

Thumbs down Oil Pressure issue. 2005 STi

this is my first post on nasioc... be easy

I have an 05 STi, yesterday I started my car to drive back to work after lunch and found the check oil light came on solid. No engine noise is heard, I checked the oil and found it to be 1 quart low.I topped off the oil to the specified mark and the light remained. drove it to work and one of my subie techs take a look at it, he pulled the alternator off and proceeded to check oil pressure which there was none. So I am freakin out here! He told me that there is no noise so the pump, pick up tube, or the screen is possible to blame. He will be tearing it down this afternoon to find the cause and correction for my issue.I'll keep posting

Thanks for listening to my sob story.
* Registered users of the site do not see these ads.
05_TurboxSti is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-24-2006, 11:24 AM   #2
Cooter05WRX
Scooby Specialist
 
Member#: 110567
Join Date: Mar 2006
Chapter/Region: NWIC
Location: Oregon
Vehicle:
2009 JK
Sunburst Orange

Default

at least you caught it before your engine got toasted. well hopefully.
Cooter05WRX is offline   Reply With Quote
Old 10-24-2006, 05:37 PM   #3
Weakness
Scooby Specialist
 
Member#: 92588
Join Date: Aug 2005
Chapter/Region: MWSOC
Location: Palatine, IL
Vehicle:
2005 STi
Silver

Default

Any update?
Weakness is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil pressure issues driving me crazy St0k3d Built Motor Discussion 43 12-27-2008 09:44 AM
oil pressure issues. GlennB Built Motor Discussion 0 06-11-2008 10:23 PM
DEFI's reading oil pressure issue hawnduhplz Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 12 05-13-2008 06:26 PM
Oil pressure issues Loomin Vancouver Impreza Club Forum -- VIC 12 10-07-2007 04:18 AM
Oil Pressure Issues MauroMotorsports Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 6 09-17-2005 12:14 PM


All times are GMT -4. The time now is 05:48 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.