Welcome to the North American Subaru Impreza Owners Club Thursday September 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-25-2006, 11:17 AM   #1
NW OBS
Scooby Specialist
 
Member#: 101361
Join Date: Nov 2005
Chapter/Region: NWIC
Location: Baja Oregon
Vehicle:
05 OBS
Obsidian Pearl Black

Exclamation Need Some Help On Setting/Changing Idle Speed on '05

I am stumped. Help, if you can.

I am driving an '05 N/A car that has 'fly by wire' throttle control. There is no way to set the idle speed it appears (if you have an '07 the ECM now allows a Suby Tech to set the idle from 0-2000 rpms) either through the ECM or mechanical.. stupid.

The issue is this. I just put in performance cams and the car pulls like a rhino ~ but the ECM continues to set the idle @ 450 rpms and the car will stall when coming to a stop. If I could adjust the throttle to say 900 rpms all would be rosey!

Any help would be appreciated. All three of my service guys at the dealership, do not have an answer on how to fix this issue. Obviously, I can't keep driving it as it stalls 50% of the time when I come to a stop!
* Registered users of the site do not see these ads.
NW OBS is offline   Reply With Quote
Old 10-25-2006, 11:25 AM   #2
drummerRS2505
Scooby Newbie
 
Member#: 111331
Join Date: Mar 2006
Chapter/Region: MWSOC
Location: Omaha NE
Vehicle:
2005 Impreza 2.5 RS
OBP

Default

congrats on getting cams! what knid did u go with? As far as idle on my 05 RS it idles when warm at 700-750 rpm which is normal for our cars stock. The only way i would think to adjust idle if the techs cannot set it with scantool via the ecu would be maybe then can adjust the accelarator pedal position switches (3 used commonly for multiple back-ups) on the gas pedal somehow.

Rick,
drummerRS2505 is offline   Reply With Quote
Old 10-25-2006, 11:41 AM   #3
NW OBS
Scooby Specialist
 
Member#: 101361
Join Date: Nov 2005
Chapter/Region: NWIC
Location: Baja Oregon
Vehicle:
05 OBS
Obsidian Pearl Black

Default

Quote:
Originally Posted by drummerRS2505 View Post
congrats on getting cams! what knid did u go with? As far as idle on my 05 RS it idles when warm at 700-750 rpm which is normal for our cars stock. The only way i would think to adjust idle if the techs cannot set it with scantool via the ecu would be maybe then can adjust the accelarator pedal position switches (3 used commonly for multiple back-ups) on the gas pedal somehow.

Rick,
Hey, thanks for the tip. I pulled that assembly to put on the aluminium peddle... I don't remember seeing 'switches'. I will have to crawl back under the dash and have a look.

I went with Delta re-grinds. Just got them in late yesterday and still tip toeing around. I can already feel the harder pull across the middle rpm ranges.
NW OBS is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need some help with cluch change kx02wr Transmission (AT/MT) & Driveline 10 04-08-2010 11:23 PM
Need Help On Setting/Changing Idle Speed On '05 NW OBS Engine Management & Tuning 14 11-10-2006 02:29 PM
need some help with setting up wheels SilverBulletWRX Tri-State Area Forum 1 05-24-2004 10:49 PM
Need some help with setting up the AVC-R Hojai Normally Aspirated with bolt-on Forced Induction Powertrain 16 06-26-2003 11:03 PM
need a little help on setting boost vs speed on unichip HM3SC Factory 2.0L Turbo Powertrain 0 11-22-2001 08:05 PM


All times are GMT -4. The time now is 10:08 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.