Welcome to the North American Subaru Impreza Owners Club Thursday July 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > Commercial ECU Reflashes

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-30-2006, 01:38 PM   #1
Ginntonnik
Scooby Newbie
 
Member#: 126506
Join Date: Sep 2006
Default TBE with no EM

Hey, im going to gruppe-s today and get my TBE. im planning on only installing my HKS carbon ti catback today unless i can get a go ahead to do a full tbe with no engine managment. gruppe-s said i might have boost creep and it might lean it out... now i always like to listen to shops who have a proven track record.. but it is a business and the do like to up sell. i am going to be getting a ecutek reflash from them just not now. im 24 and it cost alot to live in bay area he he. its on a 06 tr.

thanks guys and hope you can help
* Registered users of the site do not see these ads.
Ginntonnik is offline   Reply With Quote
Old 10-30-2006, 03:19 PM   #2
Master2192
RIP 10/12/83 to 02/10/08
Scooby Specialist
 
Member#: 83254
Join Date: Mar 2005
Chapter/Region: NWIC
Location: Roy, Washington
Vehicle:
98 2.5 RS
04 WRX

Default

I would only do the cat-back. The Ecu will have trouble controlling boost if you install the downpipe. That and the boost creep issue, but boost creep can't always be cured with EM anyway (it is more of a mechanical problem).

You know, since this is in here. If you've got a laptop, you could look into getting a Tactrix cable and reflashing your ECU yourself.
Master2192 is offline   Reply With Quote
Old 10-31-2006, 11:55 AM   #3
bofh
Scooby Specialist
 
Member#: 59287
Join Date: Apr 2004
Chapter/Region: TXIC
Location: Houston, Tx
Vehicle:
2007 WRB WRX
2004 WRB WRX (RIP)

Default

What car do you have? It makes a big difference. 02-03 WRX? Fine. 04+ WRX? OL/CL issues. 06+ WRX Boost Creep and spike issues added to the OL/CL. STI? Boost creep and spike only.
bofh is offline   Reply With Quote
Old 10-31-2006, 05:13 PM   #4
Jon [in CT]
*** Banned ***
 
Member#: 2992
Join Date: Nov 2000
Chapter/Region: NESIC
Location: Connecticut, USA
Vehicle:
02 WRX Sedan
Silver

Default

All those issues are avoided if he uses moderate acceleration, stays out of the fast lane, and doesn't try to pass anyone.
Jon [in CT] is offline   Reply With Quote
Old 10-31-2006, 06:01 PM   #5
TheShad0w
Scooby Specialist
 
Member#: 91925
Join Date: Jul 2005
Chapter/Region: TXIC
Location: Little Elm, TX
Vehicle:
2005 Saabaru 92-x
AWDTuning.com

Default

Sounds like a plan haha
TheShad0w is offline   Reply With Quote
Old 10-31-2006, 06:59 PM   #6
hondaeater69
Scooby Guru
 
Member#: 60324
Join Date: Apr 2004
Location: a pillow.
Default

yea i wouldn't suggest the TBE without EM.
hondaeater69 is offline   Reply With Quote
Old 11-01-2006, 06:15 PM   #7
cramlow82
Scooby Newbie
 
Member#: 124244
Join Date: Aug 2006
Chapter/Region: MWSOC
Location: Fox Lake
Vehicle:
2006 WRX
Blue

Default

I have the same issue. I have an 06 and bought a TBE for a great deal. I don't want to screw anything up, but i don't want to get into EM. I am not going to be doing any other modifications. What do you think abou this?

I just called GRD in Naperville... they told me that they have not had any issues with 06 wrx with just TBE. They said the issue is with the sti.

What do you think I should do?
cramlow82 is offline   Reply With Quote
Old 11-01-2006, 07:44 PM   #8
Subyslacker
Scooby Specialist
 
Member#: 105096
Join Date: Jan 2006
Chapter/Region: TXIC
Location: Port Arthur, Texas
Vehicle:
2007 WRX/STI
Black

Default

I hear ya dude I have a 07 STI,exhaust is just waiting to be put on the car. Gotta wait for the computer stuff to come out
Subyslacker is offline   Reply With Quote
Old 11-01-2006, 07:50 PM   #9
Cabal
Scooby Specialist
 
Member#: 31159
Join Date: Dec 2002
Chapter/Region: TXIC
Location: Austin, TX
Vehicle:
2006 WRX, 2008 2.5i
San Remo Red

Default

If you run a TBE with no EM, you get stuck in Iraq.
Cabal is offline   Reply With Quote
Old 11-01-2006, 08:50 PM   #10
cramlow82
Scooby Newbie
 
Member#: 124244
Join Date: Aug 2006
Chapter/Region: MWSOC
Location: Fox Lake
Vehicle:
2006 WRX
Blue

Default

Yeah well i don't have an sti.
So has anyone here with an 06 wrx actually put on a tbe with out em? If so, what were your experiences?
cramlow82 is offline   Reply With Quote
Old 11-01-2006, 09:00 PM   #11
V6TurboTA
Scooby Guru
 
Member#: 9090
Join Date: Aug 2001
Location: < of Boston
Vehicle:
09 Forester Gump
02WRX->04STi->09Gump

Default

Quote:
Originally Posted by Cabal View Post
If you run a TBE with no EM, you get stuck in Iraq.

Well played.

~v6
V6TurboTA is offline   Reply With Quote
Old 11-02-2006, 12:34 AM   #12
Tgui
Scooby Specialist
 
Member#: 44771
Join Date: Oct 2003
Default

I posted this earlier. Consider how much a new engine costs.

******************************************
Why don't you play it safe and flash your ECU ala:
www.openecu.org
www.tactrix.com

and if you want to tweak your map some, lower boost etc.
www.enginuity.org

Cheap egt
http://www.jegs.com/webapp/wcs/store...chItemId=79699

Guage bezel, insert EGT and you can move your stock boost guage into the other side, I did it, doesn't look too hokey.
http://www.fastwrx.com/dugadabe.html

Wide band
http://www.zeitronix.com/Products/zt2/zt2.htm

$80 for cable, free tunes
$125 for cheap egt
$79 guage bezel
$279 wideband

total: $563
Tgui is offline   Reply With Quote
Old 11-02-2006, 04:38 PM   #13
cramlow82
Scooby Newbie
 
Member#: 124244
Join Date: Aug 2006
Chapter/Region: MWSOC
Location: Fox Lake
Vehicle:
2006 WRX
Blue

Default

OKay, now my next question? I think i know the answer already, but...
Does this void my warranty?
If i need to have any warranty work done, i don't want to have to take all this stuff off, or have them find something reflashed in the ecu.... Basically i don't want to deal with any crap down the road.

Do you think it is worth all this hastle, or do you think i should just get a catback and sell the tbe?
cramlow82 is offline   Reply With Quote
Old 11-02-2006, 04:54 PM   #14
Tgui
Scooby Specialist
 
Member#: 44771
Join Date: Oct 2003
Default

Quote:
Originally Posted by cramlow82 View Post
OKay, now my next question? I think i know the answer already, but...
Does this void my warranty?
If i need to have any warranty work done, i don't want to have to take all this stuff off, or have them find something reflashed in the ecu.... Basically i don't want to deal with any crap down the road.

Do you think it is worth all this hastle, or do you think i should just get a catback and sell the tbe?

Before you get ripped a new one with people telling you to read the FAQs on warranty issues (which you really do need to do), I'll say I've had no problems being stage 2. Then again, I've never had much warranty work.

In any case, you better make provisions for the worste case. If you mod your car, you better be prepared to pretty much write off your powertrain warranty.
Tgui is offline   Reply With Quote
Old 11-02-2006, 05:10 PM   #15
cramlow82
Scooby Newbie
 
Member#: 124244
Join Date: Aug 2006
Chapter/Region: MWSOC
Location: Fox Lake
Vehicle:
2006 WRX
Blue

Default

That's the thing,... I don't want to mod my car much at all. SO should i just go with a catback instead?
cramlow82 is offline   Reply With Quote
Old 11-02-2006, 05:14 PM   #16
Tgui
Scooby Specialist
 
Member#: 44771
Join Date: Oct 2003
Default

Its kind of an all or nothing thing bud.

What does just a catback get you? A little sound? Not worth the money to me.

Beyond that once you throw in a DP, you better have some mapping or EM going on, and that means no warranty.

What do YOU want, and can you live with the consequences?
Tgui is offline   Reply With Quote
Old 11-02-2006, 05:30 PM   #17
littledrummerboy
Scooby Newbie
 
Member#: 94408
Join Date: Aug 2005
Chapter/Region: E. Canada
Location: Canada
Vehicle:
2006 WRX Stg. 2+
World Rally Blue

Default

Quote:
Originally Posted by cramlow82 View Post
I just called GRD in Naperville... they told me that they have not had any issues with 06 wrx with just TBE. They said the issue is with the sti.

What do you think I should do?
IMO, I don't believe them. It may have not been an issue with the 02-05s since they were 2.0L, but the 06 WRX has a nearly identical 2.5L that the STI does and pushes a hell of alot of exhaust out of the engine than the stock wastegate can handle when mated with a larger downpipe... 06s exhibit the same creep possiblity that STIs do. There are more than enough cases on nasioc to prove it.

Stick with just a catback if you don't want to get EM. If you do the TBE, at the very least get the EM, if creep is still a problem then port the wastegate as that is the only sure way to get rid of it.

For me, the AP has pretty good wastegate duty cycles and I am not experiencing any creep, but that doesn't mean this works for everyone. I'm also catted, which may be providing enough back pressure to keep the turbo from over-spooling.
littledrummerboy is offline   Reply With Quote
Old 11-06-2006, 06:47 PM   #18
Makako54
Scooby Newbie
 
Member#: 110013
Join Date: Mar 2006
Chapter/Region: South East
Location: Miami, FL
Vehicle:
2006 Impreza WRX
Black

Unhappy TBE W/out EM

I got a deal as well for a catless TBE in my area and just for kicks i installed it. It sounds great, but i dunno it was worth the drawbacks, I did have problems with fuel cut, it definately doesnt feel good and its bad for the engine. i have no boost gauge but im pretty sure it was due to Spike, the colder the weather the less it took for me to hit fuel cut. I ended stocking it all back till i can get a tune
Makako54 is offline   Reply With Quote
Old 11-06-2006, 06:48 PM   #19
Makako54
Scooby Newbie
 
Member#: 110013
Join Date: Mar 2006
Chapter/Region: South East
Location: Miami, FL
Vehicle:
2006 Impreza WRX
Black

Default

IMO ride cat-back and keep the DP for the when you get EM, or if u need warranty work done just hold off on it all till later.
Makako54 is offline   Reply With Quote
Old 11-07-2006, 11:42 AM   #20
EdWRX
Scooby Specialist
 
Member#: 108068
Join Date: Feb 2006
Location: Caracas, Venezuela
Vehicle:
05 WRX Enginuity'd
WRB Stg II y00!

Default

Flash it on a stg II map, and everything will be solved.

Also might think of getting the wideband o2, and the GM BCS and tune it.
EdWRX is offline   Reply With Quote
Old 11-13-2006, 08:06 PM   #21
athensway84
Scooby Newbie
 
Member#: 122346
Join Date: Aug 2006
Chapter/Region: SCIC
Location: Lawndale
Vehicle:
2006 Impreza Wrx
WRC Blue

Default

im having similar problems as a couple people on here. I added a Hks Downpipe and hi power exhaust. Now im getting check engine lights and fuel cuts at hi rpms in 4th gear. From what I read on here i should get EM? Can anyone help me on links to read up on EM or Mappings? I don't know much about EM but I want this problem to stop. Anyone help me!! haha thnx guys
athensway84 is offline   Reply With Quote
Old 11-14-2006, 04:19 PM   #22
dtseng01
Scooby Specialist
 
Member#: 105323
Join Date: Jan 2006
Chapter/Region: SCIC
Location: Monterey Park, California
Vehicle:
2005 Impreza WRX STi
Aspen White

Default

Quote:
Originally Posted by athensway84 View Post
im having similar problems as a couple people on here. I added a Hks Downpipe and hi power exhaust. Now im getting check engine lights and fuel cuts at hi rpms in 4th gear. From what I read on here i should get EM? Can anyone help me on links to read up on EM or Mappings? I don't know much about EM but I want this problem to stop. Anyone help me!! haha thnx guys

You're CEL light is probably just because of your catback not having any cats. The O2 sensor picks up too much crap and throws a CEL light. See if you can get a mechanical fix that'll push your O2 sensor a little out more.
dtseng01 is offline   Reply With Quote
Old 11-28-2006, 04:52 PM   #23
dsm02c
Scooby Newbie
 
Member#: 130822
Join Date: Nov 2006
Chapter/Region: South East
Location: Tampa, Fl
Vehicle:
2007 STi
SWP

Default

Quote:
Originally Posted by Cabal View Post
If you run a TBE with no EM, you get stuck in Iraq.

dsm02c is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
TBE w/ no EM.... need help please... ! RexRus Newbies & FAQs 22 09-14-2009 09:46 PM
downpipe install with no EM Wookie768 Factory 2.0L Turbo Powertrain 18 04-15-2006 12:08 PM
2006 WRX: Downpipe with no EM a good idea? Integra96 Factory 2.5L Turbo Powertrain 16 10-31-2005 07:58 AM
Running an Up-pipe and Downpipe with no EM... WRXem Factory 2.0L Turbo Powertrain 34 05-25-2005 09:00 PM
VF30's with no EM. Big-Sexy907 Factory 2.0L Turbo Powertrain 14 08-29-2004 03:01 PM


All times are GMT -4. The time now is 03:43 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.