Welcome to the North American Subaru Impreza Owners Club Thursday August 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-16-2006, 08:00 PM   #1
RobK0000
Scooby Specialist
 
Member#: 62230
Join Date: May 2004
Chapter/Region: NESIC
Default car studders in first

I changed my sparkplugs this morning, Platinum 4's. compared to the cheap $2 plugs i had in my car before. When i started teh car and sounded good no need to take it for a spin. SO morning after, i was going to head for school, and some strange reason everytime i released clutch and it grabbed the car kinda studdered forward felt like i was going on a rumble strip??? That cant be from the spark plugs can it?

Thanks
Rob K.
* Registered users of the site do not see these ads.
RobK0000 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Car studdering...wierd. help please subizzo02 Factory 2.0L Turbo Powertrain 28 04-09-2010 08:27 AM
Winter weather, boost high & car studdering Carreragt2e Factory 2.0L Turbo Powertrain 15 12-11-2006 06:38 PM
switched downpipes , now car studders kcook Factory 2.0L Turbo Powertrain 2 09-05-2006 02:31 PM
Car studders at 5 psi . SoDmFst Service & Maintenance 9 08-06-2006 03:08 PM
Car Studder Problem (Vacume to Boost) UpTown I-TS Normally Aspirated with bolt-on Forced Induction Powertrain 9 05-31-2006 01:01 PM


All times are GMT -4. The time now is 07:22 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.