Welcome to the North American Subaru Impreza Owners Club Monday May 4, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Alaskan Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Alaskan Impreza Club Forum -- AKIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-09-2006, 02:54 PM   #1
Racer Dubya
some old guy
Moderator
 
Member#: 112225
Join Date: Apr 2006
Chapter/Region: AKIC
Location: Anchorage
Vehicle:
1985 78 HP of Rage!
Blue

Default TGV Deletes and Cold Weather.

I have had several questions about how my car runs with the TGV Deletes in the cold weather.

While at home my car is in the garage but at work it is outside uncovered.

I haven't had any start-up, idle or studder issues in this weather. Car starts fine and pulls strong as well.

Let me know if you have specific questions.
* Registered users of the site do not see these ads.
Racer Dubya is offline   Reply With Quote
Old 11-19-2006, 09:13 PM   #2
LittleBlueGT
Scooby Specialist
 
Member#: 96204
Join Date: Sep 2005
Chapter/Region: W. Canada
Location: Winnipeg
Vehicle:
2013 STI GR
White

Default

You on legacygt.com?

Curious about TGV deletes myself, as I will be runing about 320 whp in the near future with my 05 LGT.

Are they really needed for a midly modded 2.5?
LittleBlueGT is offline   Reply With Quote
Old 11-19-2006, 09:28 PM   #3
AWDBST
Scooby Specialist
 
Member#: 80085
Join Date: Jan 2005
Chapter/Region: AKIC
Location: Anchorage
Vehicle:
11.8 117 Trap
Stock EJ205

Default

You don't need TGV deletes unless you are running a big turbo. Lik the ones with 3 inch inlets. But if you have in torn apart it is nice to go ahead and do them anyways.
AWDBST is offline   Reply With Quote
Old 11-19-2006, 10:53 PM   #4
00Maddog
Scooby Specialist
 
Member#: 62410
Join Date: May 2004
Chapter/Region: AKIC
Location: its bristol baby
Vehicle:
2004 wrx w/o engine
psm/carbon

Default

they are for emissions only. even some n/a cars have them.
00Maddog is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
TGV Delete and Cold Start PolarisSnT Open Source Reflashes 48 01-20-2011 08:51 AM
Doing TGV delete and downpipe, what fuel injector rubber is needed and APS inlet? cava23 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 4 02-24-2010 09:42 PM
TGV Deletes and Extreemly Cold Weather nicholam Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 8 03-10-2007 07:56 PM
Perf Tires and Cold Weather kpratte Brakes, Steering & Suspension 1 06-29-2001 09:41 AM
Turbos and cold weather -> special measures? Mr. Jones Technical Forum Archive 5 09-06-2000 09:32 PM


All times are GMT -4. The time now is 11:25 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.