Welcome to the North American Subaru Impreza Owners Club Saturday October 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-12-2006, 02:27 PM   #1
6lug
Scooby Newbie
 
Member#: 108817
Join Date: Feb 2006
Default clutch engagement issue...help quick please

ok, so I just got done replacing my clutch. At the end of the instructions I got online, it said that a very low clutch engagement would be noticed...my clutch now has like an inch of travel from the floor to full engagement. So it said this was expected...now how do I get it back to normal???



*nevermind..fixed it...thanks a whole bunch*
* Registered users of the site do not see these ads.

Last edited by 6lug; 11-12-2006 at 04:28 PM.
6lug is offline   Reply With Quote
Old 11-13-2006, 04:20 AM   #2
cbourbs
Scooby Specialist
 
Member#: 117749
Join Date: Jun 2006
Default

adjust your clutch pedal out!!that should do the trick
cbourbs is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird transmission/clutch engagement issue kahunaking Newbies & FAQs 3 08-23-2009 12:40 PM
Need help quickly please. Stage 2 Power Steering Issue. nofriends Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 2 12-30-2005 05:36 PM
Clutch engagement issue aspenwhitewrx Transmission (AT/MT) & Driveline 4 06-29-2005 11:13 PM
Clutch engagement issue Texas25RS Transmission (AT/MT) & Driveline 1 02-27-2004 12:14 PM


All times are GMT -4. The time now is 12:43 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.