Welcome to the North American Subaru Impreza Owners Club Friday July 11, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-21-2006, 12:16 PM   #1
imaaaron
Scooby Specialist
 
Member#: 74047
Join Date: Nov 2004
Location: South Jersey
Vehicle:
2005 STi
PSM

Default My Exhaust Woes

Its been less than a year since this happened. However, it was the first time I took pics and now that I have pics, I figured I'd post about it.

This all started after I'd owned my car for 8 months. The black paint started chipping off the exhaust. I take the car in and ask the dealer what can be done, they claim "SOA will consider this wear and tear, it won't be covered." Fine, I drive around for another year and a half with this crusty muffler. Luckily, by the time I was through, nearly ALL of the paint had chipped off and it was finally one color!

Unfortunately after owning it for about 2 years, it rattles. Dealer checks out the rattle and says the "element" has come loose in the muffler. Dandy! I finally get the exhaust I'd been waiting for! The dealer puts the paperwork through and SIX weeks later my muffler comes in. That was a long six weeks of rattling, thanks SOA.

Now for the installation. This isn't SOA's fault, but rather the dealers. They call, say its in, ask me when I can drop it off. I say "but its only a muffler, I can't just wait?" Nice girl at the dealership says "No I don't think so, we're probably going to need you to leave it." Fine, I make my appointment for about a week later. I think about it more and its two bolts and a gasket. This shouldn't take more than an hour. The dealership is 30 mins from me. Even though my schedule is tight, I'd rather sit at the dealership and waste an hour of my time rather than:

30 mins there
30 mins there (friend/ride)
30 mins back
30 mins back (friend/ride)
30 mins there
30 mins back.

Thats a lot of driving for 2 people over an axleback. I find the service managers number (Jim Donnelly) and figure I'll reason with him. Surely he'll see where I'm coming from. I call him and he too, insists that I drop it off! I call him one more time (kind of a PITA I know, but this is a PITA for me at this point) and he still denies my requests. He wins, I drop the car off.

I drive back to pick up my car and am just happy for it to be over with. I don't check out the work because "hey, its a two-bolt fix, how could it be screwed up?" I wash my car 4 days later and find the edge of the tip scuffed and dinged! I'm livid. I don't even bother going back because it its worth the 6 week wait time and ~3 hours labor (MY labor) to get rid of the dings.

However, how much did the little marks on the tip bother me, you ask? A lot. I picked up an SPT catback largely in part to the tip looking like crap about 6 months later. I was already in dismay over the dealerships work, but then I crawled under the car to change it out. I climb under and go "WTF is that??" Investigate it some more, and hrm, it appears that they never bothered to pull a sticker off the can. Smart guy probably thought it would eventually wash off, little did he know it would actually weld itself on.

What is the point of all this? Well, not sure really. I couldn't believe that you could actually screw up an axleback muffler install, I thought wrong though.

The dealer was Burke Subaru. I may buy a car there again, but they'll never see it for service.





C/N: Axleback went bad on my car, it took a long time to get fixed, and the Dealer did a poor job.
* Registered users of the site do not see these ads.
imaaaron is offline   Reply With Quote
Old 11-21-2006, 12:32 PM   #2
RBelcher00
Scooby Specialist
 
Member#: 100829
Join Date: Nov 2005
Chapter/Region: SCIC
Location: Corona, CA
Vehicle:
2006 WRX R.I.P. =(
'07 CBR600RR =)

Default

Welcome to Subaru dealership service departments.
RBelcher00 is offline   Reply With Quote
Old 11-21-2006, 01:46 PM   #3
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

Quote:
Originally Posted by RBelcher00 View Post
Welcome to Subaru dealership service departments.
We're not all like that

First, to the OP, even if the paint issue was wear and tear, wear and tear items are covered for 3 years or 36,000 miles. You need to familiarize yourself with your warranty, and apparently, your dealer too. (this I would call SOA on, because that dealer does not know Subaru warranty)

You also need to find out (probably from SOA) WHY the exhaust took so long. I think you will find that it was probably the dealer, not SOA. It probably never got ordered.

Unfortunately, the paint on the muffler, even if you got a new one, probably would have come off again. Your car is not the only one it happens to. But, I am not sure if it is a Subaru thing or a corrosion thing (crap on the road). I have replaced ones that just started to peel (under 3/36, no questions asked) only to have them peel again. Sucks, I know.
RexyGirl is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Exhaust woes. [image heavy] Farnk Newbies & FAQs 14 01-19-2006 10:50 AM
$72 later... my exhaust woes are gone! (www.mcnewsautomotive.com) Siper2 Mid Atlantic Impreza Club -- MAIC 5 07-11-2005 02:21 PM
Oh me oh my, My headlight woes. What should I do kids? trail*of*dead Electrical & Lighting 4 01-09-2005 02:05 AM
My work woes... Blindeye_03 South East Region Forum 14 01-03-2004 10:43 PM
Exhaust woes continue... bigdweeb New England Impreza Club Forum -- NESIC 11 06-11-2003 09:02 AM


All times are GMT -4. The time now is 08:17 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.