Welcome to the North American Subaru Impreza Owners Club Tuesday July 28, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-21-2006, 06:20 PM   #1
DTSJR
Scooby Newbie
 
Member#: 73780
Join Date: Nov 2004
Chapter/Region: NESIC
Vehicle:
2000 Impreza 2.5RS
SRP

Angry Broke something on my 93 SS

Im working on installing a new CTS (PITA) and while taking the intake off, this nifty little plastic peice broke in a few places. Im still working on taking off the part that connect to the block. What does it do, do I need it, how do I fix it?!

* Registered users of the site do not see these ads.
DTSJR is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 11-21-2006, 06:44 PM   #2
fibuz
Scooby Specialist
 
Member#: 53410
Join Date: Jan 2004
Chapter/Region: SWIC
Location: Tucson, AZ / Port Angeles, WA
Vehicle:
BE-> GD->GR->SG->BL
WAawd.org

Default

gum & duct tape ftw?

PM subiegal and try to find a part number for replacement?
fibuz is offline   Reply With Quote
Old 11-22-2006, 11:15 AM   #3
cowapult
Scooby Specialist
 
Member#: 25324
Join Date: Sep 2002
Chapter/Region: MAIC
Location: London, UK (formerly Wash DC)
Vehicle:
00 2.5RSwhite-sold
91 Legacy Turbo Red

Default

This comes from the area near the turbo, right? If so, it's just a plan old pipe - part of the PCV system.

Options
1) Buy a new one from a dealership
2) Try to glue it back together with JB weld (seems like a pain, and you'd definitely have to check for leaks)
3) Replace it with hoses and a y-splitter you can pick up at any local auto parts store. You might want to chop off the bottom fitting and re-use that fitting in your new contraption if it's not something standard (I've honestly never seen the bottom half of this part!).
4) Install a catch can, which I believe would effectively replace this fitting anyway.
5) Grab a used one from the junkyard or from a partout on bbs.legacycentral.org. You'd could also PM Blackbart on there.
cowapult is offline   Reply With Quote
Old 11-22-2006, 02:25 PM   #4
DTSJR
Scooby Newbie
 
Member#: 73780
Join Date: Nov 2004
Chapter/Region: NESIC
Vehicle:
2000 Impreza 2.5RS
SRP

Default

Last night I went out and bought some parts to make a new one of those out of hose connectors and tubing. I also have one on order from the dealership. I was hoping I could get it today, but it might not come until Tuesday.
DTSJR is offline   Reply With Quote
Old 11-22-2006, 03:39 PM   #5
DLC
out back
Moderator
 
Member#: 1964
Join Date: Jul 2000
Chapter/Region: RMIC
Location: 84XXX
Vehicle:
05 OB XT LTD
Silver/Gray

Default

The coolant tank on the driver side of the engine is the most common thing to break on the older turbos. Heat and age take their toll.
DLC is offline   Reply With Quote
Old 11-23-2006, 07:41 PM   #6
subiekid
Scooby Guru
 
Member#: 25516
Join Date: Oct 2002
Chapter/Region: NWIC
Location: Send help, stuck in internet!
Vehicle:
1995 Legacy TURBO!!!
EJ22T/TEC3 & '12 Civic

Default

Make sure to order the rubber hose that connects that "F" tube to the block. If you can't wait for the rubber part just go to an auto parts store and ask to see their hoses. I found some that fit and just used it (only needed like 2 inches).
subiekid is offline   Reply With Quote
Old 11-24-2006, 01:42 AM   #7
biggreen96
Scooby Specialist
 
Member#: 12535
Join Date: Nov 2001
Chapter/Region: NWIC
Location: Idaho slash Washington
Vehicle:
vf39 93 Legacy Wagon
92 Legacy Rally EG33'd

Default

I broke mine a few weeks ago, I went to napa and made one out of hose and plastic tees.
biggreen96 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
help, broke something on shifter instal RS 1986 Transmission (AT/MT) & Driveline 6 05-23-2010 10:16 PM
Broke 1kmls on my 05' STI!! Got $2000 to spend on Mods speedyralph Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 26 10-12-2004 01:06 AM
HELP! I broke something in my WRX! -=Ice-T=- Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 19 05-10-2004 01:01 PM
Need Help, I broke something on my WRX anant369 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 11 06-11-2002 06:05 PM


All times are GMT -4. The time now is 09:36 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.