Welcome to the North American Subaru Impreza Owners Club Thursday September 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-16-2001, 01:28 AM   #1
madmax1
Scooby Newbie
 
Member#: 8548
Join Date: Jul 2001
Location: bay area
Vehicle:
2002 wrx
silver

Angry camshaft sensor on 5 times

my camshaft sensor triggered my cel light for the fifth time yesterday
the fourth time i went into the shop a little pissed and they cleared the code for me while i waited and said they would contact the california subaru rep for me
two weeks later still no reply and the light went off again went back to the dealer for the fifth time very pissed and got the manager again,
this time he had just finished talking to the rep about my car and said that when the cel was triggered i was at 6900 rpm and that the light would come on every time i revved the engine that high
i said that is b.s. because it dosn't happen every time i bring the car to redline
anyway maybe he is going to send my ecu out for reprogramming which he said will take a month

my concern is if there is something really wrong with my car
does anyone really know what is happening in order for that sensor to trigger
does anyone know about the california lemon law
any help will be greatly appruciated
thanks
Max
* Registered users of the site do not see these ads.
madmax1 is offline   Reply With Quote
Old 11-16-2001, 09:18 AM   #2
Jon [in CT]
*** Banned ***
 
Member#: 2992
Join Date: Nov 2000
Chapter/Region: NESIC
Location: Connecticut, USA
Vehicle:
02 WRX Sedan
Silver

Default

Do you know whether this is the trouble code?
P0340 - Camshaft Position Sensor Circuit Malfunction

If so, first of all, suggest to your service department that they follow the Diagnostic Procedure given in the factory service manual for this trouble code. In essence, if they can't find a short circuit, open circuit or bad connection and if the sensor is securely bolted in place, they're supposed to replace the sensor. How many times have they replaced your camshaft position sensor?

Secondly, it appears that P0340 may be generated spuriously and that the fix is to reprogram the engine's computer. See, this thread:
http://www.i-club.com/forums/showthr...ighlight=p0340

Hopefully, the reprogramming doesn't fix the problem by reducing the rev-limiter cut-in to 6500 RPM.
Jon [in CT] is offline   Reply With Quote
Old 11-16-2001, 12:32 PM   #3
madmax1
Scooby Newbie
 
Member#: 8548
Join Date: Jul 2001
Location: bay area
Vehicle:
2002 wrx
silver

Default

yes i believe that is the correct code and they replaced my sensor once
do you know what the engine is doing to trigger this code?
madmax1 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Camshaft Sensor P/N:22056AA062 - $10 gedwrx Engine/Power/Exhaust 3 03-19-2007 02:32 PM
P0011 Camshaft Sensor Trouble Code TurboRex Factory 2.5L Turbo Powertrain 5 03-28-2005 08:03 AM
Camshaft Sensor Derylwc Newbies & FAQs 1 06-25-2004 05:56 PM
P0340 Camshaft sensor circuit code? TXS Stage 4... annointed Factory 2.0L Turbo Powertrain 9 02-20-2004 12:37 PM
got my new camshaft sensor for my CEl - P0304 i think Turbo Tin Can Factory 2.0L Turbo Powertrain 4 07-26-2002 06:36 PM


All times are GMT -4. The time now is 01:49 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.