Welcome to the North American Subaru Impreza Owners Club Tuesday September 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-05-2006, 10:16 PM   #1
Speedwagon
Scooby Specialist
 
Member#: 19681
Join Date: Jun 2002
Chapter/Region: RMIC
Location: Denver, CO
Vehicle:
1998 Legacy Wagon GT
Green

Default Well crap, I broke my strut

I recently discovered that my right rear strut was not quite tight. The strut itself was moving up and down a bit in the top mount. So I was busy trying to tighten the thing, and it didn't think the same thing. Stupid thing snapped the stud off!

These are STi v5 struts, too. Anyone know if there's a way to fix this? Or is the strut garbage now?
* Registered users of the site do not see these ads.
Speedwagon is offline   Reply With Quote
Old 12-05-2006, 10:37 PM   #2
KD7000
Scooby Specialist
 
Member#: 16653
Join Date: Mar 2002
Chapter/Region: NESIC
Location: Central MA
Vehicle:
2012 Mazda 3
2004 Honda Pilot

Question

Wait, did you just break a stud off the top mount, or did you actually break off the top of the strut shaft?
KD7000 is offline   Reply With Quote
Old 12-05-2006, 10:47 PM   #3
Speedwagon
Scooby Specialist
 
Member#: 19681
Join Date: Jun 2002
Chapter/Region: RMIC
Location: Denver, CO
Vehicle:
1998 Legacy Wagon GT
Green

Default

I broke the stud coming off the strut shaft. Not the tophat trio, the main stud connecting the strut to the tophat.
Speedwagon is offline   Reply With Quote
Old 12-05-2006, 10:53 PM   #4
KD7000
Scooby Specialist
 
Member#: 16653
Join Date: Mar 2002
Chapter/Region: NESIC
Location: Central MA
Vehicle:
2012 Mazda 3
2004 Honda Pilot

Default

Wow.

Those would typically take a large amount of torque to shear off. It must have been rattling around inside the tophat and had some crazy wear near the threads.

Looks like it's time to buy some new struts. And a new set of rear tophats.
KD7000 is offline   Reply With Quote
Old 12-05-2006, 10:56 PM   #5
Speedwagon
Scooby Specialist
 
Member#: 19681
Join Date: Jun 2002
Chapter/Region: RMIC
Location: Denver, CO
Vehicle:
1998 Legacy Wagon GT
Green

Default

Quote:
Originally Posted by KD7000 View Post
Wow.

Those would typically take a large amount of torque to shear off. It must have been rattling around inside the tophat and had some crazy wear near the threads.

Looks like it's time to buy some new struts. And a new set of rear tophats.
Yea, that's the only thing I can figure. Don't know how it managed to come loose in the first place though. But it does appear time for a new setup now.
Speedwagon is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Well crap ... my PhotoShop 6 CD crapped out. Jessie James Off-Topic 6 04-29-2009 01:38 PM
pls help me i broke my strut i need stock one Mr. SUAVE Private 'Wanted' Classifieds 0 11-08-2005 12:13 AM
broke my strut, what do i do now? WRC1 Brakes, Steering & Suspension 4 03-03-2005 03:21 AM
holy crap! I just broke my toe! bleuquila Off-Topic 16 12-18-2003 11:55 PM
HELP: I just broke my strut tower brace dubRexn Brakes, Steering & Suspension 10 04-21-2003 02:05 AM


All times are GMT -4. The time now is 02:51 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.