Welcome to the North American Subaru Impreza Owners Club Monday May 2, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 06-05-2015, 10:19 PM   #1
Need BB
Scooby Specialist
 
Member#: 66103
Join Date: Jul 2004
Chapter/Region: NESIC
Location: MA
Vehicle:
2005 Legacy GT Wagon
While

Default Uneven Brake Wear

I installed all new brakes last year including calipers, rotors, and pads. The front brakes are working great, but the rear are not wearing evenly across the face of the rotor. While the car was last at the dealer, the lead tech mentioned that this occurs when the car sits and the rust doesn't come off the rotors properly. He mentioned I would need the rotors turned.

Has anyone ever had this happen? I never had a car where the brakes needed to be turned if the car sat for two weeks. I only have 4,000 miles on the car since I did the brakes and I am disappointed that I am having issues.

* Registered users of the site do not see these ads.
Need BB is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 06-08-2015, 11:54 PM   #2
Need BB
Scooby Specialist
 
Member#: 66103
Join Date: Jul 2004
Chapter/Region: NESIC
Location: MA
Vehicle:
2005 Legacy GT Wagon
While

Default

Any ideas?
Need BB is offline   Reply With Quote
Old 06-10-2015, 09:18 AM   #3
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
QuickSilver Metallic

Default

It'll fix itself. Definitely no need to turn the rotors. If it bugs you, take a 3M Roloc Scotchbrite disk on a drill and clean it up.
Patrick Olsen is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 09:52 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.