Welcome to the North American Subaru Impreza Owners Club Saturday April 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Tire & Wheel Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Tire & Wheel

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-14-2006, 12:10 PM   #1
Danny Boy
Scooby Specialist
 
Member#: 94938
Join Date: Aug 2005
Chapter/Region: NESIC
Vehicle:
'99 Hybrid RS Coupe
don't-pull-me-over Silver

Default STi wheels on GC/GM/GF and rubbing issues

In the past half-year I've been getting lots of questions about running 2004 STi wheels and rubbing issues on my '99 RS.

Old Silver set:


Current Gold set:


The 2004 (and only the 2004) STi shares the same 5x100 bolt pattern with All Impreza's excluding the 2005-present STi.

2004 OEM STi BBS Wheel Specs
5x100 bolt pattern
+53mm offset
17x7.5

The factory tires that come on these STi wheels are 225/45/17 Bridgestone Potenza RE-070's. YOU WILL HAVE RUBBING ISSUES IN THE REAR FENDERS WITH 225 series tires with ANY suspension. You can eliminate the Rubbing issues one of two differnt ways:
1. Have the rear fenders rolled out a little bit to provide a little extra clearance.
or....
2. Run 215 series tires.

Currently my suspension setup is KYB AGX's and SPT Springs. I have rolled my rear fenders to accomodate the 225 series tires and have no rubbing issues anymore. Next week I am installing H&R sport springs and will report back on if there are any rubbing issues with that setup.

I hope this thread helps people looking at rubbing issues in general or specifically running 2004 STi wheels.

Danny
* Registered users of the site do not see these ads.
Danny Boy is offline   Reply With Quote
Old 12-14-2006, 03:34 PM   #2
mrpedal
Scooby Newbie
 
Member#: 71361
Join Date: Sep 2004
Chapter/Region: BAIC
Location: SFBay
Vehicle:
2000 Impreza 2.5RS
silver

Default

Quote:
Originally Posted by Danny Boy View Post
The factory tires that come on these STi wheels are 225/45/17 Bridgestone Potenza RE-070's. YOU WILL HAVE RUBBING ISSUES IN THE REAR FENDERS WITH 225 series tires with ANY suspension. You can eliminate the Rubbing issues one of two differnt ways:
1. Have the rear fenders rolled out a little bit to provide a little extra clearance.
or....
2. Run 215 series tires.

Currently my suspension setup is KYB AGX's and SPT Springs. I have rolled my rear fenders to accomodate the 225 series tires and have no rubbing issues anymore.
Couple questions..
  1. What is your car's ride height (these are SPT pink springs)?
  2. When you had rubbing, it was only on the fender side and not on the strut?
  3. Do have upgraded sway bars, and if so what thickness?
  4. STM - this your autocross class? Can you list any other suspension mods you have?
mrpedal is offline   Reply With Quote
Old 12-14-2006, 04:20 PM   #3
Danny Boy
Scooby Specialist
 
Member#: 94938
Join Date: Aug 2005
Chapter/Region: NESIC
Vehicle:
'99 Hybrid RS Coupe
don't-pull-me-over Silver

Default

Quote:
Originally Posted by mrpedal View Post
Couple questions..
  1. What is your car's ride height (these are SPT pink springs)?
  2. When you had rubbing, it was only on the fender side and not on the strut?
  3. Do have upgraded sway bars, and if so what thickness?
  4. STM - this your autocross class? Can you list any other suspension mods you have?
1. The SPT springs (Blue/darkish I think - bought them used so they were dirty) drop the RS 3/4" front and back.
2. The only rubbing was on the fender side. There should be a little (and I mean TINY like a couple sheets of paper) space on the strut side.
3. I'm running the FHI 20mm rear sway bar and the stock front sway bar.
4. STM = Silverthorn Metallic (Subaru's silver paint color from 93-01), STS = Street Touring S (my auto-x class).
5. All suspension mods: KYB AGX adjustable shocks, SPT springs (H&R sport springs going on next week), 20mm FHI Rear sway bar, and Kartboy solid rear sway bar end links.

Danny
Danny Boy is offline   Reply With Quote
Old 12-15-2006, 02:30 PM   #4
recnelis
Scooby Specialist
 
Member#: 92778
Join Date: Aug 2005
Chapter/Region: NESIC
Location: Connecticut
Vehicle:
2000 Impreza 2.5RS
#74 ST - RCE Tarmac 2

Default

For what it's worth, my old set of worn-to-wearbars 225/50/16 v700s (on '00/'01 RS wheels) had "rubbing" issues on the strut body in the rear with stock springs (at least I think they're stock). This was due to the sticky tire picking up debris and it coming into contact with the spring perch.

With the same wheels and tires, but now lowered on Prodrive WR springs and struts, I had rubbing on the front fender/inner lining on big bumps. In the rear, I had rubbing on the strut on one corner, but that was also the corner with -2.0* of camber. The other side at -1.6* was fine.
recnelis is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone remember the really old group buy on GC/GM/GF carpet? Siper2 Interior & Exterior Modification 15 10-02-2006 01:59 AM
Wanted: Pics of 17" Prodrive P7 wheels on GC/GM RS! Siper2 Member's Car Gallery 22 10-12-2005 11:32 AM
why wont 16x8 slipstreams work on a GC/GM/GF? psyber_0ptix Tire & Wheel 16 09-02-2005 01:06 PM
May be parting out my car, tons of GC/GM/GF parts and WRX brakes, swaybar BenBortner Private 'For Sale' Classifieds 14 08-17-2005 02:55 PM
To those who put a Ver6 rear bumper on their GC/GM/GF Billy Interior & Exterior Modification 2 06-11-2005 10:04 AM


All times are GMT -4. The time now is 01:51 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.