Welcome to the North American Subaru Impreza Owners Club Wednesday July 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
South West Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > South West Impreza Club Forum -- SWIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-24-2006, 03:56 PM   #1
v8eaterWRX
Scooby Guru
 
Member#: 108547
Join Date: Feb 2006
Chapter/Region: SWIC
Location: boondock camping
Vehicle:
2013 RAM 2500 4x4
6.7l Cummins

Default flagstaff people - may need help quick

well apparently my bad luck is still following me. seems my turbo took a crap this afternoon in flagstaff and I need to be back to work in chadler on tuesday. the car won't boost past 5psi and has black crap coming out of the exhaust. I had to fill up with crappy gas on the way here because there were no shell stations so could I have gotten bad gas? no cels. any help would be greatly appreciated. thanks guys!
* Registered users of the site do not see these ads.

Last edited by v8eaterWRX; 12-24-2006 at 04:35 PM.
v8eaterWRX is offline   Reply With Quote
Old 12-24-2006, 03:59 PM   #2
schooby
Scooby Specialist
 
Member#: 89387
Join Date: Jun 2005
Chapter/Region: SWIC
Location: Phoenix,AZ
Vehicle:
2005 RS
White

Default

i don't know anything on turboed cars or i would help you out.
schooby is offline   Reply With Quote
Old 12-24-2006, 04:41 PM   #3
v8eaterWRX
Scooby Guru
 
Member#: 108547
Join Date: Feb 2006
Chapter/Region: SWIC
Location: boondock camping
Vehicle:
2013 RAM 2500 4x4
6.7l Cummins

Default

well I just got back to my hotel and checked my oil. no metal shavings and at a good level. had my girlfriend start the car with my hand at the exhaust and no more black junk. reset the ecu and changed my realtime map to stage II 91 octane but stll only boosts to 5psi. added some octane booster too, but I'm sure that isn't gonna help any. car feels a little sluggish but I don't know that its because of this or if its just the different altitude. it had a really rough idle this morning when I started it, but I think that was due to the heavy oil. any ideas? I can't decide whether its safe to drive home or if I should have my buddy bring the car hualer up.
v8eaterWRX is offline   Reply With Quote
Old 12-24-2006, 04:52 PM   #4
pudnana
Scooby Newbie
 
Member#: 89071
Join Date: Jun 2005
Chapter/Region: SWIC
Location: Lake Montezuma AZ
Vehicle:
2000 Blue 2.5 RS
2004 Java WRX

Default

i run cobb stage 2 on my 04 wrx and i just use the gas from the fry's grocery store. No trouble at all. Most if not all gas in arizona comes from the same refineries, so it really doesn't matter where you buy it from. i think if you have a problem boosting, you either have a turbo problem or a vaccuum line off somewhere.
pudnana is offline   Reply With Quote
Old 12-24-2006, 04:54 PM   #5
dozer54321
Scooby Specialist
 
Member#: 116437
Join Date: Jun 2006
Chapter/Region: SWIC
Location: Glendale, AZ
Vehicle:
2002 WRX - MINE
99 SUS - WIFEY

Default

i personally would use a car hauler, at least you know you cant hurt anything else by putting it on a hauler
dozer54321 is offline   Reply With Quote
Old 12-24-2006, 09:14 PM   #6
pimpininaz
Scooby Specialist
 
Member#: 88362
Join Date: Jun 2005
Chapter/Region: SWIC
Location: Flagstaff AZ
Vehicle:
2007 WRX Limited
SATIN WHITE PEARL

Default

what up hommie? the sluggishness is from the altitude one of the drawbacks to flagstaff, do you have an egt gauge? if you have black crap coming out then there is obviously a oil or fuel issue. pm me if you need a mechanic at a cheap price. id help but am off my feet with a broken ankle
pimpininaz is offline   Reply With Quote
Old 12-24-2006, 09:58 PM   #7
v8eaterWRX
Scooby Guru
 
Member#: 108547
Join Date: Feb 2006
Chapter/Region: SWIC
Location: boondock camping
Vehicle:
2013 RAM 2500 4x4
6.7l Cummins

Default

well I checked my boost with the ap and it has been 13-14 psi, so I guess my mechanical gauge is just off? the black crap I have determined to be my cat cleaning itself out from my injector cleaner I ran cause its not doing it now. I'm still a couple psi low, but not as drastic as I thought. seems like I'm good, guess ill know when I get back to the valley. thanks for the help guys!
v8eaterWRX is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help quick on springs g7run Brakes, Steering & Suspension 0 06-03-2010 02:57 PM
may need help with aem wideband a/f gauge install 005sti Mid Atlantic Impreza Club -- MAIC 3 05-10-2005 05:07 PM
amplified road noise, may need help auricom Mid Atlantic Impreza Club -- MAIC 11 03-06-2003 08:36 AM
need help quick trojan9x Normally Aspirated Powertrain 4 05-21-2001 09:39 PM
('93-'01) Need HELP quick please... kaos200 Impreza Forum 2 04-21-2001 08:22 AM


All times are GMT -4. The time now is 03:56 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.