Welcome to the North American Subaru Impreza Owners Club Thursday November 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-28-2006, 06:16 PM   #1
runninstrong
Scooby Specialist
 
Member#: 121474
Join Date: Jul 2006
Chapter/Region: NESIC
Location: Middle East of CT
Vehicle:
1991 SS & 2013 STi
Red & Blue

Default Help! Lights won't turn off!

OKAY of course there is a new issue with my 95 BG, the damn parking lights won't turn off now. I know it usually does this when the battery gets disconnected, but if you start the car up again, they turn off. Well, this time they won't. I replaced the light bulbs behind the dash and the ac/heater as well, and boom, all of a sudden the parking lights won't turn off? I have no idea why, everything seems to be working fine, where did I go wrong?
* Registered users of the site do not see these ads.
runninstrong is offline   Reply With Quote
Old 12-28-2006, 06:17 PM   #2
Danny Boy
Scooby Specialist
 
Member#: 94938
Join Date: Aug 2005
Chapter/Region: NESIC
Vehicle:
'99 Hybrid RS Coupe
don't-pull-me-over Silver

Default

Check the switch on the steering column that controls the parking lights. It's independent of the ignition.
Danny Boy is offline   Reply With Quote
Old 12-28-2006, 06:34 PM   #3
danNYtrack
Scooby Newbie
 
Member#: 129710
Join Date: Oct 2006
Chapter/Region: Tri-State
Location: Hudson Valley
Vehicle:
2004 WRX
PSM

Default

I had the same thing happen to me when I bought my old 93L wagon. Don't feel bad!!!
danNYtrack is offline   Reply With Quote
Old 12-28-2006, 06:36 PM   #4
subiekid
Scooby Guru
 
Member#: 25516
Join Date: Oct 2002
Chapter/Region: NWIC
Location: Send help, stuck in internet!
Vehicle:
1995 Legacy TURBO!!!
EJ22T/TEC3 & '12 Civic

Default

If you look in the FAQ there is a thread titled "HELP Lights will not turn off!!!"
subiekid is offline   Reply With Quote
Old 12-28-2006, 09:28 PM   #5
runninstrong
Scooby Specialist
 
Member#: 121474
Join Date: Jul 2006
Chapter/Region: NESIC
Location: Middle East of CT
Vehicle:
1991 SS & 2013 STi
Red & Blue

Default

Quote:
Originally Posted by Danny Boy View Post
Check the switch on the steering column that controls the parking lights. It's independent of the ignition.
I just took apart the whole dashboard of the car, I know this car very well, although...can't say I've had this issue before. That was the first thing I checked. haha, thanks for the help though.
runninstrong is offline   Reply With Quote
Old 12-28-2006, 09:37 PM   #6
legacy99black
Scooby Newbie
 
Member#: 52238
Join Date: Jan 2004
Chapter/Region: NESIC
Location: Guilford, Vermont
Vehicle:
2001 Legacy GT LTD
Hummer Black

Default

I did that when I first took apart my BD dash, I thought I broke something.
legacy99black is offline   Reply With Quote
Old 12-28-2006, 09:51 PM   #7
runninstrong
Scooby Specialist
 
Member#: 121474
Join Date: Jul 2006
Chapter/Region: NESIC
Location: Middle East of CT
Vehicle:
1991 SS & 2013 STi
Red & Blue

Default

Alright, I just remembered I took this apart twice, and you guys got me to question whether I turned it off the second time when I put the trim ring back on, well sure enough I didn't. I was in such a rush, totally didn't even notice. Thanks muchly.
runninstrong is offline   Reply With Quote
Old 12-29-2006, 01:45 AM   #8
Wiscon_Mark
Scooby Guru
 
Member#: 94945
Join Date: Aug 2005
Chapter/Region: MWSOC
Location: Stevens Point, WI
Vehicle:
1995 Legacy OB 5MT
2003 Forester X 5MT

Default



Threads like this make me giggle.
Wiscon_Mark is offline   Reply With Quote
Old 12-29-2006, 02:58 AM   #9
Chi_San
Scooby Guru
 
Member#: 53558
Join Date: Jan 2004
Chapter/Region: NWIC
Location: Deadford, OR
Vehicle:
2002 WRX Wagon
Silver

Default

Quote:
Originally Posted by Wiscon_Mark View Post


Threads like this make me giggle.
You giggle a lot.
Chi_San is offline   Reply With Quote
Old 12-29-2006, 11:29 AM   #10
LetItSnow
Scooby Specialist
 
Member#: 38222
Join Date: Jun 2003
Chapter/Region: Tri-State
Location: Cicero, NY
Vehicle:
'10 &'12 Foresters
another Miata convert

Default

That switch has given us so much amusement over the years...
LetItSnow is offline   Reply With Quote
Old 12-29-2006, 11:36 AM   #11
badbasser98
Scooby Specialist
 
Member#: 104801
Join Date: Jan 2006
Chapter/Region: NESIC
Location: Upstate, NY
Vehicle:
2011 WRX Limited
DGM

Default

I remember the first time I did that I felt like such a dumbass after.

Also the time i forgot my trunk was popped on my BE and the interior lights wouldn't shutoff, that was a good one too
badbasser98 is offline   Reply With Quote
Old 12-29-2006, 01:58 PM   #12
redlegacygt
Scooby Specialist
 
Member#: 82994
Join Date: Mar 2005
Chapter/Region: MAIC
Location: Danville, PA
Vehicle:
1997 Legacy GT
Rio Red

Default

lol these are like the stories of the trunk lock thing...guess there's always something that will trip you up...
redlegacygt is offline   Reply With Quote
Old 12-29-2006, 02:08 PM   #13
illegal2.2
Scooby Specialist
 
Member#: 58329
Join Date: Mar 2004
Chapter/Region: MWSOC
Location: MN
Vehicle:
97 Legacy GT
Rio Red

Default

about trunks, i guess someone switched the locked button the trunk. I stood there yanking on my trunk and had someone press the trunk leverage. Found out that the switch was on lock!! and i couldn't get access since i got wrx rear seats so the tearing began. lolz
illegal2.2 is offline   Reply With Quote
Old 12-29-2006, 05:10 PM   #14
runninstrong
Scooby Specialist
 
Member#: 121474
Join Date: Jul 2006
Chapter/Region: NESIC
Location: Middle East of CT
Vehicle:
1991 SS & 2013 STi
Red & Blue

Default

Truly a noob mistake. Thanks for the help once again.
runninstrong is offline   Reply With Quote
Old 12-29-2006, 11:47 PM   #15
Wiscon_Mark
Scooby Guru
 
Member#: 94945
Join Date: Aug 2005
Chapter/Region: MWSOC
Location: Stevens Point, WI
Vehicle:
1995 Legacy OB 5MT
2003 Forester X 5MT

Default

Quote:
Originally Posted by Chi_San View Post
You giggle a lot.
What can I say? I lead a happy life

(sort of)
Wiscon_Mark is offline   Reply With Quote
Old 12-29-2006, 11:52 PM   #16
Chi_San
Scooby Guru
 
Member#: 53558
Join Date: Jan 2004
Chapter/Region: NWIC
Location: Deadford, OR
Vehicle:
2002 WRX Wagon
Silver

Default

Well, that's a good reason.
Chi_San is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Front turn signal, brake light, and running light won't turn off Floor it Electrical & Lighting 0 06-27-2009 11:34 PM
My lights won't turn off after I turn the car off. need HELP sillyme Newbies & FAQs 8 12-18-2008 09:41 PM
Help, Lights Won't Turn Off BlackRex22 Southern California Impreza Club Forum -- SCIC 12 11-03-2003 06:01 PM
Need quick Help! Parking lights won't turn off Conduit Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 8 10-13-2001 12:31 PM


All times are GMT -4. The time now is 11:11 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.