Welcome to the North American Subaru Impreza Owners Club Saturday August 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-21-2001, 05:53 PM   #1
TurboSub
Scooby Newbie
 
Member#: 8701
Join Date: Jul 2001
Location: Greenwood Lake NY
Vehicle:
2002 WRX
WR Blue Pearl

Question CEL question?

How bad is it if the CEL comes on. It's happen to me twice , I think both times were cause by the gas cap not being on right. Here are a couple of questions I have: 1. If it is a steady light is there still a possible problem 2. Do I have to reset the ECU after a CEL 3. where can I take my car to have someone pull the code, can I do it my self, any mechanic , just subaru? 4. Is it bad to just leave it alone when the light comes on?

Thanks for any help.

James
* Registered users of the site do not see these ads.
TurboSub is offline   Reply With Quote
Old 11-21-2001, 09:18 PM   #2
yamarocket630
Scooby Specialist
 
Member#: 9436
Join Date: Aug 2001
Chapter/Region: MWSOC
Location: My member# is lower than yours
Vehicle:
05 Saab 9-5 Aero

Default

The cel means the ECU has detected a problem. It could be minor or major. No way to know unless you pull the code. ANY OBDII scanner will pull the code. Should you reset it? Not unless you know what the problem is... unless you like driving around with a mystery problem that could be major.
yamarocket630 is offline   Reply With Quote
Old 11-21-2001, 09:39 PM   #3
Flesher
Scooby Newbie
 
Member#: 7921
Join Date: Jun 2001
Location: www.i-club.com
Vehicle:
2002 WRX
Sliver

Default

According to a subaru mechanic that I asked the same question, if the light is on steady and the car seems to be running ok it's not an emergency to get it checked; it's just some part of the emissions system not working 100%. If the CEL's blinking then it _is_ a big problem, and you should go to a dealer ASAP.
Flesher is offline   Reply With Quote
Old 11-21-2001, 11:35 PM   #4
wolf8314
Scooby Specialist
 
Member#: 9185
Join Date: Aug 2001
Chapter/Region: MAIC
Location: Still just Coots
Vehicle:
2012 Toyota Tundra
Black

Default I know what your going through

Let me tell you ....i know exzactly what your going through. I have had problems with my CEL ever sense i bought the car. Most recently the CEL would come for two to three days then go off for a week then come back. Real weird. I noticed no performance loss, but went to the dealer neways. THey suggested since i had no performance loss to reset the ECU. SO i did and ahvent had a CEL in 2 weeks now and have had no problems. Word of advise though.........make sure you dissconnect your alarm or be fore warned that your alarm will go off after your reconnect your alarm. My ears still are ringing and my head still hurts
wolf
wolf8314 is offline   Reply With Quote
Old 11-23-2001, 09:45 AM   #5
TurboSub
Scooby Newbie
 
Member#: 8701
Join Date: Jul 2001
Location: Greenwood Lake NY
Vehicle:
2002 WRX
WR Blue Pearl

Default

Thanks for the help guys. I have no performance loss, the car is running just as good as before, so I'm just gonna reset the ECU.
TurboSub is offline   Reply With Quote
Old 11-23-2001, 09:50 AM   #6
SubEd
Scooby Guru
 
Member#: 717
Join Date: Jan 2000
Chapter/Region: NESIC
Default Re: I know what your going through

Quote:
Originally posted by wolf8314
I noticed no performance loss, but went to the dealer neways. THey suggested since i had no performance loss to reset the ECU.
Wolf, that's bad advice on your dealers' part. They are obligated to pull it to see if there is anything to be concerned about. The light came on for a reason - could be as small as a loose gas cap, but it could be for something more serious.

Sounds like they were being slackers.

Ed
SubEd is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Flashing cel question mikaust Factory 2.0L Turbo Powertrain 3 12-24-2001 01:45 PM
CEL Question... Strafe Factory 2.0L Turbo Powertrain 20 12-14-2001 11:32 PM
exhaust/OBDII/CEL questions 2.0 guy Factory 2.0L Turbo Powertrain 7 09-03-2001 12:10 AM


All times are GMT -4. The time now is 12:31 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.