Welcome to the North American Subaru Impreza Owners Club Sunday October 4, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Thread Tools Display Modes
Old 01-03-2007, 07:35 PM   #1
Scooby Newbie
Member#: 131662
Join Date: Nov 2006
Chapter/Region: E. Canada
Location: Toronto
1996 Legacy LS

Default Coolant temp sensor, is it in this picture?

Alright, i have searched plenty and found people asking but really no answers

I removed the air box thinking it would be right under it from previous advice
no dice

now, i faintly see a brown female end of some sort of sensor, could it be the temp sensor?

is it somewhere underneath in the middle of this picture?

is it hidden there in the middle of the photo? (beside the visible brownish cable)

i was thinking this would be alot easier than what i have made it out to be
* Registered users of the site do not see these ads.
breakfasteatre is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-04-2007, 08:47 AM   #2
North Ursalia
Miss You Mom
Oct 1940 - Feb 2008

Super Moderator
Member#: 809
Join Date: Jan 2000
Chapter/Region: NESIC
Location: NH, Land Of Many Trees
2000 2.5 RS, '14 For
92 5MT SVX


It's buried under the intake manifold on the passenger side. It's in the coolant crossover pipe. Remove those hoses (the large ones) in the second photo and you should be able to see it.

North Ursalia is offline   Reply With Quote
Old 01-04-2007, 12:28 PM   #3
Scooby Specialist
Member#: 53856
Join Date: Jan 2004
Chapter/Region: NESIC
Location: NoVerm Brah......
2012 Speed3
Red Mica


Yep it's burried under the intake manifold on the passenger side. I just did one on my freinds 1.8 impreza. Do you have the part yet? That helps because you will know exactly what it looks like. It is a little bit of a beeoch to get to but it's not that bad. Get some coolant because you will leak some when you take the coolant temp sensor out.

Or you can try to put the new one in really quickly so yo lose as little as possible.
abosworth is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Is it me or is something wrong in this picture? BigWrecKs Off-Topic 27 01-02-2007 03:39 PM
Help finding Intake Air Temp or Coolant temp sensor jacksonww Legacy Forum 1 08-27-2002 01:42 PM
Stock coolant temp sensor Jewbaru Normally Aspirated with bolt-on Forced Induction Powertrain 7 07-17-2002 09:23 PM
Coolant temp sensor LVSUBARU Normally Aspirated with bolt-on Forced Induction Powertrain 11 03-19-2002 12:28 AM

All times are GMT -4. The time now is 08:28 PM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.