Welcome to the North American Subaru Impreza Owners Club Wednesday October 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
South West Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > South West Impreza Club Forum -- SWIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-04-2007, 02:39 PM   #1
Black-Falcon
Scooby Specialist
 
Member#: 106318
Join Date: Jan 2006
Chapter/Region: SWIC
Location: AZ
Vehicle:
14 Cadirrack
ATS

Default Wow my fuel mileage sucks.

Well I got my gauges installed and a new exhaust installed at DynoComp. When I picked it up, Rich told me that my rear o2 sensor was cross-threaded (thanks Subaru), and that he just zip-tied it up under the car.
I said alright, fine. I asked him it would affect the afr or the fueling trims of the car at all? He said no, so I went home.

Well I've been driving around today for about 100 miles and besides the damn cat rattling around, everything was fine.

Then I looked at my fuel tank, which was much lower than normal for only 100 miles

I searched around on iwsti.com and on nasioc, and I found that the rear o2 sensor might affect the afr and trims, as well as cruising and idling.

Mods:
Cobb Stage 2
APS 3" TBE w/ cat (going to be removed soon, want to be catless)
Defis: Boost, EGT, OilPres.


So I'm asking you if I'm right, or is Rich?



CN: Rich at Dynocomp couldnt reinstall my rear o2, told me that it would be fine, and wouldn't affect the fuel ratios or trims. My gas tank says otherwise. Does it really affect the afr and trims?
* Registered users of the site do not see these ads.
Black-Falcon is offline   Reply With Quote
Old 01-04-2007, 03:41 PM   #2
Evil_STI
*** Banned ***
 
Member#: 106521
Join Date: Feb 2006
Chapter/Region: SWIC
Location: is_gay
Vehicle:
I am an ancient of
chaos. \\ t3hclap.com

Default

Dude...I have the same problem I go 195 then I have to fill up
Evil_STI is offline   Reply With Quote
Old 01-04-2007, 03:44 PM   #3
taerron
Scooby Specialist
 
Member#: 75744
Join Date: Nov 2004
Chapter/Region: SWIC
Location: phoenix (valley of the damned)
Vehicle:
2k2 low boostin
evo3, for now....

Default

sweet, i thought i was the only one getting crappy mileage. i barely hit 120 at 1/2 tank now. but i think my gauge is off too a little bit. at 1/2 tank, i filled up and it only put in 5.6 gal. 1/2 tank should be closer to 8 gal.
taerron is offline   Reply With Quote
Old 01-04-2007, 03:45 PM   #4
Evil_STI
*** Banned ***
 
Member#: 106521
Join Date: Feb 2006
Chapter/Region: SWIC
Location: is_gay
Vehicle:
I am an ancient of
chaos. \\ t3hclap.com

Default

Nah....Our tanks hold like 14.2 or sumthing unless they changed it over the years...
Evil_STI is offline   Reply With Quote
Old 01-04-2007, 03:46 PM   #5
szeny
Scooby Guru
 
Member#: 81383
Join Date: Feb 2005
Chapter/Region: SWIC
Location: Paradise Valley
Vehicle:
07 335i e90
TiAG/Dakota Black

Default

Quote:
Originally Posted by Evil WRX View Post
Dude...I have the same problem I go 195 then I have to fill up
thats cuz you cant drive! hahahahah jk
szeny is offline   Reply With Quote
Old 01-04-2007, 03:47 PM   #6
Evil_STI
*** Banned ***
 
Member#: 106521
Join Date: Feb 2006
Chapter/Region: SWIC
Location: is_gay
Vehicle:
I am an ancient of
chaos. \\ t3hclap.com

Default

Well when I shift I shift at 3000...Thats what alot of other people shift at as well.
Evil_STI is offline   Reply With Quote
Old 01-04-2007, 03:49 PM   #7
szeny
Scooby Guru
 
Member#: 81383
Join Date: Feb 2005
Chapter/Region: SWIC
Location: Paradise Valley
Vehicle:
07 335i e90
TiAG/Dakota Black

Default

dude i had a vf22 and fmic and would boost first gear to 40 then go to 4th not to mention boost corners and freeway and i got 21mpg avg...would get like 230-265per tank
szeny is offline   Reply With Quote
Old 01-04-2007, 03:49 PM   #8
coolcatcolin
Scooby Specialist
 
Member#: 66517
Join Date: Jul 2004
Chapter/Region: MWSOC
Location: Valparaiso,IN
Vehicle:
'03
my bugeye is gone

Default

Yeah my mileage sucks as well I think I'm getting roughly 16 mpg in the city. I had no O2 sensor in my downpipe for a while because mine was cross threaded as well so I got a new one eventually and it's in the car and I really didn't notice a difference I just have sucky gas mileage.

P.S. I just bought those same gauges.
coolcatcolin is offline   Reply With Quote
Old 01-04-2007, 03:53 PM   #9
Evil_STI
*** Banned ***
 
Member#: 106521
Join Date: Feb 2006
Chapter/Region: SWIC
Location: is_gay
Vehicle:
I am an ancient of
chaos. \\ t3hclap.com

Default

Quote:
Originally Posted by szeny View Post
dude i had a vf22 and fmic and would boost first gear to 40 then go to 4th not to mention boost corners and freeway and i got 21mpg avg...would get like 230-265per tank
Damn. 21mpg

Thats crazy!

Okaie...

For the WRX TR
20 City
27 Highway

STI
19 City
25 Highway
Evil_STI is offline   Reply With Quote
Old 01-04-2007, 03:56 PM   #10
Drew For The Win
Scooby Newbie
 
Member#: 136084
Join Date: Dec 2006
Chapter/Region: SWIC
Location: Tempe, AZ/ Valparaiso IN
Vehicle:
2002 GTI 337
Silver

Default

i think part of the reason for the bad gas mileage would be most people commenting are either stage 2 or stage 3. the different mods and ecu changes would probably have something to do with it.
Drew For The Win is offline   Reply With Quote
Old 01-04-2007, 03:58 PM   #11
Evil_STI
*** Banned ***
 
Member#: 106521
Join Date: Feb 2006
Chapter/Region: SWIC
Location: is_gay
Vehicle:
I am an ancient of
chaos. \\ t3hclap.com

Default

Ohhkaie I went out and checked my milage....I have 267 miles on it and almost empty...Maybe it was just me but it seem's like I dont even make that many miles..LOL I have 21,000miles ALREADY!
Evil_STI is offline   Reply With Quote
Old 01-04-2007, 04:04 PM   #12
v8eaterWRX
Scooby Guru
 
Member#: 108547
Join Date: Feb 2006
Chapter/Region: SWIC
Location: boondock camping
Vehicle:
2013 RAM 2500 4x4
6.7l Cummins

Default

I'm pulling about 21 on stage 2 and that is either city or highway. only changes around 1mpg for me.
v8eaterWRX is offline   Reply With Quote
Old 01-04-2007, 04:19 PM   #13
taerron
Scooby Specialist
 
Member#: 75744
Join Date: Nov 2004
Chapter/Region: SWIC
Location: phoenix (valley of the damned)
Vehicle:
2k2 low boostin
evo3, for now....

Default

Quote:
Originally Posted by Evil WRX View Post
Nah....Our tanks hold like 14.2 or sumthing unless they changed it over the years...
no, its a 15.9 gal tank
taerron is offline   Reply With Quote
Old 01-04-2007, 04:27 PM   #14
Poweredbysnail
Scooby Specialist
 
Member#: 74753
Join Date: Nov 2004
Chapter/Region: BAIC
Location: Snail Performance
Vehicle:
2003 Wrx 2.5Lw/gt30r
Team Snail

Default

Yeah its only a 15.9 gal tank Man i get better fuel mileage then you i get about 24 to 25 miles per gallon if i keep my foot out of it.
Poweredbysnail is offline   Reply With Quote
Old 01-04-2007, 04:29 PM   #15
Evil_STI
*** Banned ***
 
Member#: 106521
Join Date: Feb 2006
Chapter/Region: SWIC
Location: is_gay
Vehicle:
I am an ancient of
chaos. \\ t3hclap.com

Default

Ohh yeah I knew 14 didnt sound right.

But still my tank fills 9.98 AT THE MOST when my light goes on..Maybe my gauge is dumb..
Evil_STI is offline   Reply With Quote
Old 01-04-2007, 04:35 PM   #16
szeny
Scooby Guru
 
Member#: 81383
Join Date: Feb 2005
Chapter/Region: SWIC
Location: Paradise Valley
Vehicle:
07 335i e90
TiAG/Dakota Black

Default

thats why you do your own work! dont pay somone for gauges and exhaust! then your car works the same after!

PS> THERE is NO way the 02 sensor caused that. Because my rear o2 sesor didnt even work and was unplugged. i only had it in so there wasnt a leak... sounds like you either need a retune or some company doesnt know how to install stuff right

maybe your car isnt accounting for all this new found breathability (post turbo flow)
szeny is offline   Reply With Quote
Old 01-04-2007, 04:46 PM   #17
mike91401
Scooby Newbie
 
Member#: 86510
Join Date: May 2005
Chapter/Region: SWIC
Location: Phoenix, AZ
Vehicle:
2010 Toyota Tacoma
Silver

Default

Quote:
Originally Posted by Black-Falcon View Post
Well I've been driving around today for about 100 miles and besides the damn cat rattling around, everything was fine.
Damn cats! That's why you should have a Dog! (sorry.. couldn't resist)

Quote:
Originally Posted by Evil WRX View Post
Ohh yeah I knew 14 didnt sound right.

But still my tank fills 9.98 AT THE MOST when my light goes on..Maybe my gauge is dumb..
Are you sure it's the gauge that is dumb?
mike91401 is offline   Reply With Quote
Old 01-04-2007, 04:54 PM   #18
taerron
Scooby Specialist
 
Member#: 75744
Join Date: Nov 2004
Chapter/Region: SWIC
Location: phoenix (valley of the damned)
Vehicle:
2k2 low boostin
evo3, for now....

Default

my light came on close to 14gal. 14gal is an evo gas tank
taerron is offline   Reply With Quote
Old 01-04-2007, 05:03 PM   #19
boarderguy
Scooby Specialist
 
Member#: 131955
Join Date: Nov 2006
Chapter/Region: SWIC
Location: colorado/phoenix/panama
Vehicle:
2006 2.5i
OBP/Red Mud

Default

ha ha ha i have the 2.5 and stock i have gotten most 420 miles on a tank average like 350-370 cruising arround town i just got a better air filter so i might get a bit better good gas mileage but lacking power bad.
boarderguy is offline   Reply With Quote
Old 01-04-2007, 05:04 PM   #20
AaronB
Worst Mod Ever
Moderator
 
Member#: 369
Join Date: Oct 1999
Chapter/Region: SWIC
Location: Phoenix, AZ
Vehicle:
12 Vagon

Default

If I get 20 in either car it is fantastic mileage...
AaronB is offline   Reply With Quote
Old 01-04-2007, 05:09 PM   #21
Evil_STI
*** Banned ***
 
Member#: 106521
Join Date: Feb 2006
Chapter/Region: SWIC
Location: is_gay
Vehicle:
I am an ancient of
chaos. \\ t3hclap.com

Default

Quote:
Originally Posted by mike91401 View Post
Are you sure it's the gauge that is dumb?
The STOCK guage? yes.

Evil_STI is offline   Reply With Quote
Old 01-04-2007, 05:24 PM   #22
Black-Falcon
Scooby Specialist
 
Member#: 106318
Join Date: Jan 2006
Chapter/Region: SWIC
Location: AZ
Vehicle:
14 Cadirrack
ATS

Default

Quote:
Originally Posted by coolcatcolin View Post
Yeah my mileage sucks as well I think I'm getting roughly 16 mpg in the city. I had no O2 sensor in my downpipe for a while because mine was cross threaded as well so I got a new one eventually and it's in the car and I really didn't notice a difference I just have sucky gas mileage.

P.S. I just bought those same gauges.
You will love them


Quote:
Originally Posted by szeny View Post
maybe your car isnt accounting for all this new found breathability (post turbo flow)
Well considering I had a turbo back before...probably not.


Everyone check out this thread:
http://www.iwsti.com/forums/showthre...ht=rear+sensor
Black-Falcon is offline   Reply With Quote
Old 01-04-2007, 05:42 PM   #23
szeny
Scooby Guru
 
Member#: 81383
Join Date: Feb 2005
Chapter/Region: SWIC
Location: Paradise Valley
Vehicle:
07 335i e90
TiAG/Dakota Black

Default

well plug it back in...use some clamps or somethin to hold it down since its stripped
szeny is offline   Reply With Quote
Old 01-04-2007, 05:48 PM   #24
Black-Falcon
Scooby Specialist
 
Member#: 106318
Join Date: Jan 2006
Chapter/Region: SWIC
Location: AZ
Vehicle:
14 Cadirrack
ATS

Default

I'm going to see if fish will warranty it since it came out of the stock exhaust like that
Black-Falcon is offline   Reply With Quote
Old 01-04-2007, 05:49 PM   #25
Evil_STI
*** Banned ***
 
Member#: 106521
Join Date: Feb 2006
Chapter/Region: SWIC
Location: is_gay
Vehicle:
I am an ancient of
chaos. \\ t3hclap.com

Default

Ask his homo ass if he is going tonight?
Evil_STI is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My WRX gas mileage sucks sonic_boost_wagon Off-Topic 22 11-02-2007 03:44 PM
Cobb Stage 2 but my gas mileage SUCKS.... smac AccessPort 31 07-23-2007 11:37 PM
Holy Hell My Gas Mileage Sucks! Gecko2k2 Legacy Forum 8 04-09-2004 09:50 AM
why does my mileage suck? Omis Tri-State Area Forum 25 05-20-2003 06:53 PM
Fuel Mileage has dropped since my K&N - normal? Slalom RS Normally Aspirated Powertrain 3 01-03-2003 04:50 PM


All times are GMT -4. The time now is 01:00 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.