Welcome to the North American Subaru Impreza Owners Club Sunday July 24, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Notices

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 01-05-2007, 12:46 AM   #1
baby_Z_350
Scooby Newbie
 
Member#: 79899
Join Date: Jan 2005
Default CEL came on again recently

Hi everybody, could someone help me out for which I have this code
< P0456 - Evaporative emission control system malfunction >

" A guy told me that "Alot of times, the fault is caused by the Electrical harness in the rear for the Purge Solenoid, by the canister. Sometimes, there is moisture build up, or dirt build up that causes a bad connection on the connector. Or the on the harness, there is a splice inside the loom, and the splice usually corrodes or falls off due to moisture aswell. "

would that be the problem?? if not,can anyone show me a picture of which part i should chk out....thank you.
* Registered users of the site do not see these ads.
baby_Z_350 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-05-2007, 08:06 AM   #2
bWRX
Scooby Specialist
 
Member#: 6672
Join Date: May 2001
Chapter/Region: MAIC
Location: murland
Default

What car are we talking about here?
bWRX is offline   Reply With Quote
Old 01-05-2007, 11:36 AM   #3
Hayes
Scooby Specialist
 
Member#: 11808
Join Date: Oct 2001
Location: Cape Coral,FL
Default

+1 to check the gas cap sealing. Then the hoses that go to the solioid and charcol canister for leaks and pinching. I would think the electrical harness would be a very long shot so do the easy first.
Hayes is offline   Reply With Quote
Old 01-06-2007, 05:44 AM   #4
baby_Z_350
Scooby Newbie
 
Member#: 79899
Join Date: Jan 2005
Default

it's a 2001 rs coupe 2.5rs....
baby_Z_350 is offline   Reply With Quote
Old 01-06-2007, 11:55 AM   #5
Uncle Scotty
*** Banned ***
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK buy Nates beans
westcoastroasting.com

Default

Quote:
Originally Posted by baby_Z_350 View Post
it's a 2001 rs coupe 2.5rs....
...put that in yer damned profile so we know ya not talkin about a farking Pinto
Uncle Scotty is offline   Reply With Quote
Old 01-08-2007, 04:00 AM   #6
baby_Z_350
Scooby Newbie
 
Member#: 79899
Join Date: Jan 2005
Default

Considering that I'm a newbie, if u dont want to help, u can go read the next post.
baby_Z_350 is offline   Reply With Quote
Old 01-08-2007, 08:38 PM   #7
blackfang
Scooby Guru
 
Member#: 131347
Join Date: Nov 2006
Chapter/Region: MAIC
Location: Richmond Va
Vehicle:
2007 Legacy 2.5i SE
98 Z/28, VN 900 custom

Default

I have replaced a few Purge Solenoid's on a few cars.
blackfang is offline   Reply With Quote
Old 01-09-2007, 01:01 AM   #8
baby_Z_350
Scooby Newbie
 
Member#: 79899
Join Date: Jan 2005
Default

really?? is it hard to replace these solenoid?
baby_Z_350 is offline   Reply With Quote
Old 01-09-2007, 01:05 AM   #9
Uncle Scotty
*** Banned ***
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK buy Nates beans
westcoastroasting.com

Default

Quote:
Originally Posted by baby_Z_350 View Post
Considering that I'm a newbie, if u dont want to help, u can go read the next post.
......d000000d.....do NOT get an attitude or ya may get NO(good) help with anything around here.

GOT IT????
Uncle Scotty is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine died on highway and Fuel Pump Controller CEL came on garface Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 5 12-05-2003 02:16 PM
My WRX CEL came on and pulled 3 codes! 42202sub Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 7 07-04-2002 02:57 PM
CEL came on again ImprezaTs Normally Aspirated Powertrain 11 03-11-2002 09:46 PM
CEL came on first time SilverDragon Tri-State Area Forum 7 02-08-2002 07:15 PM
My CEL came on at 8090 miles... UU AR EX Southern California Impreza Club Forum -- SCIC 0 10-11-2001 08:46 PM

All times are GMT -4. The time now is 07:19 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.