Welcome to the North American Subaru Impreza Owners Club Tuesday October 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-10-2007, 12:51 AM   #1
Fusionpnoy
Scooby Specialist
 
Member#: 43752
Join Date: Sep 2003
Chapter/Region: Tri-State
Unhappy Clicking clutch pedal

Hi Everyone,

I have a MY04 WRX. When I depress the clutch, right before it is fully at the bottom of the footwell there is a clicking sound. Does anyone know what that is? It happens on every shift, and it started happening two days ago.

I tried looking tonight, but it is to late and to cold to be doing that.
* Registered users of the site do not see these ads.
Fusionpnoy is offline   Reply With Quote
Old 01-10-2007, 12:56 PM   #2
AphexDouble
Scooby Newbie
 
Member#: 96427
Join Date: Sep 2005
Chapter/Region: SCIC
Location: Riverside, CA
Vehicle:
2010 Legacy 3.6R
Pearl White

Default

Yup.. my 04 does the same thing.. BUT my clutch is also gong to be replaced in the next week or so. Might want to get yours checked out - not 100% sure if the click noise is cause because of a warn down clutch.
AphexDouble is offline   Reply With Quote
Old 01-10-2007, 09:27 PM   #3
Counterfit
Scooby Guru
 
Member#: 124254
Join Date: Aug 2006
Chapter/Region: NESIC
Location: Rhode Island
Vehicle:
2006 06 SGM Slowbaru
"The Scoobinator"

Default

Is it coming from the footwell area? It might be the switch that senses whether it's depressed or not.
Counterfit is offline   Reply With Quote
Old 01-10-2007, 11:01 PM   #4
neuhate9999
Scooby Newbie
 
Member#: 85796
Join Date: Apr 2005
Chapter/Region: NESIC
Location: Blacstone, MA
Vehicle:
2005 WRX
Silver

Default

try to start the car before it clicks. if it wont start then push it till it clicks and try to start it. if it starts the clicking you hear is your clutch safety switch. It is normal.
neuhate9999 is offline   Reply With Quote
Old 01-11-2007, 02:11 PM   #5
strohausii
Scooby Specialist
 
Member#: 26770
Join Date: Oct 2002
Chapter/Region: South East
Location: Tampa
Vehicle:
'02 WRX
midnight black

Default

I don't hear a click, but more like feel one (last 1" to 1/2" of fully depressed). My clutch is in the beginning of the end now, but I can't help to wonder if the slave is starting to act up too.
strohausii is offline   Reply With Quote
Old 02-24-2007, 03:31 PM   #6
Imurpushr
Scooby Newbie
 
Member#: 141315
Join Date: Feb 2007
Chapter/Region: NESIC
Location: Putnam Valley NY
Default

My clicking is the same but I've traced it to the inside the bell housing possibly a broken spring??? 20K hard miles.
Imurpushr is offline   Reply With Quote
Old 03-08-2007, 06:21 PM   #7
juztin180
Scooby Specialist
 
Member#: 11804
Join Date: Oct 2001
Location: New Smyrna Beach/Daytona Beach
Default

is it from the pedal itself?

Having some issues myself and noticed on my 02 there is a rubber piece of the arm of the clutch pedal that touches one of the sensors to tell if its engauged or not. It had some dirt on it and was sticking the rubber piece to the sensor and then when getting far enough away it would snap back and make a loud click. Cleaned it up a bit and its gone
juztin180 is offline   Reply With Quote
Old 03-09-2007, 02:38 AM   #8
pooster.online
Scooby Newbie
 
Member#: 120461
Join Date: Jul 2006
Chapter/Region: BAIC
Location: Bay Area/ L.A
Vehicle:
2004 WRX STi JBP

Default

I have a clicking too on my 04 STi, I always thought it was b/c the pedal was not oiled enough?
pooster.online is offline   Reply With Quote
Old 05-13-2007, 02:13 PM   #9
kainam00
Scooby Specialist
 
Member#: 100708
Join Date: Nov 2005
Chapter/Region: MWSOC
Location: Michigan
Vehicle:
2000 2.5RS
2006 WRX

Default

Same noise here after doing the clutch... trying to figure it out
kainam00 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Clutch Pedal to Floor = Loud Clicking calmdev Transmission (AT/MT) & Driveline 3 01-16-2009 08:06 AM
clutch pedal clicking noise GeLLo_Boi Newbies & FAQs 6 03-01-2008 08:37 PM
Clicking Clutch pedal Soulofdarkness Newbies & FAQs 1 11-23-2005 03:43 PM
Metallic Clicking sound when clutch pedal depressed Craig W Transmission (AT/MT) & Driveline 4 07-31-2005 10:14 PM


All times are GMT -4. The time now is 08:59 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.