Welcome to the North American Subaru Impreza Owners Club Saturday December 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-14-2007, 02:12 AM   #1
_JsWRX
Scooby Newbie
 
Member#: 119117
Join Date: Jul 2006
Chapter/Region: AKIC
Location: Juneau
Vehicle:
06 wrx sgm
SGM

Default Metallic noise when letting off gas

My 06 Wagon is stock w/ no upgrades. When accelerating at any gear up to around 4k and letting off the gas pedal and let the rpm drop to around 2.5K , I hear a vibrating tingy metallic rattle noise up in the engine compartment where the turbo lies. What noise is this and is it normal, my best guess is it might have something to do w/ the stock turbo heat shield. Its not loud but noticeable. Any ideas ?
* Registered users of the site do not see these ads.
_JsWRX is offline   Reply With Quote
Old 01-14-2007, 01:13 PM   #2
billg
Scooby Newbie
 
Member#: 92766
Join Date: Aug 2005
Chapter/Region: BAIC
Location: Novato, CA near San Francisco
Vehicle:
2005 STI
Silver

Default

I had the same problem, and it was the welds on the heat shield coming unwelded. I had it re-welded for an hours labor, and the problem disappeared.
billg is offline   Reply With Quote
Old 01-14-2007, 04:29 PM   #3
cwepruk
Scooby Newbie
 
Member#: 121757
Join Date: Aug 2006
Location: Edmonton, Alberta
Vehicle:
2005 Subaru Forester
White

Default

2.5 k I get the same thing with my VF39 Forester. Never had it with the stock turbo. A lot of people said their VF series turbos made some odd noises, but kept running long and strong, so I ignored it.
cwepruk is offline   Reply With Quote
Old 01-14-2007, 06:24 PM   #4
ant927
Scooby Newbie
 
Member#: 65585
Join Date: Jul 2004
Location: Oakland, CA
Vehicle:
04 FXT
java

Default

Quote:
Originally Posted by cwepruk View Post
2.5 k I get the same thing with my VF39 Forester. Never had it with the stock turbo. A lot of people said their VF series turbos made some odd noises, but kept running long and strong, so I ignored it.

^ that's weird, me too on my FXT w/vf39. Noticeable when I lift off the gas abruptly at lower rpms (2-3K). Kind of a scratchy sound.
ant927 is offline   Reply With Quote
Old 01-16-2007, 02:20 PM   #5
jigga
Scooby Guru
 
Member#: 9960
Join Date: Sep 2001
Location: in bed...
Vehicle:
2002 Impreza WRX
WRBlue Perl

Default

Quote:
Originally Posted by billg View Post
I had the same problem, and it was the welds on the heat shield coming unwelded. I had it re-welded for an hours labor, and the problem disappeared.
agreed... I had the same issue too for the longest time... I just got the shields removed and no more rattle...
jigga is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Car shakes violently when letting off gas at 5k rpms? Help... ImportVenom Transmission (AT/MT) & Driveline 9 10-21-2011 07:16 AM
noise when letting off the gas crxgator Transmission (AT/MT) & Driveline 2 06-28-2009 11:25 PM
Smoke out bov when let off gas????? EklipzGSXkid Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 23 08-05-2008 01:38 AM
NEED HELP!! Weird sound from turbo when letting off gas. VIDEO INCLUDED panman91 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 27 05-10-2007 01:04 PM
wierd noise when letting off acceleration, sounds like tranny is grinding or somethin ASpec818 Transmission (AT/MT) & Driveline 3 12-29-2003 10:23 PM


All times are GMT -4. The time now is 04:21 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.