Welcome to the North American Subaru Impreza Owners Club Friday April 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-14-2007, 08:02 PM   #1
rallymarty
Scooby Newbie
 
Member#: 17418
Join Date: Apr 2002
Chapter/Region: RMIC
Location: Littleton, CO
Vehicle:
2002 WRX
2002 S6 Avant

Default Help with CEL...

I have a po440 CEL (evap. emiss. control malfunction) on my wife's '00 pontiac. i replaced the gas cap already thinking this was the culprit. no luck, the CEL is back. what else could be the problem?
* Registered users of the site do not see these ads.
rallymarty is offline   Reply With Quote
Old 01-14-2007, 10:01 PM   #2
DrD
Scooby Guru
 
Member#: 22412
Join Date: Aug 2002
Chapter/Region: SWIC
Location: Albuquerque, NM
Vehicle:
2012 Legacy 2.5GT
Ice Silver Metallic

Default

Maybe other parts of the evap. system? Charcoal cannister, valves/solenoids, etc. - check to see if any wires are broken, etc. - for specific diagnostic stuff, it really helps if you have the service manual for the car, though...
DrD is offline   Reply With Quote
Old 01-15-2007, 07:19 PM   #3
blackfang
Scooby Specialist
 
Member#: 131347
Join Date: Nov 2006
Chapter/Region: MAIC
Location: Richmond Va
Vehicle:
2007 Legacy 2.5i SE
98 Z/28, VN 900 custom

Default

Whenever you have an evap code first place to check is the gas cap. Verify it is tight and reset light. If light comes back on with the same evap codes then the charcoal canister, purge valve, etc might be the culprit.
blackfang is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
****need Help With Cel Codes-please Help************** stito Subaru Conversions 4 07-29-2007 04:55 AM
need help with CEL slammedWRX Factory 2.0L Turbo Powertrain 3 08-06-2002 12:16 AM
Help with CEL P0457 EVAP Sparks Factory 2.0L Turbo Powertrain 8 07-15-2002 10:35 AM
Help with CEL! WRXavier Service & Maintenance 3 06-26-2002 08:24 PM
Need help with CELs BluJay Tri-State Area Forum 3 11-03-2001 08:31 PM


All times are GMT -4. The time now is 01:23 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.