Welcome to the North American Subaru Impreza Owners Club Sunday November 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-26-2001, 11:03 AM   #1
knoffer
Scooby Newbie
 
Member#: 12669
Join Date: Nov 2001
Location: SE WI
Vehicle:
2000 Impreza 2.5 RS
Blue

Default Oxygen Sensor problems on 2000 Impreza 2.5 RS

I would like to know if anyone else has had problems with the front O2 sensor on their Impreza 2.5 RS?

I've had three changed out so far including the original and the recall letter. Now their (Subaru) is telling me that there may be a need to replace the ECM and put in a different sensor.

At this point I'm a little miffed that a car of this caliber is having such problems with a relatively unsophisticated / standard part.

Any feedback / experience would be greatly appreciated.

Thanks in advance.

knoffer
* Registered users of the site do not see these ads.
knoffer is offline   Reply With Quote
Old 11-26-2001, 11:14 AM   #2
JGard
pooptastic
 
Member#: 1904
Join Date: Jul 2000
Chapter/Region: TXIC
Location: Austin, TX
Vehicle:
2014 Lexus IS 350
01 Miata red

Default

don't know what to tell ya.

I had my O2 replaced via recall, however, I never saw a problem before that. I still haven't had a problem with it, that I can tell.

I mean, are you throwing CE lights or something?
JGard is offline   Reply With Quote
Old 11-26-2001, 11:25 AM   #3
Impreza Rider
Scooby Specialist
 
Member#: 756
Join Date: Jan 2000
Chapter/Region: MAIC
Location: Ashburn, Va
Vehicle:
2003 Legacy L wagon
2009 Kawasaki C14

Default

I know that on some of the MY00 RS's, when the o2 sensor would go bad, the ECU would "short out" and both would have to be replaced, or the o2 sensors would continue to go bad.
Impreza Rider is offline   Reply With Quote
Old 11-26-2001, 11:29 AM   #4
knoffer
Scooby Newbie
 
Member#: 12669
Join Date: Nov 2001
Location: SE WI
Vehicle:
2000 Impreza 2.5 RS
Blue

Default

Not only do I throw the CE light, I can be driving along at a constant speed and all of a sudden the car will start chugging and drop about 5 MPH. If I give it gas it will come out of this mood and be alright for a while. If I don't give it gas it will still come out of this mode but it will take longer.
My gas mileage also drops about 5 GPM when the sensor goes. The car is running extremely rich. The dealer has confirmed this when they scan it.
When they replace the sensor everything is alright until it eventually craps out again.

Thanks,

Ken
knoffer is offline   Reply With Quote
Old 11-26-2001, 11:31 AM   #5
inpreza kid
Scooby Specialist
 
Member#: 3334
Join Date: Dec 2000
Location: Calgary, Alberta, Canada
Default

i did the o2 sensor recall a few months back. no didn't have any problems before or after the recall. don't know about the ecu.
inpreza kid is offline   Reply With Quote
Old 11-26-2001, 11:42 AM   #6
mrbell
Scooby Specialist
 
Member#: 1871
Join Date: Jul 2000
Location: Salt Lake City, UT
Vehicle:
2000 Impreza 2.5RS
Blue Ridge Pearl

Default

I didn't have a problem originally, but I got the recall notice, so I went ahead and had the o2 sensor replaced... well... then I had problems... got it replaced again, and still had problems, so they replaced it a third time, and no problems since...
I have heard of the ECU being replaced when the o2 sensor doesn't fix it, but I didn't have to...
mrbell is offline   Reply With Quote
Old 11-26-2001, 01:39 PM   #7
Section 8
Scooby Specialist
 
Member#: 821
Join Date: Jan 2000
Chapter/Region: MWSOC
Location: "Like a hyena you are..."
Default

Are you paying for the ECU? If not have them replace it. If three sensors went bad, I would imagine that there is something else that needs to be taken care of. If you need to pay for it for some reason or another (out of warrenty already) you HAVE to get stinky about it. Lemon Laws in some states are pretty direct in their nature as well as being on your side, and you might already qualify as having a lemon.

FWIW- My O2 sensor went bad at 2,600 miles, was replaced under warrenty, and I have not had any problems again with it. Though I have just passed 6000, so we will see.

Greg
Section 8 is offline   Reply With Quote
Old 11-27-2001, 12:20 PM   #8
mrbell
Scooby Specialist
 
Member#: 1871
Join Date: Jul 2000
Location: Salt Lake City, UT
Vehicle:
2000 Impreza 2.5RS
Blue Ridge Pearl

Default

You people are bad luck... my car started acting up a bit last night then the CE light came on... I'm betting its the O2 sensor...
mrbell is offline   Reply With Quote
Old 11-27-2001, 01:55 PM   #9
Faraz
What?...
Do they speak English in What?

Moderator
 
Member#: 1459
Join Date: May 2000
Chapter/Region: Tri-State
Location: Allentown
Vehicle:
2008 WRX 5door MT
WR Blue

Default

nice cross post, now which thread do you want deleted?
Faraz is offline   Reply With Quote
Old 11-27-2001, 06:16 PM   #10
RebelINS
Scooby Specialist
 
Member#: 2953
Join Date: Nov 2000
Chapter/Region: MWSOC
Location: Rochester, MI, USA
Vehicle:
2000 Impreza 2.5RS
2005 Impreza WRX STi

Default

I've had my O2 sensor replaced two or three times, and just blew another one last sunday I'm pretty sure. I have to take my car in tomorrow. The only problem is the dealership over the phone was giving me a hassle about replacing it because my car is over 36,000 miles. We'll see if they take the cost tomorrow, if not I will be very upset.

-Wes
RebelINS is offline   Reply With Quote
Old 11-28-2001, 09:20 AM   #11
subarumantoo
Scooby Specialist
 
Member#: 3257
Join Date: Dec 2000
Location: Houston, TX
Vehicle:
2000 ImprezaRS
Blue Ridge Pearl

Default

I own a 2000RS and I am now on my 3rd O2 sensor (front). No charge to replace it (warranty). Still sucks to see that bright orange CEL come on though!
subarumantoo is offline   Reply With Quote
Old 12-03-2001, 02:42 AM   #12
RebelINS
Scooby Specialist
 
Member#: 2953
Join Date: Nov 2000
Chapter/Region: MWSOC
Location: Rochester, MI, USA
Vehicle:
2000 Impreza 2.5RS
2005 Impreza WRX STi

Default

I actually got so sick of looking at the CEL from my O2 sensor that I took the bulb out, so it wouldn't shine. (I already had my gauges apart for something else)

-Wes
RebelINS is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help with emergency brake issue on 2000 Impreza 2.5 RS PastorBrian Brakes, Steering & Suspension 2 09-11-2005 12:07 AM
Oxygen Sensor problems on 2000 Impreza 2.5 RS Antonio Domit Subaru Conversions 4 09-25-2004 01:56 PM
FS - 2000 Impreza 2.5 RS - BRP - 5 speed - *pics* Slalom RS New England Impreza Club Forum -- NESIC 29 07-25-2003 09:57 AM
FS - 2000 Impreza 2.5 RS - BRP - 5 speed - New England *pics* Slalom RS Private Vehicle 'For Sale' Classifieds 8 07-24-2003 12:09 PM
Oxygen Sensor problems on 2000 Impreza 2.5 RS knoffer Warranty Issues & SOA Problems 20 12-12-2001 06:04 PM


All times are GMT -4. The time now is 08:25 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.