Welcome to the North American Subaru Impreza Owners Club Tuesday September 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-16-2007, 11:01 PM   #1
fearlessfairless
Scooby Newbie
 
Member#: 91381
Join Date: Jul 2005
Chapter/Region: SCIC
Location: northridge, CA
Vehicle:
2004 STi wingless
WRB

Default Check Engine light is always on

Hey everyone,

I have an '01 2.5RS and my check engine light is always on. When I take the car to get smog'd, it says there is a misfire on cylinder 4 but I have taken the car to 4 dealerships and they all tell me they can't find anything wrong with the car and that there is nothing that can be done. I was hoping someone on here might have some helpfull info because I need to get this light off so the car can get smog'd. Thanks alot.
* Registered users of the site do not see these ads.
fearlessfairless is offline   Reply With Quote
Old 01-17-2007, 09:36 AM   #2
z&cobb
Scooby Specialist
 
Member#: 12344
Join Date: Nov 2001
Chapter/Region: MAIC
Location: Mountains of Maryland
Vehicle:
2002 2JC
blue

Default

Don't you hate it when "experts" just give up?

Have you disconnected the negative terminal of the battery and let it sit that way overnight. The next morning reconnect the the terminal, and do the hands off feet off basic start and warm up procedure. Maybe the cel will go away.

If not, you can request testing, or replacing, the spark plugs and associated wires. I don't know much about the RS ignition though.
z&cobb is offline   Reply With Quote
Old 01-17-2007, 06:18 PM   #3
badtaste
Scooby Newbie
 
Member#: 116636
Join Date: Jun 2006
Chapter/Region: MWSOC
Location: ohio
Vehicle:
2003 impreza
black

Default

try a coil pack and wires ive had to actually replace 3 pcms cause of somthing similar
badtaste is offline   Reply With Quote
Old 01-18-2007, 05:59 PM   #4
rick-l
Scooby Specialist
 
Member#: 33868
Join Date: Mar 2003
Location: Chesterfield, MO
Vehicle:
2003 wrx
srp

Default

Does this car have a wasted spark ignition? (1 coil per 2 cylinders) If so I doubt the spark would be bad in just one cylinder and I'm sure one of the experts changed the plugs.

You aren't losing any coolant are you? Where I'm going here is head gasket leak causing intermittent misfire (by intermittent I mean more than once per 3 drive cycles)

Did they look at fuel trim and see if there was excess oxygen or excess hydrocarbons in the exhaust? Where I'm going here is a bad fuel injector.

I take it the car runs/idles fine? A subaru dealership should have known all these issues so you may.......
rick-l is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My 2002 WRX check engine light is on and is overheating. SUBY1305 Newbies & FAQs 17 01-15-2010 01:26 PM
My check engine light is on but car is running fine. Ripper Normally Aspirated Powertrain 27 09-24-2001 11:59 AM
Check Engine Light Is On!! Ya its Yellow Factory 2.0L Turbo Powertrain 3 09-06-2001 06:35 PM
Uh Oh my check engine light is on Tainted South West Impreza Club Forum -- SWIC 21 07-27-2001 12:18 PM
Need Help-Check Engine light is on AndyHidley Technical Forum Archive 3 05-19-2000 01:35 PM


All times are GMT -4. The time now is 04:22 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.