Welcome to the North American Subaru Impreza Owners Club Wednesday August 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-19-2007, 04:35 PM   #1
rougeben83
Scooby Guru
 
Member#: 115154
Join Date: May 2006
Chapter/Region: MWSOC
Location: NYC
Vehicle:
2005 Outback XT
White on grey

Default Stuck gas pedal

Hey all,
Something kinda scary happened today...pulled onto a 3 lane boulevard, started to shift to 3rd, mid-way the gas pedal got stuck, and kept going up to the redline...I think it bounced off the limiter once or twice . Anyway, tapped it a couple of times and went back to normal (I was in midshift so it started climbing while I was in neutral). Anyone had this happen? That was the weirdest thing to happen to this car to date (that wasn't my own doing )

I think the gas pedal got stuck under my extra heavy rubber floormats, but just wanted to make sure. You don't think my poor EJ25 will have any problems bouncing off the limiter like that? (funny thing because, I NEVER bounce the rev limiter when I do any event)

I quickly lubed up the pedal cable at the TB right after that just to be sure though...
* Registered users of the site do not see these ads.
rougeben83 is offline   Reply With Quote
Old 01-19-2007, 04:40 PM   #2
fibuz
Scooby Specialist
 
Member#: 53410
Join Date: Jan 2004
Chapter/Region: SWIC
Location: Tucson, AZ / Port Angeles, WA
Vehicle:
BE-> GD->GR->SG->BL
WAawd.org

Default

subaru heavy rubber floormats FTL. gf has them and I can't stand them.
fibuz is offline   Reply With Quote
Old 01-19-2007, 05:10 PM   #3
Wiscon_Mark
Scooby Guru
 
Member#: 94945
Join Date: Aug 2005
Chapter/Region: MWSOC
Location: Stevens Point, WI
Vehicle:
1995 Legacy OB 5MT
2003 Forester X 5MT

Default

I like stock - no problems to date.
Wiscon_Mark is offline   Reply With Quote
Old 01-19-2007, 05:13 PM   #4
rougeben83
Scooby Guru
 
Member#: 115154
Join Date: May 2006
Chapter/Region: MWSOC
Location: NYC
Vehicle:
2005 Outback XT
White on grey

Default

But I'm stock too
rougeben83 is offline   Reply With Quote
Old 01-19-2007, 05:16 PM   #5
andivic
Scooby Specialist
 
Member#: 7568
Join Date: Jun 2001
Location: New York
Default

how about try taking out Legacy carpet under the rubber mat ?
andivic is offline   Reply With Quote
Old 01-19-2007, 05:54 PM   #6
Wiscon_Mark
Scooby Guru
 
Member#: 94945
Join Date: Aug 2005
Chapter/Region: MWSOC
Location: Stevens Point, WI
Vehicle:
1995 Legacy OB 5MT
2003 Forester X 5MT

Default

Quote:
Originally Posted by rougeben83 View Post
But I'm stock too
I mean the carpet mats with all the grippers on the bottom - mine does not do that.

Andy is right though, the stock (carpet) floormats are often found underneath the heavy duty rubber mats and is usually culprit.
Wiscon_Mark is offline   Reply With Quote
Old 01-19-2007, 06:06 PM   #7
rougeben83
Scooby Guru
 
Member#: 115154
Join Date: May 2006
Chapter/Region: MWSOC
Location: NYC
Vehicle:
2005 Outback XT
White on grey

Default

lol mark and your one liners

Yeah, I have the stock ones...I guess it's not very smart to run 3 layers of floormats (you read right) First time this has happened to me since I started driving. Weird...

Last edited by rougeben83; 01-19-2007 at 07:22 PM.
rougeben83 is offline   Reply With Quote
Old 01-19-2007, 06:52 PM   #8
andivic
Scooby Specialist
 
Member#: 7568
Join Date: Jun 2001
Location: New York
Default

BTW, my clutch pedal sometimes gets stuck by the legacy carpet. I need to figure out a way to make carpet stay instead of keep moving forward !! any bright idea beside using velcro ?
andivic is offline   Reply With Quote
Old 01-19-2007, 07:25 PM   #9
Plays_With_toys
Scooby Specialist
 
Member#: 82556
Join Date: Mar 2005
Location: Parker, Colorado
Vehicle:
1996 Legacy L wagon

Default

I hate floor mats. Over the summer I drive without them. Newer cars have clips that hold them back.
Plays_With_toys is offline   Reply With Quote
Old 01-19-2007, 08:23 PM   #10
rougeben83
Scooby Guru
 
Member#: 115154
Join Date: May 2006
Chapter/Region: MWSOC
Location: NYC
Vehicle:
2005 Outback XT
White on grey

Default

Yeah, my factory one has clips, but the floormat actually ripped it out of the carpet over time...
rougeben83 is offline   Reply With Quote
Old 01-19-2007, 10:30 PM   #11
ivwarrior
Scooby Specialist
 
Member#: 100610
Join Date: Nov 2005
Location: Lewistown, PA
Vehicle:
2002 WRX
MBP

Default

Zip-tie it to the seat base? That's the solution I've been considering, but have been too lazy to actually get around to trying.
ivwarrior is offline   Reply With Quote
Old 01-19-2007, 10:35 PM   #12
jedz123
Scooby Newbie
 
Member#: 67083
Join Date: Jul 2004
Chapter/Region: NESIC
Location: Northfield, VT
Vehicle:
1993 Impreza L HB
EJ25D swap, 5-speed FWD

Default

did you check the throttle cable? ....If there is one. Your cable might be getting snared on something near the throttle body. I would pop the hood and have a look see. This has happened to me before but by the time I got to it the car had been bouncing of the rev-limiter(6.5KRPM) for about 30seconds. She still is running fine, ended up my cable was snagged....
hope that helps
Good Luck!
jedz123 is offline   Reply With Quote
Old 01-19-2007, 10:38 PM   #13
jedz123
Scooby Newbie
 
Member#: 67083
Join Date: Jul 2004
Chapter/Region: NESIC
Location: Northfield, VT
Vehicle:
1993 Impreza L HB
EJ25D swap, 5-speed FWD

Default

I just go without floor mats all together....I hate em'
jedz123 is offline   Reply With Quote
Old 01-20-2007, 01:08 AM   #14
rougeben83
Scooby Guru
 
Member#: 115154
Join Date: May 2006
Chapter/Region: MWSOC
Location: NYC
Vehicle:
2005 Outback XT
White on grey

Default

Quote:
Originally Posted by jedz123 View Post
did you check the throttle cable? ....If there is one. Your cable might be getting snared on something near the throttle body. I would pop the hood and have a look see. This has happened to me before but by the time I got to it the car had been bouncing of the rev-limiter(6.5KRPM) for about 30seconds. She still is running fine, ended up my cable was snagged....
hope that helps
Good Luck!

Yup, I checked that too...first thing I checked. It's not snagging anything...it moves pretty freely. I put some lube on the exposed part of the cable, just in case...hmm I guess it was the carpet.

We'll see when I drive 40 miles for an event I have to go tomorrow :crossesfingers:
rougeben83 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS:STi complete gas pedal & clutch/brake pedal covers. joe r Interior/Dressup/Audio & Security 11 12-27-2009 08:08 PM
04 manual shift boot piece. Gas pedal, auto brake pedal and auto shifter assembly scOOtNsOOby Interior/Dressup/Audio & Security 0 10-12-2009 10:05 AM
Gas Pedal stuck ryanv11 Newbies & FAQs 2 06-13-2009 08:21 AM
CT: 07 STi hydro pedal box and DBW gas pedal jamesfacts Interior/Dressup/Audio & Security 16 02-25-2008 02:43 PM
Anybody make a gas pedal (heel/toe friendly) that matches our oe pedals? BIGSKYWRX Interior & Exterior Modification 12 09-09-2003 03:09 PM


All times are GMT -4. The time now is 12:17 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.