Welcome to the North American Subaru Impreza Owners Club Wednesday April 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-18-2007, 04:28 PM   #1
Chapel
Scooby Specialist
 
Member#: 3496
Join Date: Jan 2001
Chapter/Region: NESIC
Location: Salem, MA
Vehicle:
1995 Roadmaster
Beige

Default 04 Outback 2.5L. Cruise Control cuts out randomly

Cruise will work for a number of miles then cuts out. You can hit 'set' again to turn it back on, will work for another number of miles then cut out again.
Any idea?
I noticed there was a recall on cruise control for some H6 Powered Legacy and 02-04 Imprezas, but no word on the 2.5L Legacys or Outbacks. Plus, this didn't stay true to the actual problem described in the recall.
* Registered users of the site do not see these ads.
Chapel is offline   Reply With Quote
Old 01-18-2007, 04:48 PM   #2
rougeben83
Scooby Guru
 
Member#: 115154
Join Date: May 2006
Chapter/Region: MWSOC
Location: NYC
Vehicle:
2003 Legacy L Turbo
silver

Default

You can check to see if you're getting a leak in the vacuum line going to the CC module. The module is on the right passenger side strut tower, sticks out towards the engine (black box about the size of your fist with a black line coming out of it). Either that or the module itself is going bad, or the switch in the dash.
rougeben83 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
97 outback 2.5L...power adders? slaytalera Normally Aspirated Powertrain 10 04-14-2008 04:33 AM
Should the Outback 2.5L Turbo Engine belongs to here too?? SuperTurbo Factory 2.5L Turbo Powertrain 1 06-27-2007 10:27 PM
Radio cutting out randomly vsboxerboy Car Audio, Video & Security 6 05-10-2004 12:27 PM
2004 Legacy/Outback 2.5L Power Falls to 160hp in Some States Jon [in CT] News & Rumors 6 09-06-2003 07:33 PM
Outback 2.5L car_freak85 Interior & Exterior Modification 0 07-20-2002 06:04 PM


All times are GMT -4. The time now is 09:49 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.