Welcome to the North American Subaru Impreza Owners Club Wednesday September 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
South West Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > South West Impreza Club Forum -- SWIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-18-2007, 04:16 PM   #1
02REX4LIFE
Scooby Specialist
 
Member#: 98865
Join Date: Oct 2005
Chapter/Region: SWIC
Location: Surprise, Arizona
Vehicle:
2006 Legacy 2.5i
"Now its 06LEGGY4LIFE"

Question Anyone do this mod?

http://www.scoobymods.com/forums/showthread.php?t=1564

If so, what has been the outcome?

If not, what do you think about it?
* Registered users of the site do not see these ads.
02REX4LIFE is offline   Reply With Quote
Old 01-18-2007, 04:54 PM   #2
kastle
Frank Army
 
Member#: 1457
Join Date: May 2000
Chapter/Region: SWIC
Location: Phoenix, AZ
Vehicle:
1999 Outback Sport
Steel Blue Mica

Default

I've done it on both my WRX & FXT ... it's kinda neat since it makes a small difference, maybe a couple hundred rpm's and like 1psi. Not bad for next to no work.
kastle is offline   Reply With Quote
Old 01-18-2007, 04:58 PM   #3
02REX4LIFE
Scooby Specialist
 
Member#: 98865
Join Date: Oct 2005
Chapter/Region: SWIC
Location: Surprise, Arizona
Vehicle:
2006 Legacy 2.5i
"Now its 06LEGGY4LIFE"

Default

Quote:
Originally Posted by kastle View Post
I've done it on both my WRX & FXT ... it's kinda neat since it makes a small difference, maybe a couple hundred rpm's and like 1psi. Not bad for next to no work.
did u tune for it?
02REX4LIFE is offline   Reply With Quote
Old 01-18-2007, 05:05 PM   #4
racingfish
Scooby Guru
 
Member#: 60976
Join Date: May 2004
Chapter/Region: SWIC
Location: Goodyear
Vehicle:
1969 LGT
FATURBO

Default

what mod is it i cant see it....
racingfish is offline   Reply With Quote
Old 01-18-2007, 05:09 PM   #5
02REX4LIFE
Scooby Specialist
 
Member#: 98865
Join Date: Oct 2005
Chapter/Region: SWIC
Location: Surprise, Arizona
Vehicle:
2006 Legacy 2.5i
"Now its 06LEGGY4LIFE"

Default

Quote:
Originally Posted by racingfish View Post
what mod is it i cant see it....
u basically replace the coupling that connects ur factory boost solenoid vacuum hose to the "T" next to ur turbo with a bigger, and less restrictive 3/16" coupling.
02REX4LIFE is offline   Reply With Quote
Old 01-18-2007, 05:50 PM   #6
racingfish
Scooby Guru
 
Member#: 60976
Join Date: May 2004
Chapter/Region: SWIC
Location: Goodyear
Vehicle:
1969 LGT
FATURBO

Default

OHHH i did that in 2003... personally i couldnt really tell the diff. mine came with two of those "T" things... i gave the other to my cousin who used it in his 2004 for a day... he said that his car wasnt running right so he took it out.
racingfish is offline   Reply With Quote
Old 01-18-2007, 06:00 PM   #7
Lazaride
Scooby Specialist
 
Member#: 90336
Join Date: Jul 2005
Chapter/Region: SWIC
Location: AZ
Vehicle:
2004 Forester

Subaru Stars

I have not done it but considered it a while back - after researching I decided it was not worth it for me - but if you are trying to get every bit of edge then it may be worth it for you, check this thread out - there is quite a bit out there about it but nothing real conclusive to me - http://forums.nasioc.com/forums/show...=fitting+boost
Lazaride is offline   Reply With Quote
Old 01-18-2007, 06:17 PM   #8
WgnWheel
Scooby Specialist
 
Member#: 63605
Join Date: Jun 2004
Chapter/Region: SWIC
Location: Moms...yours
Vehicle:
04 Wrx Wgn TimeAtk
10 Golf TDI, 08 Stang GT

Default

i did it way back when...it did nothing.
WgnWheel is offline   Reply With Quote
Old 01-18-2007, 06:34 PM   #9
racingfish
Scooby Guru
 
Member#: 60976
Join Date: May 2004
Chapter/Region: SWIC
Location: Goodyear
Vehicle:
1969 LGT
FATURBO

Default

my cousin said he was detonating with it in.
racingfish is offline   Reply With Quote
Old 01-19-2007, 10:40 AM   #10
02REX4LIFE
Scooby Specialist
 
Member#: 98865
Join Date: Oct 2005
Chapter/Region: SWIC
Location: Surprise, Arizona
Vehicle:
2006 Legacy 2.5i
"Now its 06LEGGY4LIFE"

Default

so i decided i was gonna do it and see wut the hype was all about! my car ran amazing for about the first two pulls in everygear and now it runs like SH**. boost spike! boost Fluctuation! I would NOT recommend this mod at all! and on scooobymods it says nothing about this problem! so i replaced it back with the other coupling and it still runs like crap! boost spike and boost fluctuation! now im lost on what to do! im guessing that the computer picked up that it was changed and then started to run like crap! so im hoping that the comp will pick up that i changed it back and start running better!

im gonna try to change the FBC out for a newer less used but functional FBC and see if that works!

Crossin My Fingers!
02REX4LIFE is offline   Reply With Quote
Old 01-19-2007, 10:42 AM   #11
02REX4LIFE
Scooby Specialist
 
Member#: 98865
Join Date: Oct 2005
Chapter/Region: SWIC
Location: Surprise, Arizona
Vehicle:
2006 Legacy 2.5i
"Now its 06LEGGY4LIFE"

Default

Quote:
Originally Posted by racingfish View Post
OHHH i did that in 2003... personally i couldnt really tell the diff. mine came with two of those "T" things... i gave the other to my cousin who used it in his 2004 for a day... he said that his car wasnt running right so he took it out.
its not the "T" thing tho. its the coupling before it that connects one of the hoses to the FBC hose.
But i didnt think of changing the "T". think that will help my prob at all or no?
02REX4LIFE is offline   Reply With Quote
Old 01-19-2007, 11:22 AM   #12
racingfish
Scooby Guru
 
Member#: 60976
Join Date: May 2004
Chapter/Region: SWIC
Location: Goodyear
Vehicle:
1969 LGT
FATURBO

Default

MAh bad i didnt mean the T thing... i ment what u were talkin bout.
racingfish is offline   Reply With Quote
Old 01-20-2007, 02:53 AM   #13
YOitsDUCE
Scooby Specialist
 
Member#: 116120
Join Date: May 2006
Chapter/Region: SWIC
Location: Az
Vehicle:
2006 Subaru WRX STI
WRB

Default

i just did it.. =] feels great
YOitsDUCE is offline   Reply With Quote
Old 01-20-2007, 10:47 AM   #14
superblkwrx
Scooby Specialist
 
Member#: 129395
Join Date: Oct 2006
Chapter/Region: SWIC
Location: Peoria, AZ
Vehicle:
2006 OBPWRX VF39 E85
342WHP 375WTQ 17PSI SRP

Default

Man check your vacume lines and look for something you may have accidently disconnected something while doing this. make sure when you removed the tee from the lines that nothing ripped or anything. This sounds like a vacume leak to me.

Quote:
Originally Posted by 02REX4LIFE View Post
so i decided i was gonna do it and see wut the hype was all about! my car ran amazing for about the first two pulls in everygear and now it runs like SH**. boost spike! boost Fluctuation! I would NOT recommend this mod at all! and on scooobymods it says nothing about this problem! so i replaced it back with the other coupling and it still runs like crap! boost spike and boost fluctuation! now im lost on what to do! im guessing that the computer picked up that it was changed and then started to run like crap! so im hoping that the comp will pick up that i changed it back and start running better!

im gonna try to change the FBC out for a newer less used but functional FBC and see if that works!

Crossin My Fingers!
superblkwrx is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
New Mod!! Never seen anyone do this before... Admission_Regret Interior & Exterior Modification 291 05-19-2012 10:03 PM
Anyone in the PDX area do this mod yet? wrxSTIcy North West Impreza Club Forum -- NWIC 33 10-16-2009 11:41 AM
Anyone do resistor mod & can you help? 4eatFp68 North West Impreza Club Forum -- NWIC 8 08-02-2009 04:29 PM
Anyone do this mod? 02REX4LIFE Factory 2.0L Turbo Powertrain 18 01-18-2007 05:47 PM


All times are GMT -4. The time now is 10:14 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.