Welcome to the North American Subaru Impreza Owners Club Friday July 11, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-18-2007, 11:17 PM   #1
roccrew585
Scooby Specialist
 
Member#: 91840
Join Date: Jul 2005
Default need help with cel number P1518 = starter switch circuit low input

i have these cel reading below.. can someone tell me what causing it and how to fix it.. thanks..


P0137 = 0-2 sensor circuit low voltage.
P0138 = 0-2 sensor circuit high voltage.
P0317 = rough road hardware not present
P0502 = Vehicle speed sensor circuit low input
P0503 = vehicle speed sensor intermittent/ erratic/ HIgh
P0852 = Neutral switch input circuit high
P1152 = 0-2 sensor circuit range/ performance (low)
P1153 = 0-2 sensor circuit range/ performance (high)
P1518 = starter switch circuit low input
* Registered users of the site do not see these ads.
roccrew585 is offline   Reply With Quote
Old 01-18-2007, 11:33 PM   #2
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

Quote:
Originally Posted by roccrew585 View Post
i have these cel reading below.. can someone tell me what causing it and how to fix it.. thanks..


P0137 = 0-2 sensor circuit low voltage.
P0138 = 0-2 sensor circuit high voltage.
P0317 = rough road hardware not present
P0502 = Vehicle speed sensor circuit low input
P0503 = vehicle speed sensor intermittent/ erratic/ HIgh
P0852 = Neutral switch input circuit high
P1152 = 0-2 sensor circuit range/ performance (low)
P1153 = 0-2 sensor circuit range/ performance (high)
P1518 = starter switch circuit low input


....welll.......for your 87 Yugo that's just fine....no problems at all....

...what kind of crap did ya try to install on what kind and year of car????

jesus christ.....this is MOST annoying......make a damned thread and don't even list the god damned car
Uncle Scotty is offline   Reply With Quote
Old 01-18-2007, 11:37 PM   #3
roccrew585
Scooby Specialist
 
Member#: 91840
Join Date: Jul 2005
Default

Quote:
Originally Posted by Uncle Scotty View Post
....welll.......for your 87 Yugo that's just fine....no problems at all....

...what kind of crap did ya try to install on what kind and year of car????

jesus christ.....this is MOST annoying......make a damned thread and don't even list the god damned car
Sorry i have an 04 STI with these mods listed below.

- HKS Hi-Power Exhaust - FP Green 3 inch inlet turbo
- HKS up-pipe - Walbro 255 fuel pump
- HKS Down-pipe - Sti 816cc (modification)
- HKS Ssqv bov - Perrin Oil Catch Can
- Turboxs FMIC - Apexi AVR boost controller
- Turboxs Utec - 3" agency inlet pipe
- Aem Short air intake - Hks header
- TGV delete
roccrew585 is offline   Reply With Quote
Old 01-19-2007, 12:13 AM   #4
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

Quote:
Originally Posted by roccrew585 View Post
Sorry i have an 04 STI with these mods listed below.

- HKS Hi-Power Exhaust - FP Green 3 inch inlet turbo
- HKS up-pipe - Walbro 255 fuel pump
- HKS Down-pipe - Sti 816cc (modification)
- HKS Ssqv bov - Perrin Oil Catch Can
- Turboxs FMIC - Apexi AVR boost controller
- Turboxs Utec - 3" agency inlet pipe
- Aem Short air intake - Hks header
- TGV delete
Uncle Scotty is offline   Reply With Quote
Old 04-11-2007, 11:47 AM   #5
secretpickle
Scooby Newbie
 
Member#: 145954
Join Date: Apr 2007
Default

I have an '06 WRX with similar mods. Having the same problem.

Headers/Uppipe/TBE/BOV/intake...

I have these codes:

p1152 - Front O2 Sensor Circuit Range / Performance (low)
p1153 - Front O2 Sensor Circuit Range / Performance (high)
p0852 - Neutral Switch input circuit high
p1518 - Starter Switch Circuit low input


I'm assuming something's wrong w/the wiring but I just don't know how to even start diagnosing it.

MAtt
secretpickle is offline   Reply With Quote
Old 03-30-2010, 08:43 PM   #6
wphill3
Scooby Newbie
 
Member#: 206733
Join Date: Mar 2009
Location: Baton Rouge, LA
Vehicle:
2007 STI
Metalic Gray

Default

I am having a similar issue. Can anyone help please?

I have a 07 sti with these codes (Only an spt intake mod done over 1.5 years ago)

P1518
p0483
p2441

Thanks,

Will
wphill3 is offline   Reply With Quote
Old 05-20-2010, 12:25 PM   #7
fzanetti
Scooby Newbie
 
Member#: 87418
Join Date: May 2005
Chapter/Region: NESIC
Location: Boston, MA
Vehicle:
05 05 Legacy 2.5GT
Garnet Red Pearl

Default

Quote:
Originally Posted by wphill3 View Post
I am having a similar issue. Can anyone help please?

I have a 07 sti with these codes (Only an spt intake mod done over 1.5 years ago)

P1518
p0483
p2441

Thanks,

Will
P1518 - Either the ignition or starter may be going...

Did you try to remove the negative cable from the battery and see if they go away?


Flavio Zanetti
Boston, MA
fzanetti is offline   Reply With Quote
Old 09-30-2010, 07:52 AM   #8
fai
Scooby Newbie
 
Member#: 213854
Join Date: Jun 2009
Exclamation Solution

Quote:
Originally Posted by roccrew585 View Post
i have these cel reading below.. can someone tell me what causing it and how to fix it.. thanks..


P0137 = 0-2 sensor circuit low voltage.
P0138 = 0-2 sensor circuit high voltage.
P0317 = rough road hardware not present
P0502 = Vehicle speed sensor circuit low input
P0503 = vehicle speed sensor intermittent/ erratic/ HIgh
P0852 = Neutral switch input circuit high
P1152 = 0-2 sensor circuit range/ performance (low)
P1153 = 0-2 sensor circuit range/ performance (high)
P1518 = starter switch circuit low input
This must be put in FAQ!

1. From driver seat look under panel. There must be two small green connectors. They are plugged together.
2. Unplug them.
3. Enjoy =)

-- These connectors are for diagnostic purposes and normally must not be connected.
fai is offline   Reply With Quote
Old 08-02-2011, 10:23 PM   #9
RedSpyder
Scooby Newbie
 
Member#: 220714
Join Date: Aug 2009
Default

Quote:
Originally Posted by fai View Post
This must be put in FAQ!

1. From driver seat look under panel. There must be two small green connectors. They are plugged together.
2. Unplug them.
3. Enjoy =)

-- These connectors are for diagnostic purposes and normally must not be connected.


YOU SIR HAVE SAVED MY LIFE! IVe had those codes for over a YEAR NOW!!!! (Being a busy man myself I always said. Ill fix em later... )

DUUUDE I WISH I COULD KISS YOU RIGHT NOW!!!
RedSpyder is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
P1518 Starter switch circuit low input tmarcel Electrical & Lighting 4 10-11-2007 12:48 AM
****need Help With Cel Codes-please Help************** stito Subaru Conversions 4 07-29-2007 04:55 AM
P1518 Starter switch circuit low input - ***? maddhatteroo7 Service & Maintenance 4 12-22-2005 02:17 AM
Help with P0103 Mass air flow sensor circuit high input kenshiro Engine Management & Tuning 0 08-03-2003 02:15 PM
Need Help with Part Numbers and Getting Parts... Xscreamer Normally Aspirated Powertrain 1 02-26-2001 10:48 AM


All times are GMT -4. The time now is 03:52 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.